xmodmap

Forum rules
Before you post please read this

xmodmap

Postby SJNY on Wed Nov 14, 2012 1:42 pm

Hello,

I bought a KVM switch which is hooked to windows PC and a Linux Mint 13 KDE. The hot key scroll lock + scroll lock works fine on windows but not on Linux. One solution that I found was to key in Ctrl+Alt+F1 to switch to command line and then Scroll lock + Scroll lock to change to Windows PC. When back on Linux box key in CTRL+F7 to go back to GUI. This works fine however adds an extra step. Another solution is to add and entry to xmodmap However, when I execute the command I keep on getting the output below.

# xmodmap -e "add mod3 = Scroll_Lock"
No protocol specified
No protocol specified
xmodmap: unable to open display ':0'

At this point I am stuck. I searched the web but could not figure out why I am getting the above output. Any help will be greatly appreciated.
SJNY
Level 1
Level 1
 
Posts: 9
Joined: Wed Nov 07, 2012 8:15 pm

Linux Mint is funded by ads and donations.
 

Re: xmodmap

Postby LindseyD. on Fri Nov 23, 2012 2:24 pm

Trying to solve a completely different problem, I discovered there's a bug (at least one, but I suspect more) in udev that causes, among other things, that "no protocol specified" message. I make no claims to understand any of it :(

I don't know if you've seen that in your travels around the web, but if not, maybe try adding udev to your search terms. I wish you much better luck than I've had solving the problem.
Mint15 KDE
LindseyD.
Level 4
Level 4
 
Posts: 259
Joined: Fri Mar 26, 2010 12:35 pm


Return to KDE

Who is online

Users browsing this forum: No registered users and 6 guests