[SOLVED] Can't log in, shared library libtinfo.so.5

Forums for the KDE Edition
Forum rules
Before you post please read this

[SOLVED] Can't log in, shared library libtinfo.so.5

Postby jude08 on Mon May 07, 2012 12:41 pm

I've been using Mint KDE for months and it's been excellent, no problems at all. But today I started up my laptop and found that when I try to log in, the screen flashes black and I get the log in screen again. If I deliberately use the wrong password, it tells me so without the screen flashing black. The black screen thing only happens when I use a correct log in.

So I tried switching to console login. When I use a correct log in there I get, '-bash.... error loading shared library libtinfo.so.5'. And then it asks me to log in again :roll: Even if I start up in recovery mode and use root login I get the same problem.

Is there a way with a live USB that I can fix whatever is causing this? Or maybe I can edit something in the grub option so I can log in as root? If I can just get past the login screen that would be a good start :)

Thanks for your help
Last edited by jude08 on Wed May 09, 2012 4:38 am, edited 1 time in total.
jude08
Level 1
Level 1
 
Posts: 2
Joined: Mon May 07, 2012 12:34 pm

Linux Mint is funded by ads and donations.
 

Re: Can't log in, shared library libtinfo.so.5

Postby jude08 on Tue May 08, 2012 4:12 am

I did a reinstall from a usb stick without formatting and now I can log in, all my settings and files are still there :)

Only problems are no wifi and no touchpad but could have been worse.

[edit] wifi and touchpad fixed with apt-get update and apt-get dist-upgrade :)
jude08
Level 1
Level 1
 
Posts: 2
Joined: Mon May 07, 2012 12:34 pm


Return to KDE

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 11 guests