sound problem

Forum rules
Before you post please read this

sound problem

Postby xoutdeyes on Sun Mar 09, 2008 4:37 am

i am very new to linux. i just installed the mint kde ce and i got everything to work except for the sound.
i'm using a compaq presario b1819tu

i think i have tried doing the solutions in this and other forums but none has worked.
but atleast ive got the dedicated volume buttons on the notebook to work now. but im stil not getting anysound even at 100% volume and all the output levels in kmix are full.

any detailed help would be very nice. everything in linux except for the eyecandy is all very foreign to me for the moment.
xoutdeyes
Level 1
Level 1
 
Posts: 4
Joined: Sun Mar 09, 2008 4:29 am

Linux Mint is funded by ads and donations.
 

Re: sound problem

Postby 67GTA on Sun Mar 09, 2008 11:41 am

Have you tried changing the master channel with the kicker(taskbar) icon? There is a known bug with Mint KDE and Kmix forgetting settings until it is reset after installation.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: sound problem

Postby xoutdeyes on Sun Mar 09, 2008 3:21 pm

what do you mean?..
master channel is set to master and kmix output channels are on full level.

i just noticed something. it turns out there is some sound coming out when i connect the notebook with desktop speakers. very low sound even when its set in full volume.
xoutdeyes
Level 1
Level 1
 
Posts: 4
Joined: Sun Mar 09, 2008 4:29 am

Re: sound problem

Postby 67GTA on Sun Mar 09, 2008 3:25 pm

Right click on the kicker kmix icon. Select "Select Master Channel". What channel is selected? Try changing the channel to PCM or Front and see what happens.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: sound problem

Postby xoutdeyes on Mon Mar 10, 2008 8:16 pm

yeah ive tried that. no difference
xoutdeyes
Level 1
Level 1
 
Posts: 4
Joined: Sun Mar 09, 2008 4:29 am

Re: sound problem

Postby ed@Mint on Wed Mar 12, 2008 3:47 pm

Hi,

still got that sound problem ?
I had it too... and now it's solved

2 important resources :
http://ubuntuforums.org/showthread.php?t=205449
http://ubuntuforums.org/showthread.php?t=569082

At the beginning, the command aplay -l told me that there were no sound card installed.
basically, what i did is this :
Code: Select all
$ sudo apt-get install module-assistant
$ sudo m-a update
$ sudo m-a prepare
$ sudo m-a a-i alsa


Then it worked.
However, after the following reboot, amarok played the medias but i eventually got no sound out of the speakers.
I had to unmute the front channel in alsamixer (command is : alsamixer), select the channel and press 'm' to mute/unmute
And then store the alsa settings for it to reload them on next reboot :
Code: Select all
sudo alsactl store 0


Hope this helps...
cu
In libro veritas

Now switched to : ArchLinux

New users, read the Linux Mint User Guide | Problem ? See the Wiki first | Check out the Software Portal | Join the IRC channel : #linuxmint @ irc.spotchat.org
User avatar
ed@Mint
Level 5
Level 5
 
Posts: 565
Joined: Sun Mar 09, 2008 6:03 pm
Location: Liege, Belgium

Re: sound problem

Postby xoutdeyes on Thu Mar 13, 2008 1:06 am

thanks. but im still not getting anything.

bytheway, when i do the aplay -l i get :

**** List of PLAYBACK Hardware Devices ****
card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0


is getting 2 devices normal?
xoutdeyes
Level 1
Level 1
 
Posts: 4
Joined: Sun Mar 09, 2008 4:29 am

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 2 guests