xorg.conf and fonts

Forum rules
Before you post please read this

xorg.conf and fonts

Postby helterskelter on Thu Mar 13, 2008 3:41 pm

I am trying mint for the first time,so far so good,looks nice.

I have the nvidia drivers installed via Envy,it set the screen up nicely at 1680 x 1050. However something has happened to the fonts appearance.
Looking at xorg.conf I notice there is no entry regarding fonts,in fact it seems to be a very minimal xorg.conf in general,although it has included code for a wacom tablet that I do not possess?

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Oct 4 10:33:51 PDT 2007

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "L20W"
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV34 [GeForce FX 5200]"
Monitor "L20W"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "1680x1680" "1680x1050" "1440x1440" "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Have I missed a set up stage some where?


eddie
helterskelter
Level 2
Level 2
 
Posts: 67
Joined: Mon Mar 10, 2008 1:53 pm
Location: Cardiff UK.

Linux Mint is funded by ads and donations.
 

Re: xorg.conf and fonts

Postby Husse on Sat Mar 15, 2008 3:11 pm

This is a standard xorg.conf
I don't think Debian/Ubuntu(/Mint) has included fonts in xorg.conf (at least lately)
Right now I'm in gnome so I don't find the correct "path" but in Appearances there should be a Fonts tab with some settings
I'll try to remember this topic when I log in to KDE next time
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: xorg.conf and fonts

Postby deadguy on Sat Mar 15, 2008 3:31 pm

Husse wrote:This is a standard xorg.conf
I don't think Debian/Ubuntu(/Mint) has included fonts in xorg.conf (at least lately)
Right now I'm in gnome so I don't find the correct "path" but in Appearances there should be a Fonts tab with some settings
I'll try to remember this topic when I log in to KDE next time




it's in "system settings/Appearance & Themes/Fonts".
User avatar
deadguy
Level 5
Level 5
 
Posts: 710
Joined: Wed Aug 15, 2007 9:41 pm
Location: Illinois USA

Re: xorg.conf and fonts

Postby helterskelter on Mon Mar 17, 2008 1:18 am

Sorted! After a bit of digging around, I have added the following to xorg.conf

Code: Select all
Section "Files"
   Fontpath   "/usr/share/fonts/X11/misc"
   Fontpath   "/usr/share/fonts/X11/100dpi:unscaled"
   Fontpath   "/usr/share/fonts/X11/75dpi:unscaled"
   Fontpath   "/usr/share/fonts/X11/misc:unscaled"
   Fontpath   "/usr/share/fonts/truetype/freefont"
   Fontpath   "/usr/share/fonts/truetype/arphic"
   Fontpath   "/usr/share/fonts/truetype/ttf-bitstream-vera"
   Fontpath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection


And

Code: Select all
Section "Monitor"
   Identifier   "L20W"
   Option      "DPMS"
   Horizsync   31-83
   Vertrefresh   56-76
   DisplaySize   444  277  # This bit = (1680/96)*25.4     (1050/96)*25.4
EndSection



All signs of 'Dottiness' have now gone,fonts nice and smooth.

I should point out that the 'DisplaySize' bit was the clincher,whether or not it would work without the font file pointers I have not tried.

eddie
helterskelter
Level 2
Level 2
 
Posts: 67
Joined: Mon Mar 10, 2008 1:53 pm
Location: Cardiff UK.


Return to KDE

Who is online

Users browsing this forum: No registered users and 4 guests