[SOLVED] Mint 12 KDE Update Manager wants to remove KDE

Forum rules
Before you post please read this

[SOLVED] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Thu Jul 19, 2012 7:06 pm

Today I received a notice that I have 103 updates available. (No I don't check very often)
I look them over and it's the usual stuff, like firefox and thunderbird updates and gpg and kdepim. All Level 3 updates.

I click install updates and I get a notice that additional changes will be made, and my jaw hits the floor that It wants to remove 36 of my packages
Including the following:

apturl-kde
digikam
gdebi-kde
jockey-kde
kde-config-touchpad
kde-window-manager
kde-workspace
kde-workspace-bin
kde-plasma-addons
kgpg
kscreensaver


And the list goes on from there. Obviously I canceled the request.
The question is,what do I do now? Sit and stare at the updates I can never get?

--Jim
Last edited by RJim on Mon Jul 23, 2012 11:45 pm, edited 1 time in total.
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Linux Mint is funded by ads and donations.
 

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby tdockery97 on Thu Jul 19, 2012 7:28 pm

You may want to look at the whole scenario again. Perhaps it is replacing the older KDE with KDE 4.8.4?
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
Registered Linux User #520972
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4844
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Thu Jul 19, 2012 7:33 pm

Is there a way I can tell for certain without the risk of breaking my system?
Here's a screen shot.
Attachments
KDE Update.jpeg
kde-update-details
KDE Update.jpeg (68.33 KiB) Viewed 1613 times
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby Stel on Thu Jul 19, 2012 8:20 pm

I have the same problem with Mint Maya KDE. My solution is to start Synaptic, then click on "status" at the lower left corner, select "installed (upgradable)" and mark everything there for upgrade. In this case, i do not get any messages that any packets will be removed. ( careful with the x-org updates if you are using propriety graphics card drivers)
Stel
Level 1
Level 1
 
Posts: 16
Joined: Wed Jul 20, 2011 6:30 am

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Thu Jul 19, 2012 9:12 pm

@Stel
So I am in synaptic now; you are saying that I should upgrade everything in synaptic except for xserver-xorg packages, correct? (I am using nvidia proprietary drivers)
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Fri Jul 20, 2012 12:35 am

Okay so I did Stel's suggestion, and it seems to have worked, but I do not feel I should mark this as solved because it is not really a solution, but a work-around to the problem.

It would seem that both Stel and myself have the same problem with the Update Manager wanting to remove things that do not need removing. If someone with more experience has a solution, to our problem, posting it would be much appreciated.

--Jim
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby Stel on Fri Jul 20, 2012 7:19 am

Sorry for the late reply, but yes, it is not a solution, it is a workaround. It happens to me every time there is a big update of KDE packages.
Stel
Level 1
Level 1
 
Posts: 16
Joined: Wed Jul 20, 2011 6:30 am

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby zerozero on Fri Jul 20, 2012 11:56 am

jim,
unfortunately that screenshot is not telling us much (and that is one of the limitations of mintupdate: with complex updates involving upgrades+additions+removals the real information given to the user is short).

as tdockery was suggesting above "look at the whole scenario" and there's only one way to do that:
- open a terminal and run:
Code: Select all
apt update && apt upgrade
now look closely at the end of the output, you have there all the history.
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Fri Jul 20, 2012 12:08 pm

@zerozero Thanks for that bit of info, I will remember that for the future... although because I already did what Stel suggested, the only updates that those commands showed were for the xorg packages which I did not upgrade from Synaptic.


However now I have a new issue related to the upgrades: Now every time I log-in, KResource Migration Tool tries to migrate data from the KDE Address Book (which I never use) and Akonadi.

The window stays there for 15 seconds and then self-closes every time. And it always tries to migrate the same things. It is rather annoying and I can't find any way to prevent it. I've been looking for some place to change the Apps started at login, to see if maybe the Migration Tool is in there somewhere... but somehow I feel as though I am thinking too much like a Windows user still and perhaps Linux has no such place. :lol:

EDIT: Okay I did find the KDE Control Panel section for Autostart and Service Manager... No Migration Tool is to be found there. I did however disable the irritating Nepomuk Search... all it ever did was give errors every three minutes anyway.

--Jim
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby zerozero on Fri Jul 20, 2012 12:19 pm

Jim, that should only happen once, see this http://linux.derkeiler.com/Mailing-List ... 00258.html (might help)
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby Stel on Fri Jul 20, 2012 1:25 pm

zerozero wrote:jim,
unfortunately that screenshot is not telling us much (and that is one of the limitations of mintupdate: with complex updates involving upgrades+additions+removals the real information given to the user is short).

as tdockery was suggesting above "look at the whole scenario" and there's only one way to do that:
- open a terminal and run:
Code: Select all
apt update && apt upgrade
now look closely at the end of the output, you have there all the history.


So, is it possible that mintupdate would actually update the system correctly and the pre-installation report was inaccurate?

When i first installed LM 13 KDE, there was an update from KDE 4.8.3 to 4.8.4. Mintupdate reported that 8 packages would be removed and, if i remember correctly, about 16 new ones would be installed (no connection with those to be removed). When i tried Synaptic, i got a pre-installation report that zero packages would be removed and only one new package would be installed. Same thing happened again in a recent KDE update.

Still, it is very unnerving to get the kind of pre-installation reports mintupdate provides before a major upgrade. Especially when it affects your main production PC. So, until this is clarified, i will stick with Synaptic.
Stel
Level 1
Level 1
 
Posts: 16
Joined: Wed Jul 20, 2011 6:30 am

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby zerozero on Fri Jul 20, 2012 4:28 pm

So, is it possible that mintupdate would actually update the system correctly and the pre-installation report was inaccurate?

Stel,
mintupdate and synaptic are just frontends for apt, so they should have the same behavior. they don't, it's true: first because according to the levels selected in MU the upgrade output varies (those levels have no influence in apt or in synaptic); secondly the informative windows are not very user-friendly (tho they at least now exist - after a long fight :lol: )
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby Stel on Fri Jul 20, 2012 5:02 pm

zerozero wrote:Stel,
mintupdate and synaptic are just frontends for apt, so they should have the same behavior. they don't, it's true: first because according to the levels selected in MU the upgrade output varies (those levels have no influence in apt or in synaptic); secondly the informative windows are not very user-friendly (tho they at least now exist - after a long fight :lol: )


Thank you for your answer :wink:

Now that i think about it, in synaptic i upgraded packages that mintupdate would classify as level 4. In mintupdate, i have all five levels visible, but only the first three ones enabled by default. Obviously, in major updates with mixed "level 1-2-3" and "level 4" updates (for mintupdate), upgrade scenarios are different, if you forget to enable all levels in mintupdate.

I will check next time to see if i made that mistake. ( because i do not really remember right now)
Stel
Level 1
Level 1
 
Posts: 16
Joined: Wed Jul 20, 2011 6:30 am

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Sat Jul 21, 2012 11:38 pm

@zerozero That link helped me to solve the problem by editing the config to disable the migration tool for my user account.

So before I mark this as solved, just to clarify:

Is MintUpdate just giving incorrect info... or would it actually have done the things that it listed and broken my system had I clicked OK?
Should I just use Synaptic all the time and Never use MintUpdate?

--Jim
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby zerozero on Sun Jul 22, 2012 4:09 pm

RJim wrote:Is MintUpdate just giving incorrect info... or would it actually have done the things that it listed and broken my system had I clicked OK?
Should I just use Synaptic all the time and Never use MintUpdate?

--Jim

Jim,
without testing both scenarios i can't answer that for sure;
MU is a mature tool (not perfect but where are those?) but updating/upgrading your system is a crucial task and you should only rely on tools you trust fully.
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Sun Jul 22, 2012 5:41 pm

@zerozero Well let me rephrase this way... Do you trust MintUpdate to do a proper job if you had seen the screenshot above on your system?
From your earlier post it sounds as though you know that something is wrong with the way it handles certain things... but I want to make sure I am understanding you properly on this.

Of course I know that no software is perfect, that is why I posted this topic in the first place -- because I could tell something was amiss.
Please understand that I am not bashing MintUpdate (or any of it) but I think in the light of my experience, and the seriousness of the task of updates and upgrades (as you pointed out), my question is completely justified.

--Jim
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby zerozero on Mon Jul 23, 2012 10:10 pm

Jim,
here it is: the test i wanted to do (but couldn't find the time before)
done with mint 13 maya kde liveDVD
1st part is the update with mintupdate
Image
similar screen to the one you saw with "disturbing" removals but after i hit apply and let all the upadtes install this is what is in history.log (note that there is not one removal in there)
mint@mint ~ $ cat /var/log/apt/history.log
Code: Select all
Start-Date: 2012-07-24  00:47:42
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 52428922 -o Synaptic::closeZvt=true --progress-str Please wait, this can take some time --finish-str Update is complete --set-selections-file /tmp/tmpPDzE0Z
Install: printer-driver-postscript-hp:amd64 (3.12.2-1ubuntu3.1, automatic)
Upgrade: libsmbclient:amd64 (3.6.3-2ubuntu2.1, 3.6.3-2ubuntu2.3), libpolkit-backend-1-0:amd64 (0.104-1, 0.104-1ubuntu1), libkresources4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), ksystemlog:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkrb5-3:amd64 (1.10+dfsg~beta1-2, 1.10+dfsg~beta1-2ubuntu0.1), libkprintutils4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libk5crypto3:amd64 (1.10+dfsg~beta1-2, 1.10+dfsg~beta1-2ubuntu0.1), apt-transport-https:amd64 (0.8.16~exp12ubuntu10, 0.8.16~exp12ubuntu10.2), libkldap4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libswscale2:amd64 (0.8.1-0ubuntu1, 0.8.3-0ubuntu0.12.04.1), kde-zeroconf:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kppp:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libktnef4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libokularcore1abi1:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), update-notifier-common:amd64 (0.119ubuntu8.1, 0.119ubuntu8.4), python-cupshelpers:amd64 (1.3.8+20120201-0ubuntu8, 1.3.8+20120201-0ubuntu8.1), libkonq5-templates:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libqt4-declarative:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libmtp9:amd64 (1.1.3-1, 1.1.3-1ubuntu0.1), libgutenprint2:amd64 (5.2.8~pre1-0ubuntu2, 5.2.8~pre1-0ubuntu2.1), freespacenotifier:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libavutil51:amd64 (0.8.1-0ubuntu1, 0.8.3-0ubuntu0.12.04.1), libkcalcore4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libv4l-0:amd64 (0.8.6-1ubuntu1, 0.8.6-1ubuntu2), libcupsppdc1:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libqt4-qt3support:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libkxmlrpcclient4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), kde-baseapps-bin:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), bind9-host:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), libcupsimage2:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libkholidays4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libsane-hpaio:amd64 (3.12.2-1ubuntu3, 3.12.2-1ubuntu3.1), libcupscgi1:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libknewstuff2-4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), kde-workspace-data:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libknewstuff3-4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libjpeg-turbo8:amd64 (1.1.90+svn733-0ubuntu4, 1.1.90+svn733-0ubuntu4.1), libcairo-gobject2:amd64 (1.10.2-6.1ubuntu2, 1.10.2-6.1ubuntu3), smbclient:amd64 (3.6.3-2ubuntu2.1, 3.6.3-2ubuntu2.3), libcupsdriver1:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), plasma-netbook:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkexiv2-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libnepomuksync4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkipi8:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkipi-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), qdbus:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libmtp-runtime:amd64 (1.1.3-1, 1.1.3-1ubuntu0.1), libkdeclarative5:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), pulseaudio-module-bluetooth:amd64 (1.1-0ubuntu15, 1.1-0ubuntu15.1), pulseaudio:amd64 (1.1-0ubuntu15, 1.1-0ubuntu15.1), dnsutils:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), libnepomukquery4a:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), gstreamer0.10-alsa:amd64 (0.10.36-1, 0.10.36-1ubuntu0.1), libplasma-geolocation-interface4:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libqt4-test:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), kde-workspace-bin:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libqt4-script:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libqt4-designer:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libkleo4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libqt4-network:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), openjdk-7-jre:amd64 (7~u3-2.1.1~pre1-1ubuntu2, 7~u3-2.1.1~pre1-1ubuntu3), libqt4-dbus:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libweather-ion6:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkonq-common:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), plasma-widget-kimpanel:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libnm-util2:amd64 (0.9.4.0-0ubuntu4, 0.9.4.0-0ubuntu4.1), gwenview:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), xserver-common:amd64 (1.11.4-0ubuntu10.2, 1.11.4-0ubuntu10.6), libthreadweaver4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), accountsservice:amd64 (0.6.15-2ubuntu9, 0.6.15-2ubuntu9.1), libmarblewidget13:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libgl1-mesa-dri:amd64 (8.0.2-0ubuntu3, 8.0.2-0ubuntu3.1), libkdecore5:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libnepomukutils4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libktexteditor4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), foomatic-filters:amd64 (4.0.15-0ubuntu1, 4.0.16-0ubuntu0.2), python-software-properties:amd64 (0.82.7-1linuxmint1, 0.82.7-1linuxmint2), cups-client:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libkmediaplayer4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libgl1-mesa-glx:amd64 (8.0.2-0ubuntu3, 8.0.2-0ubuntu3.1), plasma-scriptengine-python:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libpolkit-gobject-1-0:amd64 (0.104-1, 0.104-1ubuntu1), hplip:amd64 (3.12.2-1ubuntu3, 3.12.2-1ubuntu3.1), libakonadi-kmime4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libdns81:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), plasma-scriptengine-javascript:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), klipper:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), pulseaudio-module-x11:amd64 (1.1-0ubuntu15, 1.1-0ubuntu15.1), libwbclient0:amd64 (3.6.3-2ubuntu2.1, 3.6.3-2ubuntu2.3), libkrosscore4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), kaddressbook:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), xsettings-kde:amd64 (0.12.3-0ubuntu2, 0.12.3-0ubuntu2.1), libplasmaclock4abi3:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), kontact:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), kwalletmanager:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libcairo2:amd64 (1.10.2-6.1ubuntu2, 1.10.2-6.1ubuntu3), libgnutls26:amd64 (2.12.14-5ubuntu3, 2.12.14-5ubuntu3.1), printer-driver-gutenprint:amd64 (5.2.8~pre1-0ubuntu2, 5.2.8~pre1-0ubuntu2.1), libglapi-mesa:amd64 (8.0.2-0ubuntu3, 8.0.2-0ubuntu3.1), ksysguard:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), policykit-1:amd64 (0.104-1, 0.104-1ubuntu1), libapt-inst1.4:amd64 (0.8.16~exp12ubuntu10, 0.8.16~exp12ubuntu10.2), mysql-server-core-5.5:amd64 (5.5.22-0ubuntu1, 5.5.24-0ubuntu0.12.04.1), libkcddb4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkactivities-bin:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libmessagecore4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libeventviews4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libkwineffects1abi3:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), kdepim-kresources:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libkateinterfaces4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), shared-mime-info:amd64 (1.0-0ubuntu4, 1.0-0ubuntu4.1), libcalendarsupport4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libqt4-opengl:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), grub-pc:amd64 (1.99-21ubuntu3, 1.99-21ubuntu3.1), dolphin:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libglib2.0-0:amd64 (2.32.1-0ubuntu2, 2.32.3-0ubuntu1), libmysqlclient18:amd64 (5.5.22-0ubuntu1, 5.5.24-0ubuntu0.12.04.1), kmenuedit:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libv4lconvert0:amd64 (0.8.6-1ubuntu1, 0.8.6-1ubuntu2), libavcodec53:amd64 (0.8.1-0ubuntu1, 0.8.3-0ubuntu0.12.04.1), plasma-dataengines-addons:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libisccc80:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), libsyndication4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), khelpcenter4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkdcraw-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkmbox4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libaccountsservice0:amd64 (0.6.15-2ubuntu9, 0.6.15-2ubuntu9.1), libsolid4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), cups-ppdc:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), apt-utils:amd64 (0.8.16~exp12ubuntu10, 0.8.16~exp12ubuntu10.2), kdeaccessibility:amd64 (71~pre15ubuntu12.1, 71~pre15ubuntu12.3), libqt4-xmlpatterns:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libqt4-sql-sqlite:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libmessagecomposer4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libkontactinterface4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), update-manager-core:amd64 (0.156.14.4, 0.156.14.5), libnepomuk4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libkmanagesieve4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), xkb-data:amd64 (2.5-1ubuntu1, 2.5-1ubuntu1.3), konsole:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkdegames5a:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkcalutils4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), korganizer:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), samba-common:amd64 (3.6.3-2ubuntu2.1, 3.6.3-2ubuntu2.3), libmicroblog4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), akregator:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), python-aptdaemon:amd64 (0.43+bzr805-0ubuntu1, 0.43+bzr805-0ubuntu2), libqt4-help:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libkdnssd4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libksgrd4:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkparts4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), kamera:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), apt:amd64 (0.8.16~exp12ubuntu10, 0.8.16~exp12ubuntu10.2), ark:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), firefox:amd64 (12.0+build1-0ubuntu0.12.04.1, 14.0.1+build1-0ubuntu0.12.04.1), libkpgp4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libqgpgme1:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), kde-runtime-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kde-window-manager:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), cups-common:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), kde-window-manager-common:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), network-manager:amd64 (0.9.4.0-0ubuntu4, 0.9.4.0-0ubuntu4.1), libtaskmanager4abi3:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkabc4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libhpmud0:amd64 (3.12.2-1ubuntu3, 3.12.2-1ubuntu3.1), liblwres80:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), libcups2:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libkdepim4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), kdoctools:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libkactivities6:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libqtcore4:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libmailcommon4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libkdecorations4:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libnm-glib-vpn1:amd64 (0.9.4.0-0ubuntu4, 0.9.4.0-0ubuntu4.1), libkrb5support0:amd64 (1.10+dfsg~beta1-2, 1.10+dfsg~beta1-2ubuntu0.1), libgtk-3-0:amd64 (3.4.2-0ubuntu0.2, 3.4.2-0ubuntu0.4), printer-driver-ptouch:amd64 (1.3-3, 1.3-3ubuntu0.1), sudo:amd64 (1.8.3p1-1ubuntu3.2, 1.8.3p1-1ubuntu3.3), libincidenceeditorsng4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libksieve4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libnepomukdatamanagement4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), mysql-client-core-5.5:amd64 (5.5.22-0ubuntu1, 5.5.24-0ubuntu0.12.04.1), kde-baseapps-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), python-problem-report:amd64 (2.0.1-0ubuntu8, 2.0.1-0ubuntu11), libnm-glib4:amd64 (0.9.4.0-0ubuntu4, 0.9.4.0-0ubuntu4.1), plasma-widget-folderview:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kde-workspace:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), kdm:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkdepimdbusinterfaces4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), system-config-printer-udev:amd64 (1.3.8+20120201-0ubuntu8, 1.3.8+20120201-0ubuntu8.1), libpulse-mainloop-glib0:amd64 (1.1-0ubuntu15, 1.1-0ubuntu15.1), cron:amd64 (3.0pl1-120ubuntu3, 3.0pl1-120ubuntu4), libkidletime4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), katepart:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libgcrypt11:amd64 (1.5.0-3, 1.5.0-3ubuntu0.1), tasks-icons:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), ssl-cert:amd64 (1.0.28, 1.0.28ubuntu0.1), aptdaemon:amd64 (0.43+bzr805-0ubuntu1, 0.43+bzr805-0ubuntu2), libkunitconversion4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libgail-3-0:amd64 (3.4.2-0ubuntu0.2, 3.4.2-0ubuntu0.4), libxatracker1:amd64 (8.0.2-0ubuntu3, 8.0.2-0ubuntu3.1), libbind9-80:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), cups:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libpostproc52:amd64 (0.8.1-0ubuntu1, 0.8.3-0ubuntu0.12.04.1), libkcmutils4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libglade2-0:amd64 (2.6.4-1ubuntu1, 2.6.4-1ubuntu1.1), libkdgantt2:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libkcal4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), plasma-widgets-addons:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), knotes:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), libapt-pkg4.12:amd64 (0.8.16~exp12ubuntu10, 0.8.16~exp12ubuntu10.2), libkalarmcal2:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libqt4-sql:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libakonadi-calendar4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libkfile4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libkopete4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kdegames-card-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), firefox-locale-en:amd64 (12.0+build1-0ubuntu0.12.04.1, 14.0.1+build1-0ubuntu0.12.04.1), language-pack-kde-en:amd64 (12.04+20120508, 12.04+20120618), isc-dhcp-client:amd64 (4.1.ESV-R4-0ubuntu5, 4.1.ESV-R4-0ubuntu5.1), libqt4-svg:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), samba:amd64 (3.6.3-2ubuntu2.1, 3.6.3-2ubuntu2.3), kde-workspace-kgreet-plugins:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkpty4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libplasmagenericshell4:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkblog4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libkimap4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libkexiv2-10:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libqt4-xml:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), gstreamer0.10-x:amd64 (0.10.36-1, 0.10.36-1ubuntu0.1), libmailtransport4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libksignalplotter4:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libmessageviewer4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), grub-pc-bin:amd64 (1.99-21ubuntu3, 1.99-21ubuntu3.1), libavformat53:amd64 (0.8.1-0ubuntu1, 0.8.3-0ubuntu0.12.04.1), libkntlm4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), cups-bsd:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libtiff4:amd64 (3.9.5-2ubuntu1, 3.9.5-2ubuntu1.2), kinfocenter:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libplasma3:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libkworkspace4abi1:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), plasma-dataengines-workspace:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libgstreamer-plugins-base0.10-0:amd64 (0.10.36-1, 0.10.36-1ubuntu0.1), ksysguardd:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libmessagelist4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), openjdk-7-jre-lib:amd64 (7~u3-2.1.1~pre1-1ubuntu2, 7~u3-2.1.1~pre1-1ubuntu3), libkemoticons4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libkpimtextedit4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libkephal4abi1:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), update-manager-kde:amd64 (0.156.14.4, 0.156.14.5), libmtp-common:amd64 (1.1.3-1, 1.1.3-1ubuntu0.1), printer-driver-hpcups:amd64 (3.12.2-1ubuntu3, 3.12.2-1ubuntu3.1), libkscreensaver5:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkmime4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), kdelibs-bin:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libisccfg82:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), libkdewebkit5:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libqtgui4:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libksieveui4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), kdepimlibs-kio-plugins:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), kde-runtime:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkjsembed4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), krb5-locales:amd64 (1.10+dfsg~beta1-2, 1.10+dfsg~beta1-2ubuntu0.1), kde-style-oxygen:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libpolkit-agent-1-0:amd64 (0.104-1, 0.104-1ubuntu1), libkio5:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libakonadi-kabc4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), ntpdate:amd64 (4.2.6.p3+dfsg-1ubuntu3, 4.2.6.p3+dfsg-1ubuntu3.1), libkjsapi4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), kdemultimedia-kio-plugins:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libprocesscore4abi1:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libpango1.0-0:amd64 (1.30.0-0ubuntu2, 1.30.0-0ubuntu3.1), libkdcraw20:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libpulse0:amd64 (1.1-0ubuntu15, 1.1-0ubuntu15.1), kopete:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kdelibs5-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libpulsedsp:amd64 (1.1-0ubuntu15, 1.1-0ubuntu15.1), libkpimidentities4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libkpimutils4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), samba-common-bin:amd64 (3.6.3-2ubuntu2.1, 3.6.3-2ubuntu2.3), libqt4-sql-mysql:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), system-config-printer-common:amd64 (1.3.8+20120201-0ubuntu8, 1.3.8+20120201-0ubuntu8.1), kate:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), grub-common:amd64 (1.99-21ubuntu3, 1.99-21ubuntu3.1), kmail:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), grub2-common:amd64 (1.99-21ubuntu3, 1.99-21ubuntu3.1), libexif12:amd64 (0.6.20-2, 0.6.20-2ubuntu0.1), libqt4-scripttools:amd64 (4.8.1-0ubuntu4.1, 4.8.1-0ubuntu4.2), libglu1-mesa:amd64 (8.0.2-0ubuntu3, 8.0.2-0ubuntu3.1), libgssapi-krb5-2:amd64 (1.10+dfsg~beta1-2, 1.10+dfsg~beta1-2ubuntu0.1), isc-dhcp-common:amd64 (4.1.ESV-R4-0ubuntu5, 4.1.ESV-R4-0ubuntu5.1), marble-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libcupsmime1:amd64 (1.5.2-9ubuntu1, 1.5.3-0ubuntu1), libisc83:amd64 (9.8.1.dfsg.P1-4, 9.8.1.dfsg.P1-4ubuntu0.1), libsolidcontrolifaces4abi2:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkde3support4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), plasma-desktop:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libknotifyconfig4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), kget:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), systemsettings:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libnautilus-extension1a:amd64 (3.4.2-0ubuntu1, 3.4.2-0ubuntu3), system-config-printer-kde:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kdelibs5-plugins:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), kdenetwork-filesharing:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kdepim-runtime:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), kgpg:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libprocessui4a:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkhtml5:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libkdeui5:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), mysql-common:amd64 (5.5.22-0ubuntu1, 5.5.24-0ubuntu0.12.04.1), jovie:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libakonadi-kcal4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libkdesu5:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.2), libgtk-3-common:amd64 (3.4.2-0ubuntu0.2, 3.4.2-0ubuntu0.4), language-pack-en:amd64 (12.04+20120508, 12.04+20120618), gstreamer0.10-plugins-base:amd64 (0.10.36-1, 0.10.36-1ubuntu0.1), libakonadi-notes4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), python-crypto:amd64 (2.4.1-1, 2.4.1-1ubuntu0.1), libtemplateparser4:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), okular:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkatepartinterfaces4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kdepim-strigi-plugins:amd64 (4.8.3-0ubuntu0.1, 4.8.4a-0ubuntu0.3), plasma-widgets-workspace:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), openjdk-7-jre-headless:amd64 (7~u3-2.1.1~pre1-1ubuntu2, 7~u3-2.1.1~pre1-1ubuntu3), kate-data:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), pulseaudio-utils:amd64 (1.1-0ubuntu15, 1.1-0ubuntu15.1), libxkbfile1:amd64 (1.0.7-1, 1.0.7-1ubuntu0.1), libakonadi-contact4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), libakonadi-kde4:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), printer-driver-hpijs:amd64 (3.12.2-1ubuntu3, 3.12.2-1ubuntu3.1), libsolidcontrol4abi2:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), okular-extra-backends:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libgpgme++2:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.2), hplip-data:amd64 (3.12.2-1ubuntu3, 3.12.2-1ubuntu3.1), kdepasswd:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), kmix:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkonq5abi1:amd64 (4.8.3-0ubuntu0.1, 4.8.4-0ubuntu0.1), libkwinglutils1:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1), libkwinnvidiahack4:amd64 (4.8.3-0ubuntu0.2, 4.8.4a-0ubuntu0.1)
End-Date: 2012-07-24  00:50:15
mint@mint ~ $

now rebooting and trying the same with the terminal:
here we go:

Code: Select all
mint@mint ~ $ apt update && apt upgrade
[...]
Fetched 158 kB in 4s (32.6 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  hplip hplip-data libhpmud0 libsane-hpaio linux-generic linux-image-generic
  printer-driver-hpcups printer-driver-hpijs
The following packages will be upgraded:
  accountsservice akregator apt apt-transport-https apt-utils aptdaemon ark
  bind9-host cron cups cups-bsd cups-client cups-common cups-ppdc dnsutils
  dolphin faenza-icons-kde firefox firefox-locale-en foomatic-filters
  freespacenotifier grub-common grub-pc grub-pc-bin grub2-common
  gstreamer0.10-alsa gstreamer0.10-plugins-base gstreamer0.10-x gwenview
  isc-dhcp-client isc-dhcp-common jovie kaddressbook kamera kate kate-data
  katepart kde-baseapps-bin kde-baseapps-data kde-runtime kde-runtime-data
  kde-style-oxygen kde-window-manager kde-window-manager-common kde-workspace
  kde-workspace-bin kde-workspace-data kde-workspace-kgreet-plugins
  kde-zeroconf kdeaccessibility kdegames-card-data kdelibs-bin kdelibs5-data
  kdelibs5-plugins kdemultimedia-kio-plugins kdenetwork-filesharing kdepasswd
  kdepim-kresources kdepim-runtime kdepim-strigi-plugins
  kdepimlibs-kio-plugins kdm kdoctools kget kgpg khelpcenter4 kinfocenter
  klipper kmail kmenuedit kmix knotes konsole kontact kopete korganizer kppp
  krb5-locales ksysguard ksysguardd ksystemlog kwalletmanager language-pack-en
  language-pack-kde-en libaccountsservice0 libakonadi-calendar4
  libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4
  libakonadi-kmime4 libakonadi-notes4 libapt-inst1.4 libapt-pkg4.12
  libavcodec53 libavformat53 libavutil51 libbind9-80 libcairo-gobject2
  libcairo2 libcalendarsupport4 libcups2 libcupscgi1 libcupsdriver1
  libcupsimage2 libcupsmime1 libcupsppdc1 libdbusmenu-glib4 libdbusmenu-gtk3-4
  libdbusmenu-gtk4 libdns81 libeventviews4 libexif12 libgail-3-0 libgcrypt11
  libgl1-mesa-dri libgl1-mesa-glx libglade2-0 libglapi-mesa libglib2.0-0
  libglu1-mesa libgnutls26 libgpgme++2 libgssapi-krb5-2
  libgstreamer-plugins-base0.10-0 libgtk-3-0 libgtk-3-common libgutenprint2
  libincidenceeditorsng4 libisc83 libisccc80 libisccfg82 libjpeg-turbo8
  libk5crypto3 libkabc4 libkactivities-bin libkactivities6 libkalarmcal2
  libkateinterfaces4 libkatepartinterfaces4 libkblog4 libkcal4 libkcalcore4
  libkcalutils4 libkcddb4 libkcmutils4 libkdcraw-data libkdcraw20
  libkde3support4 libkdeclarative5 libkdecorations4 libkdecore5 libkdegames5a
  libkdepim4 libkdepimdbusinterfaces4 libkdesu5 libkdeui5 libkdewebkit5
  libkdgantt2 libkdnssd4 libkemoticons4 libkephal4abi1 libkexiv2-10
  libkexiv2-data libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4
  libkio5 libkipi-data libkipi8 libkjsapi4 libkjsembed4 libkldap4 libkleo4
  libkmanagesieve4 libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common
  libkonq5-templates libkonq5abi1 libkontactinterface4 libkopete4 libkparts4
  libkpgp4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4
  libkpty4 libkrb5-3 libkrb5support0 libkresources4 libkrosscore4
  libkscreensaver5 libksgrd4 libksieve4 libksieveui4 libksignalplotter4
  libktexteditor4 libktnef4 libkunitconversion4 libkwineffects1abi3
  libkwinglutils1 libkwinnvidiahack4 libkworkspace4abi1 libkxmlrpcclient4
  liblwres80 libmailcommon4 libmailtransport4 libmarblewidget13
  libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4
  libmicroblog4 libmtp-common libmtp-runtime libmtp9 libmysqlclient18
  libnautilus-extension1a libnepomuk4 libnepomukdatamanagement4
  libnepomukquery4a libnepomuksync4 libnepomukutils4 libnm-glib-vpn1
  libnm-glib4 libnm-util2 libokularcore1abi1 libpango1.0-0
  libplasma-geolocation-interface4 libplasma3 libplasmaclock4abi3
  libplasmagenericshell4 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpostproc52 libprocesscore4abi1 libprocessui4a
  libpulse-mainloop-glib0 libpulse0 libpulsedsp libqgpgme1 libqt4-dbus
  libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql
  libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtgui4 libsmbclient libsolid4
  libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libswscale2 libsyndication4
  libtaskmanager4abi3 libtemplateparser4 libthreadweaver4 libtiff4 libv4l-0
  libv4lconvert0 libwbclient0 libweather-ion6 libxatracker1 libxkbfile1
  marble-data mysql-client-core-5.5 mysql-common mysql-server-core-5.5
  network-manager ntpdate okular okular-extra-backends openjdk-7-jre
  openjdk-7-jre-headless openjdk-7-jre-lib plasma-dataengines-addons
  plasma-dataengines-workspace plasma-desktop plasma-netbook
  plasma-scriptengine-javascript plasma-scriptengine-python
  plasma-widget-folderview plasma-widget-kimpanel plasma-widgets-addons
  plasma-widgets-workspace policykit-1 printer-driver-gutenprint
  printer-driver-ptouch pulseaudio pulseaudio-module-bluetooth
  pulseaudio-module-x11 pulseaudio-utils python-aptdaemon python-crypto
  python-cupshelpers python-problem-report python-software-properties qdbus
  samba samba-common samba-common-bin shared-mime-info smbclient ssl-cert sudo
  system-config-printer-common system-config-printer-kde
  system-config-printer-udev systemsettings tasks-icons update-manager-core
  update-manager-kde update-notifier-common xkb-data xserver-common
  xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xsettings-kde
341 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Need to get 300 MB of archives.
After this operation, 7,536 kB of additional disk space will be used.
Do you want to continue [Y/n]?


Code: Select all
mint@mint ~ $ apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-image-3.2.0-27-generic printer-driver-postscript-hp
The following packages will be upgraded:
  accountsservice akregator apt apt-transport-https apt-utils aptdaemon ark
  bind9-host cron cups cups-bsd cups-client cups-common cups-ppdc dnsutils
  dolphin faenza-icons-kde firefox firefox-locale-en foomatic-filters
  freespacenotifier grub-common grub-pc grub-pc-bin grub2-common
  gstreamer0.10-alsa gstreamer0.10-plugins-base gstreamer0.10-x gwenview hplip
  hplip-data isc-dhcp-client isc-dhcp-common jovie kaddressbook kamera kate
  kate-data katepart kde-baseapps-bin kde-baseapps-data kde-runtime
  kde-runtime-data kde-style-oxygen kde-window-manager
  kde-window-manager-common kde-workspace kde-workspace-bin kde-workspace-data
  kde-workspace-kgreet-plugins kde-zeroconf kdeaccessibility
  kdegames-card-data kdelibs-bin kdelibs5-data kdelibs5-plugins
  kdemultimedia-kio-plugins kdenetwork-filesharing kdepasswd kdepim-kresources
  kdepim-runtime kdepim-strigi-plugins kdepimlibs-kio-plugins kdm kdoctools
  kget kgpg khelpcenter4 kinfocenter klipper kmail kmenuedit kmix knotes
  konsole kontact kopete korganizer kppp krb5-locales ksysguard ksysguardd
  ksystemlog kwalletmanager language-pack-en language-pack-kde-en
  libaccountsservice0 libakonadi-calendar4 libakonadi-contact4
  libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadi-notes4 libapt-inst1.4 libapt-pkg4.12 libavcodec53 libavformat53
  libavutil51 libbind9-80 libcairo-gobject2 libcairo2 libcalendarsupport4
  libcups2 libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1
  libdbusmenu-glib4 libdbusmenu-gtk3-4 libdbusmenu-gtk4 libdns81
  libeventviews4 libexif12 libgail-3-0 libgcrypt11 libgl1-mesa-dri
  libgl1-mesa-glx libglade2-0 libglapi-mesa libglib2.0-0 libglu1-mesa
  libgnutls26 libgpgme++2 libgssapi-krb5-2 libgstreamer-plugins-base0.10-0
  libgtk-3-0 libgtk-3-common libgutenprint2 libhpmud0 libincidenceeditorsng4
  libisc83 libisccc80 libisccfg82 libjpeg-turbo8 libk5crypto3 libkabc4
  libkactivities-bin libkactivities6 libkalarmcal2 libkateinterfaces4
  libkatepartinterfaces4 libkblog4 libkcal4 libkcalcore4 libkcalutils4
  libkcddb4 libkcmutils4 libkdcraw-data libkdcraw20 libkde3support4
  libkdeclarative5 libkdecorations4 libkdecore5 libkdegames5a libkdepim4
  libkdepimdbusinterfaces4 libkdesu5 libkdeui5 libkdewebkit5 libkdgantt2
  libkdnssd4 libkemoticons4 libkephal4abi1 libkexiv2-10 libkexiv2-data
  libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkio5
  libkipi-data libkipi8 libkjsapi4 libkjsembed4 libkldap4 libkleo4
  libkmanagesieve4 libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common
  libkonq5-templates libkonq5abi1 libkontactinterface4 libkopete4 libkparts4
  libkpgp4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4
  libkpty4 libkrb5-3 libkrb5support0 libkresources4 libkrosscore4
  libkscreensaver5 libksgrd4 libksieve4 libksieveui4 libksignalplotter4
  libktexteditor4 libktnef4 libkunitconversion4 libkwineffects1abi3
  libkwinglutils1 libkwinnvidiahack4 libkworkspace4abi1 libkxmlrpcclient4
  liblwres80 libmailcommon4 libmailtransport4 libmarblewidget13
  libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4
  libmicroblog4 libmtp-common libmtp-runtime libmtp9 libmysqlclient18
  libnautilus-extension1a libnepomuk4 libnepomukdatamanagement4
  libnepomukquery4a libnepomuksync4 libnepomukutils4 libnm-glib-vpn1
  libnm-glib4 libnm-util2 libokularcore1abi1 libpango1.0-0
  libplasma-geolocation-interface4 libplasma3 libplasmaclock4abi3
  libplasmagenericshell4 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpostproc52 libprocesscore4abi1 libprocessui4a
  libpulse-mainloop-glib0 libpulse0 libpulsedsp libqgpgme1 libqt4-dbus
  libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql
  libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtgui4 libsane-hpaio libsmbclient libsolid4
  libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libswscale2 libsyndication4
  libtaskmanager4abi3 libtemplateparser4 libthreadweaver4 libtiff4 libv4l-0
  libv4lconvert0 libwbclient0 libweather-ion6 libxatracker1 libxkbfile1
  linux-generic linux-image-generic marble-data mysql-client-core-5.5
  mysql-common mysql-server-core-5.5 network-manager ntpdate okular
  okular-extra-backends openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib
  plasma-dataengines-addons plasma-dataengines-workspace plasma-desktop
  plasma-netbook plasma-scriptengine-javascript plasma-scriptengine-python
  plasma-widget-folderview plasma-widget-kimpanel plasma-widgets-addons
  plasma-widgets-workspace policykit-1 printer-driver-gutenprint
  printer-driver-hpcups printer-driver-hpijs printer-driver-ptouch pulseaudio
  pulseaudio-module-bluetooth pulseaudio-module-x11 pulseaudio-utils
  python-aptdaemon python-crypto python-cupshelpers python-problem-report
  python-software-properties qdbus samba samba-common samba-common-bin
  shared-mime-info smbclient ssl-cert sudo system-config-printer-common
  system-config-printer-kde system-config-printer-udev systemsettings
  tasks-icons update-manager-core update-manager-kde update-notifier-common
  xkb-data xserver-common xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xsettings-kde
349 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 347 MB of archives.
After this operation, 158 MB of additional disk space will be used.
Do you want to continue [Y/n]?


what you see here is the output of 2 different commands: in the first code block is upgrade and in the second is dist-upgrade
upgrade
Used to install the newest versions of all packages currently installed on the system from the sources enumerated in /etc/apt/sources.list(5). Packages currently installed with new versions available are retrieved and upgraded; under no circumstances are currently installed packages removed, nor are packages that are not already installed retrieved and installed. New versions of currently installed packages that cannot be upgraded without changing the install status of another package will be left at their current version. An update must be performed first so that apt-get knows that new versions of packages are available.

dist-upgrade
In addition to performing the function of upgrade, this option also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones, if necessary.
The /etc/apt/sources.list(5) file contains a list of locations from
which to retrieve desired package files. See also apt_preferences(5) for a mechanism for over-riding the general settings for individual packages.

- comparing both you see that upgrade installs new versions of the packages you have in the system but doesn't install new packages or remove any as dist-upgrade does;
- mintupdate is in-between: installs new packages; eventually (not tested here) remove obsolete pkgs as well but is "blocked" by the levels (doesn't install ALL the new pkgs >> this of course in a default configuration)
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: [HELP!] Mint 12 KDE Update Manager wants to remove KDE

Postby RJim on Mon Jul 23, 2012 11:44 pm

Hmmm... so you have essentially confirmed that MintUpdate will not actually remove all of the things it says will be removed.
So basically it scared me for nothing :lol:

Thank you for all of your help zerozero.
I will mark this as solved now... I guess I should just not flinch next time I get one of those disturbing confirmation messages.

--Jim
RJim
Level 3
Level 3
 
Posts: 109
Joined: Thu May 10, 2012 9:49 pm

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 1 guest