[SOLVED] Installed LM 13 KDE, only boots with USB connected

Forum rules
Before you post please read how to get help

[SOLVED] Installed LM 13 KDE, only boots with USB connected

Postby Tonttu on Mon Jul 23, 2012 9:15 am

I had openSUSE installed and selected "use all available space" in the Mint installer. Now when I try to boot to HD, it doesn't do anything - only flashing cursor. When the USB stick with LM is connected, it boots to the HD. How can I get the boot loader to the HD?
I can't reinstall Mint because it will just boot into the Mint installed on HD.
Last edited by Tonttu on Wed Jul 25, 2012 11:51 am, edited 1 time in total.
Tonttu
Level 1
Level 1
 
Posts: 49
Joined: Mon Jul 11, 2011 11:54 am

Linux Mint is funded by ads and donations.
 

Re: Installed LM 13 KDE, only boots with USB connected

Postby tumas04 on Mon Jul 23, 2012 11:13 am

What do u mean by "flashing cursor" ? Have u tried holding the "Shift-Button" at boot time to display the grub menu? (i think it was the shift key, not 100% sure)
If that works, u could press the "e" key to edit the startup-options. And then try to play with the (hdx,y) option.
tumas04
Level 1
Level 1
 
Posts: 1
Joined: Mon Jul 23, 2012 7:08 am

Re: Installed LM 13 KDE, only boots with USB connected

Postby disciple1964 on Mon Jul 23, 2012 11:51 am

Tonttu wrote:I had openSUSE installed and selected "use all available space" in the Mint installer. Now when I try to boot to HD, it doesn't do anything - only flashing cursor. When the USB stick with LM is connected, it boots to the HD. How can I get the boot loader to the HD?
I can't reinstall Mint because it will just boot into the Mint installed on HD.


The best thing to do is to really pay attention when loading the software, during the partitioning of system, it should ask you what mbr or drive do you want grub on. You should always choose the primary, or in your case, the local hard drive.

As for it booting only into linux, do a grubupdate and it should pick up the other OS's installed on the drive if you are dual booting. Make sure to put the HD that has grub on it first in the boot process in the bios, otherwise windows will be the only thing that boots.

If you need in depth instructions, just do a google search for " how to update os's in grub" or " How to set the MBR in opensuse" the links should give step by step. :D
disciple1964
 

Re: Installed LM 13 KDE, only boots with USB connected

Postby Tonttu on Mon Jul 23, 2012 2:10 pm

disciple1964 wrote:
Tonttu wrote:I had openSUSE installed and selected "use all available space" in the Mint installer. Now when I try to boot to HD, it doesn't do anything - only flashing cursor. When the USB stick with LM is connected, it boots to the HD. How can I get the boot loader to the HD?
I can't reinstall Mint because it will just boot into the Mint installed on HD.


The best thing to do is to really pay attention when loading the software, during the partitioning of system, it should ask you what mbr or drive do you want grub on. You should always choose the primary, or in your case, the local hard drive.

As for it booting only into linux, do a grubupdate and it should pick up the other OS's installed on the drive if you are dual booting. Make sure to put the HD that has grub on it first in the boot process in the bios, otherwise windows will be the only thing that boots.

If you need in depth instructions, just do a google search for " how to update os's in grub" or " How to set the MBR in opensuse" the links should give step by step. :D


But Mint didn't ask where I want GRUB in. It presented me with 3 options: squeeze itself into the available free space alongside openSUSE (not what I want), take up all space (and possibly mess up the boot now that I think about it?) or do it manually. I don't have Windows in the machine.
Ok I'll try sudo apt-get update grub, but it's actually my neighbor's machine, so I can't do it right now :D

Would be cool, if Mint detected the existence of an installed OS and presented an option to wipe it out and do the default automatic partitioning. I would have had to run to my place to look up partitioning Mint, so chose what I chose..
Tonttu
Level 1
Level 1
 
Posts: 49
Joined: Mon Jul 11, 2011 11:54 am

Re: Installed LM 13 KDE, only boots with USB connected

Postby Tonttu on Wed Jul 25, 2012 6:38 am

sudo apt-get update grub returned apt-get update doesn't take parameters, so I went to Synaptic and marked grub to be updated and applied. Then when I boot, I no longer got a blinking cursor, but I guess it ran through the other boot options after HD, like network book and floppy disk, because it searched DHCP and then it said Non system disk or disk error.
Now, if I manage to install a random distro, say openSUSE 12.2. RC and then I start Mint KDE install again, how do I have to do the partitioning so it will succeed?
Tonttu
Level 1
Level 1
 
Posts: 49
Joined: Mon Jul 11, 2011 11:54 am

Re: Installed LM 13 KDE, only boots with USB connected

Postby Tonttu on Wed Jul 25, 2012 9:06 am

I'll try with PartedMagic, destroy all partitions and then try LM KDE again..
Tonttu
Level 1
Level 1
 
Posts: 49
Joined: Mon Jul 11, 2011 11:54 am

Re: [SOLVED] Installed LM 13 KDE, only boots with USB connec

Postby Tonttu on Wed Jul 25, 2012 11:53 am

Ach, I had disabled booting from HD in the BIOS yesterday, so this caused the Non system disk error. Well, I already wiped the partition with PartedMagic and reinstalled Mint KDE before realizing this! I'm quite sure the GRUB update did the job. User error.
Tonttu
Level 1
Level 1
 
Posts: 49
Joined: Mon Jul 11, 2011 11:54 am

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 8 guests