No partition table???

Forum rules
Before you post please read how to get help

No partition table???

Postby BostonPeng on Wed Jul 25, 2012 5:26 pm

I ran into a serious problem today. I had a microSD memory card for my phone (formatted FAT16 by my phone) mounted via my digital media player (iriver E100) and I was in the midst of copying some files over when I bumped the cable and temporarily lost connection with the player. Except now when I mount the card it only shows two folders, and one of them isn't even in the proper location within the path. If I mount the card on my phone it shows everything's where it should be but if I try to do anything with the card in Dolphin I get read only errors. I tried opening the partition in partition manager I get an error that there's no valid partition table on the drive, or on the drive's primary drive (which wasn't even mounted ta the time). I tried running e2fsck on the partition and got
Code: Select all
$ sudo e2fsck /media/disk
e2fsck 1.42.4 (12-Jun-2012)
e2fsck: Is a directory while trying to open /media/disk

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

Does anyone have any ideas what I could do to rescue the drive? As things stand right now I can't even do a proper backup on it to do a nuke and pave operation on it and I don't have access to a Windows machine to run scandisk on it.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 3 guests