Installing Mint KDE

Forum rules
Before you post please read how to get help

Installing Mint KDE

Postby nomko on Sat Jul 28, 2012 7:01 am

Last night I tried to install KDE Mint. Failed, at least partially failed so it seems.

The installation procedure is progressing well, no problems. After the reboot I could log in properly. And then the "misery" came. KDE was so slooooooooooooooooooowwwwwwwwwwww as it could be. I got a box on my desktop which was empty and could not be removed or closed. The menu did not open, mouse reacted so slow .. Does anyone know what's going on?

Out of frustration I installed Mint + Mate again.

My system:
Motherboard: ASUS P5KPL-AM SE
Processor: Intel Core (TM) 2 Quad CPU Q8200
Memory: 4 GB ram
Video Card: nVidia GeForce 9500GT
network interface: Realtek and Ralink RT2500 802.11g RTL8101/8102E
CD / DVD: Optiarc DVD RW AD-7200A
HDD: Samsung HD501LJ & HD103SI
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)
Linux tips and tricks
User avatar
nomko
Level 9
Level 9
 
Posts: 2943
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Linux Mint is funded by ads and donations.
 

Re: Installing Mint KDE

Postby xenopeek on Sat Jul 28, 2012 7:07 am

Might be caused by nVidia driver? Some desktop effects in KDE can be demanding of the GPU. You might need to install a different graphics card driver, or disable some desktop effects.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15443
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Installing Mint KDE

Postby nomko on Sat Jul 28, 2012 7:16 am

Vincent Vermeulen wrote:Might be caused by nVidia driver? Some desktop effects in KDE can be demanding of the GPU. You might need to install a different graphics card driver, or disable some desktop effects.


How to do that? I'm not that familiar with KDE but wanna give it a try.
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)
Linux tips and tricks
User avatar
nomko
Level 9
Level 9
 
Posts: 2943
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Installing Mint KDE

Postby homerscousin on Sat Jul 28, 2012 4:48 pm

You definitely have enough horsepower to run KDE, or Compiz or anything else on linux. The problem is getting the graphics subsystem operating correctly. I had a GT 220 card up until 3 weeks ago. Very similar in performance to yours. It died. I couldn't even get my Nvidia drivers installed. I don't know much about fixing these issues but if my old Pentium D with 1 Gb ram and GT 220 would run Compiz your system has to be faster. It must be the driver or other settings. I bet you can fix it but it may take a lot of reading and learning to get there.

I got a new i5 3570k and z77 mobo last week. using the onboard Intel hd 4000 graphics. so far Mint 13 kde is running perfectly.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.
homerscousin
Level 5
Level 5
 
Posts: 541
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)

Re: Installing Mint KDE

Postby nomko on Sat Jul 28, 2012 5:04 pm

The most stupid thing is, i had Mint KDE running under Virtualbox (Mint + Mate) for testing and then it was running like hell! No problems with graphics or memory or whatever!
And now in "real life" KDE comes up with issues....
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)
Linux tips and tricks
User avatar
nomko
Level 9
Level 9
 
Posts: 2943
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Installing Mint KDE

Postby braingateway on Sun Jul 29, 2012 1:59 am

Well I do NOT think it is the KDE problem. I had it installed on a far powerless machine than urs, it runs very smooth.
I think this is just a normal Linux problem: As all other Linux DEs and releases, it requires you to spend some time on learning phase.

nomko wrote:Last night I tried to install KDE Mint. Failed, at least partially failed so it seems.

The installation procedure is progressing well, no problems. After the reboot I could log in properly. And then the "misery" came. KDE was so slooooooooooooooooooowwwwwwwwwwww as it could be. I got a box on my desktop which was empty and could not be removed or closed. The menu did not open, mouse reacted so slow .. Does anyone know what's going on?

Out of frustration I installed Mint + Mate again.

My system:
Motherboard: ASUS P5KPL-AM SE
Processor: Intel Core (TM) 2 Quad CPU Q8200
Memory: 4 GB ram
Video Card: nVidia GeForce 9500GT
network interface: Realtek and Ralink RT2500 802.11g RTL8101/8102E
CD / DVD: Optiarc DVD RW AD-7200A
HDD: Samsung HD501LJ & HD103SI
braingateway
Level 2
Level 2
 
Posts: 81
Joined: Thu Sep 29, 2011 4:21 pm

Re: Installing Mint KDE

Postby nomko on Sun Jul 29, 2012 8:15 am

braingateway wrote:Well I do NOT think it is the KDE problem. I had it installed on a far powerless machine than urs, it runs very smooth.
I think this is just a normal Linux problem: As all other Linux DEs and releases, it requires you to spend some time on learning phase.
\
Not very helpfull..... Then tell me what my problem is in not running KDE smoothly???

It did under virtualbox, it did not after installing it on my pc. What's the problem here? Better to come with a helpfull solution which helps me more rather than keep telling me something over and over again what i already know....
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)
Linux tips and tricks
User avatar
nomko
Level 9
Level 9
 
Posts: 2943
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Installing Mint KDE

Postby zerozero on Sun Jul 29, 2012 8:53 am

nomko,
do you still have with you the installation media with maya kde? try boot into that system with it;
how does it feels performance-wise? (in live-mode you are using nouveau, not the nvidia drivers and afaik desktop effects are on but kwin would disable automatically the ones that it can't handle > the most problematic situation is always blur)

now in systemsettings > desktop effects check in the last tab (advanced): probably kwin is using openGL, try to change it to Xrender and check if the performance improves; you can also disable totally the desktop effects and see how that affects (good or bad) those issues;
^^ remember that all this time you are running with nouveau (we basically want to establish that this is a graphics card related issue) ^^

now in the installed system i would check first of all if the drivers for the 9500GT are the correct ones and are properly installed;
then i would try without effects first and with Xrender after.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Installing Mint KDE

Postby JoeFootball on Sun Jul 29, 2012 9:24 am

nomko wrote:
Vincent Vermeulen wrote:Might be caused by nVidia driver? Some desktop effects in KDE can be demanding of the GPU. You might need to install a different graphics card driver, or disable some desktop effects.


How to do that? I'm not that familiar with KDE but wanna give it a try.

From the Launcher in the lower-left, go to... Applications > System > Additional Drivers ...to see if there are any proprietary drivers available for your video card.

I believe that Alt+Shift+F12 is the default toggle for the Desktop Effects, but to disable them via settings, go to... Applications > Settings > System Settings ...then... Workspace Appearance and Behavior > Desktop Effects > General ...where you can disable via one or more of the three checkboxes. (fwiw, I personally prefer speed over eye candy, so I have all three unchecked)

Joe
User avatar
JoeFootball
Level 4
Level 4
 
Posts: 267
Joined: Tue Nov 24, 2009 1:52 pm
Location: Minneapolis, MN, USA

Re: Installing Mint KDE

Postby nomko on Sun Jul 29, 2012 9:34 am

JoeFootball wrote:
nomko wrote:
Vincent Vermeulen wrote:Might be caused by nVidia driver? Some desktop effects in KDE can be demanding of the GPU. You might need to install a different graphics card driver, or disable some desktop effects.


How to do that? I'm not that familiar with KDE but wanna give it a try.

From the Launcher in the lower-left, go to... Applications > System > Additional Drivers ...to see if there are any proprietary drivers available for your video card.

I believe that Alt+Shift+F12 is the default toggle for the Desktop Effects, but to disable them via settings, go to... Applications > Settings > System Settings ...then... Workspace Appearance and Behavior > Desktop Effects > General ...where you can disable via one or more of the three checkboxes. (fwiw, I personally prefer speed over eye candy, so I have all three unchecked)

Joe

Thanks!
I'll try that!
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)
Linux tips and tricks
User avatar
nomko
Level 9
Level 9
 
Posts: 2943
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 1 guest