Kickoff Launcher misses Leave icons

Forum rules
Before you post please read this

Kickoff Launcher misses Leave icons

Postby Schoelje on Sat Aug 04, 2012 6:12 am

On Debian (wheezy) I installed KDE 4.8.4 to make the unofficial LMDE KDE with the upcoming UP5.
Everything works as expected.

I created a live DVD where I notice something peculiar: the Kickoff launcher missed the system section in the Leave menu. When I add the Lock/Logout widget there is no shut down button either.

So, in the live environment I'm unable to shut down, restart, hibernate or sleep the system through the usual graphical means and I have to shut down by typing "sudo shutdown -h -P now" in the terminal.

After installation, the icons are there and I can shut down normally.

This only seems to affect the 32-bit live version, 64-bit has the restart and shut down icons while running live.

This is what I've tried/checked:
- Delete all folders in the live user directory.
- Check Session Management: all looks well.
- I have tried adding the user to the same groups as the user from a working system (not live).
- Installing in VirtualBox, verifying that everything is working and create a live DVD from that.
- Running Live in VirtualBox does show below picture, running live from USB however, does show an extra Sleep button (!)
- I have compared (64 vs 32-bits) the config files in the following directories, without finding differences:
  • /home/<user>
  • /usr/lib/kde4
  • /usr/share/kde4
  • /usr/share/applications/kde4
  • /etc/kde4
  • /etc/skel
- I have compared running processes and found these not running in live 32-bit, but were running on the others:
  • khugepaged
  • kio_desktop
  • kio_file
  • kio_trash

Could these missing processes have to do with this issue (or a symptom of something entirely else)?

To see what I'm talking about:
Image
Last edited by Schoelje on Fri Aug 10, 2012 9:17 am, edited 7 times in total.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Linux Mint is funded by ads and donations.
 

Re: Kickoff Launcher misses Leave icons

Postby zerozero on Sat Aug 04, 2012 6:00 pm

Schoelje,
one thing is unclear (to me :oops: ) here:
what build exactly are you talking about here?
i ask this because i have right now (in the laptop) the 201208 iso (liveUSB made with dd) and i see all the options under Leave
Session
Log out
Lock
Save Session
Switch user
System
Sleep
Restart
Shut down
EDIT:
better this way
Image
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: Kickoff Launcher misses Leave icons

Postby Schoelje on Sat Aug 04, 2012 10:56 pm

This only happens when I'm running the live CD of the unofficial LMDE KDE with UP5.
This is a Plasma related issue: when I add the Lock/Logout widget there is no shut down button either.

When installed however, the Leave menu is looking how it should be.

I've been comparing all related config files (between the live and installed system) and they are all the same, so I suspect that with the upgrade a bug has been introduced that only affects the live environment.

I'm now desperate enough to create a link in the Favorites menu of the live user to shut down the live system.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Kickoff Launcher misses Leave icons

Postby Schoelje on Sun Aug 05, 2012 3:14 pm

I've tried to update in Virtualbox and copy it's content to a directory after which I created a live CD (If you want to know how: viewtopic.php?f=42&t=109398).
But all of a sudden, the system buttons have vanished again!

The new version of KDE and Plasma obviously have problems deciding whether or not you can shut down or restart while in a live environment.

So...I've decided for a shut down button in the Favorites menu of the Kickoff launcher.
Ugly, but better than letting the users type "sudo shutdown -h -P now" in a terminal.
Moreover, after installing the system, everything is as expected.

I've posted this issue with our KDE friends (http://forum.kde.org/viewtopic.php?f=67&t=107214). Maybe there is a developer who knows how to tackle this thing. But if you have an epiphany (about this issue, obviously), please let me know!
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands


Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests