KDE font size in high resolution monitor.

Forum rules
Before you post please read this

KDE font size in high resolution monitor.

Postby erku on Sat Aug 04, 2012 8:22 am

KDE 4.8 fonts are a very poor appearance with higher resolution monitor (1680x1050, and higer).

Is selected in KDE Control Center normal font and 96dpi.
Output terminal is currently:
~ # xdpyinfo | grep resolution
resolution: 87x83 dots per inch

~ # xdpyinfo | grep dimensions
dimensions: 1680x1050 pixels (490x321 millimeters)
/etc/fonts/conf.d $ xrdb -query | grep dpi
Xft.dpi: 96

How can I change the resolution of the system: 99x98 dots per inch; or: 90x88 dots per inch ?

Thank you very much for who knows...
OP: Linux Mint 9/64, 13/64
PC first: Athlon64 x2 5200+, 2x1GB RAM, GF8400GS, 2x160GB HDD (AM2+ based desktops, AM3 based desktop, Pentium Dual-Core laptop)
User avatar
erku
Level 1
Level 1
 
Posts: 7
Joined: Fri Aug 28, 2009 1:32 am
Location: Järvamaa, Estonia

Linux Mint is funded by ads and donations.
 

Re: KDE font size in high resolution monitor.

Postby Jaws on Mon Aug 06, 2012 1:49 pm

I guess I'll take a crack at it.

The video drivers detect the information it needs (resolution, refresh, dpi) from Edid stored in the monitor. As long as you have your video driver set up properly, it should use this info to give you the proper values. Now, if Edid somehow got corrupted, there are ways to override the Edid info and there are a ton of posts on doing this if you google.

When I first started using a Ubuntu based distro this past month, Mint 13 KDE 64bit, I too thought the fonts looked awful. The Ubuntu font at 9 points looked butt ugly IMO and I adjusted all fonts in System Settings to Nimbus Sans L at 10 points. Much better.

BTW, I also have a 1680x1050 monitor and the nVidia drivers pulled the Edid and set my DPI display at 99x98 automatically.

Could you post the output of

Code: Select all
$  grep -B 1 "DPI" /var/log/Xorg.0.log


EDIT: Also check Synaptic for 100 dpi font and install them.

EDIT 2: While I'm in System Setting changing the fonts to Nimbus Sans L, I also Enable anti-aliasing, and configure anti-aliasing to medium or whatever looks best to you. No check marks in either box.
Jaws
Level 1
Level 1
 
Posts: 49
Joined: Thu Jul 19, 2012 10:56 am


Return to KDE

Who is online

Users browsing this forum: No registered users and 3 guests