Mouse set to single-click won't work [Solved]

Forum rules
Before you post please read this

Mouse set to single-click won't work [Solved]

Postby corcaigher on Mon Aug 06, 2012 12:58 pm

Using Maya AMD64 edition, I have repeatedly set my mouse to single-click to open files and folders only to have it be completely ignored and even change back to double-click. This is annoying. I don't recall having this problem with Lisa. How can I get this to stay set at single-click.
Last edited by corcaigher on Wed Aug 08, 2012 6:36 am, edited 1 time in total.
Desktop: Qiana kde 64, AMD Phenom 9150e Quad-Core Processor 1.8GHz, 8GiB Memory, Nvidia GF108 [GeForce GT 430]
corcaigher
Level 1
Level 1
 
Posts: 31
Joined: Thu Mar 03, 2011 11:18 am

Linux Mint is funded by ads and donations.
 

Re: Mouse set to single-click won't work

Postby Jaws on Mon Aug 06, 2012 6:19 pm

That's kind of odd because I thought the same thing happened to me once because in the process of configuring my desktop, or updating the packages, it went back to double click. I set it once again to single click and haven't had any problems with it since.

In a terminal type, kwrite /home/your-user-name/.kde/share/config/kdeglobals

Ctrl+F opens the Find dialog in Kwrite, type in [kde] with the brackets. This is my [kde] section:

[KDE]
AutoSelectDelay=-1
ChangeCursor=true
DoubleClickInterval=400
ShowDeleteCommand=true
SingleClick=true <====
StartDragDist=4
StartDragTime=500
WheelScrollLines=3
contrast=7

Alternatively, you can use Dolphin to browse to the hidden file -> kdeglobals, in /home/your-user-name/.kde/share/config. Open it in kwite and scroll down to the [kde] section.

You want to see SingleClick=true.

If you add that line and save, I'd backup the file first, and it still doesn't work, I might also try adding a new user and seeing if it still doesn't work in that account.
Jaws
Level 1
Level 1
 
Posts: 49
Joined: Thu Jul 19, 2012 10:56 am

Re: Mouse set to single-click won't work

Postby claudecat on Tue Aug 07, 2012 2:01 am

I really dislike that Mint defaults to double-click, and yes, I have noticed that setting it to single-click sometimes does not "stick". I just keep re-setting it to single-click and it eventually (no more than 2-3 times) does stay that way. Sometimes an update will cause it to change back, so I repeat the process. Again, I wish Mint would change to the way almost EVERY other KDE distro does it (Mageia is the only exception I've seen). Double-clicking is not how KDE is supposed to work.
claudecat
Level 3
Level 3
 
Posts: 115
Joined: Wed Mar 03, 2010 1:03 am
Location: MD, USA

Re: Mouse set to single-click won't work

Postby corcaigher on Wed Aug 08, 2012 6:36 am

Thanks for the input. Mostly it is just irritating to have keep re-setting the mouse. At least I know I am not crazy...well, at least about this issue. :roll:
Desktop: Qiana kde 64, AMD Phenom 9150e Quad-Core Processor 1.8GHz, 8GiB Memory, Nvidia GF108 [GeForce GT 430]
corcaigher
Level 1
Level 1
 
Posts: 31
Joined: Thu Mar 03, 2011 11:18 am


Return to KDE

Who is online

Users browsing this forum: No registered users and 5 guests