Compiz Fusion focus (on mouse click problems)

Forum rules
Before you post please read this

Compiz Fusion focus (on mouse click problems)

Postby CJCorcoran on Mon Mar 31, 2008 3:01 pm

Hello

I am a new Linux Mint user (I've been using Ubuntu previously and I know LM is a derivative of Ubuntu). I just installed LM v4.0 KDE CE and seem to have a strange problem with compiz fusion. When clicking windows to focus on them, once clicking them, they do not get brought to the front if stuff is on top of them. Only when clicking in the titlebar area do they get brought to the front. If I disable compiz fusion, I do not have this problem.
CJCorcoran
Level 1
Level 1
 
Posts: 12
Joined: Mon Mar 31, 2008 2:52 pm

Linux Mint is funded by ads and donations.
 

Re: Compiz Fusion focus (on mouse click problems)

Postby proxima_centauri on Mon Mar 31, 2008 6:12 pm

Ok this may be the solution. Go to the advanced compiz settings, "advanced desktop effects settings" for me (not sure with KDE). Anyways go to "General Options" at the top, click on the "Focus and Raise Behaviour". Make sure "Raise on Click" is checked. I got the same behaviour as what you describe when I un-click it.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Compiz Fusion focus (on mouse click problems)

Postby Fredrik2000 on Tue Apr 01, 2008 3:28 pm

I had this problem to.
Go to KDE controll center click "desktop" > "window behavior" On the first page there is a dropdown menu "policy" choose "click to focus"
and make sure "click raise active window" is checked. This was already the default settings but uncheck them and apply them again.

Hope this works and sorry for my bad english :lol:
User avatar
Fredrik2000
Level 1
Level 1
 
Posts: 10
Joined: Tue Apr 01, 2008 3:09 pm
Location: Skinnskatteberg, Sweden

Re: Compiz Fusion focus (on mouse click problems)

Postby CJCorcoran on Wed Apr 02, 2008 9:13 am

Thanks. Ironically, I did both of those before posting my problem. The problem went away after I restarted... figures.
CJCorcoran
Level 1
Level 1
 
Posts: 12
Joined: Mon Mar 31, 2008 2:52 pm


Return to KDE

Who is online

Users browsing this forum: No registered users and 2 guests