omit application from taskbar (kstart) solved

Forum rules
Before you post please read this

omit application from taskbar (kstart) solved

Postby Tony G on Sat Apr 12, 2008 2:19 am

Hi all,

I'm trying to figure out how to keep a specific application from appearing in the taskbar (I autostart pidgin, have it on all desktops, and have it in the systray). My best research found
Code: Select all
kstart --skiptaskbar [Program]
When I enter this, I get the message "kstart: WARNING: Omitting both --window and --windowclass arguments is not recommended". I've looked at man kstart, and am baffled as to how to make a --window argument. Has anyone had luck with this?

Thanks,

Anthony
User avatar
Tony G
Level 3
Level 3
 
Posts: 178
Joined: Wed Jan 16, 2008 9:36 pm
Location: Laramie, WY, US

Linux Mint is funded by ads and donations.
 

Re: omit application from taskbar (kstart)

Postby Husse on Sat Apr 12, 2008 7:29 am

Really hard to find solutions in Google - there is kstart and kerberos in plenty, but that's not what you are looking for
However I think this is how to do it
Code: Select all
kstart --skiptaskbar --alldesktops [program]

This is taken from
http://docs.kde.org/stable/en/kdebase-r ... -work.html
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: omit application from taskbar (kstart)

Postby Tony G on Sat Apr 12, 2008 1:23 pm

Husse,

You're right. I tried that, but omitted it in my post. It didn't work for me, though, but I found a solution: Right-click the title-bar of the window --> Advanced --> Special Window Settings; go to Preference tab; check Skip taskbar, select Force, AND check the box to the right.

Thanks again, Husse
User avatar
Tony G
Level 3
Level 3
 
Posts: 178
Joined: Wed Jan 16, 2008 9:36 pm
Location: Laramie, WY, US


Return to KDE

Who is online

Users browsing this forum: No registered users and 1 guest