Head Scratching Setting Time issue with Gmail.

Forum rules
Before you post please read this

Head Scratching Setting Time issue with Gmail.

Postby Orbmiser on Wed Sep 04, 2013 8:03 pm

1) Bios clock set at 16:24 pm.
2) Dual boot with Win7

Win7 - Gmail shows message received at 4:25pm (16:25)
KDE - Gmail shows same message 11:25pm (23:25) +7 hrs. GMT I guess.

Tho have Digital Clock setting set to Los Angeles

Digital Clock Settings.jpeg
Digital Clock Settings.jpeg (13.86 KiB) Viewed 1362 times


Have Date & Time Settings set to Los Angeles with UTC unchecked.

Date and Time Settings.jpeg
Date and Time Settings.jpeg (12.84 KiB) Viewed 1362 times


Conky and tray show correct local time.

But gmail on the linux side is giving wrong time for messages.
Any help to resolve will be appreciated.
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Linux Mint is funded by ads and donations.
 

Re: Head Scratching Setting Time issue with Gmail.

Postby Orbmiser on Thu Sep 05, 2013 2:49 am

Received PM and thought to post here and see if it may help others.

Orbmiser, I can not remember where, either in the Linix Mint or Ubuntu (Kubuntu) forum, there is a post that refers to a problem similar to yours. I had similar problem, by changing the input below it solved it for me. I use root terminal so you may have to use sudo.

ln -sf /usr/share/zoneinfo/USA/Los Angeles

In the same post it refers to:

/etc/kde4/kcmclocktc

I looked at it but did not change anything.

Your digital clock settings are the same as mine except for my local info

In Digital Clock Setting/ Time Zones I have the following ticked: Melbourne, Perth, UTC & Darwin the clock default set to Australia/Darwin. I did have have some minor problems with this but by un ticking and selecting (ticking the box) in a different order I acheived my aim.
Main clock in the Task Bar shows Local Time by hovering ove the time it displays al the area/time zones I selected.
Regards, TopEnder


So will give that a try as a possible solution.
But answer me this? I Don't understand why Time seems to be a continuous unsolvable problem for All OS'es they always seems to need a fix a workaround and tweaking. But seems to be even more prevalent with Linux.

Geeze! How complex it is setting time to local. And why does a desktop need UTC?
All I want is everything on my desktop to speak one local time. Is that So Hard! ?
.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Head Scratching Setting Time issue with Gmail.

Postby Hawkeye_52 on Thu Sep 05, 2013 1:02 pm

Orbmiser,

I am running two computers; primary with LM15 Cinnamon and secondary with Netrunner KDE (Enigma). The time problem came up on their forum, and a fix was posted there by a user named 'pablodav'. The solution can be found at:

http://forums.netrunner-os.com/showthre ... 72#pid2272

It worked for me in Netrunner -- a 'kissing cousin' to Linux Mint. Hope it helps you out...

Hawkeye52
User avatar
Hawkeye_52
Level 3
Level 3
 
Posts: 148
Joined: Thu Mar 06, 2008 5:06 am
Location: USA

Re: Head Scratching Setting Time issue with Gmail.

Postby Snapcase on Thu Sep 05, 2013 3:15 pm

I have a similar problem, AFAIK only with emais (Thunderbird, but it seems it's independent os the program used). The emails arrive in correct chronological order, but for some reason some are assigned or displayed with UTC time and some with my local time (UTC+1, currently +2 due to the summer time 1 hour addition in many countries). I have no idea about why they get different times. Might be related to the delivering servers instead of the local time set in our systems or computers? Nevertheless I don't remember that this oddity happened in Mac OS. I also used Thunderbird there.

I'll pay more attention to this issue in the following days, specially for the addresses/servers I receive emails frequently.
User avatar
Snapcase
Level 3
Level 3
 
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Head Scratching Setting Time issue with Gmail.

Postby Snapcase on Thu Sep 05, 2013 3:23 pm

I made a fast check in the deleted emails folder. It seems it's only the Google servers (Gmail, Youtube,etc...) what have not local timing. They are displayed with their own local time. I'll check if it's all UTC or depending on wherever a particular server is located. Anyway, It seems to be something related to Google.
User avatar
Snapcase
Level 3
Level 3
 
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Head Scratching Setting Time issue with Gmail.

Postby DrHu on Thu Sep 05, 2013 4:15 pm

http://email.about.com/od/gmailtips/qt/ ... e_zone.htm
--it might very well be Google's geolocation connection method that causes the time zone discrepency

And UTC or local time makes no differences, it is still a legitimate time: utc mode being naturally more universal
--why don't all computers use that instead of local time

Online time zone checker..
http://www.worldtimeserver.com/current_time_in_UTC.aspx
https://en.wikipedia.org/wiki/Time_zone ... ft_Windows
--some general info on zones..
User avatar
DrHu
Level 16
Level 16
 
Posts: 6895
Joined: Wed Jun 17, 2009 8:20 pm

Re: Head Scratching Setting Time issue with Gmail.

Postby Orbmiser on Thu Sep 05, 2013 5:20 pm

Win7 - Gmail shows message received at 12:34am
KDE - Gmail shows same message7:34pm (19:25) 7 hrs. difference.

Same gmail account access on same computer. Just the linux gmail giving GMT? or UTC?
So damn confusing as shouldn't matter what the servers use as should be translated to local.

Gmail header shows right local time 12:34 but the gmail inbox is showing 7 hrs difference and showing 7:34pm.
on Gmail in Linux tho window shows fine and correct.

Gmail Header.jpeg
Gmail Header.jpeg (13.13 KiB) Viewed 1280 times

.
User avatar
Orbmiser
Level 7
Level 7
 
Posts: 1514
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon

Re: Head Scratching Setting Time issue with Gmail.

Postby Jonathan Spearman on Sat Sep 07, 2013 4:58 am

Greetings,

Just a couple of things to ask.

Do you by any chance have daylights saving time checked or unchecked?
If you check UTC, whats happens?

Is your time set correctly under linux? Is the time set correctly under windows? if not, check your bios time and see what it is set at.
Thanks
Jonathan Spearman
J.S. Technical Consulting
http://www.jstc.biz/
Running Linux Mint 15 KDE 4.11
User avatar
Jonathan Spearman
Level 1
Level 1
 
Posts: 34
Joined: Sat Aug 11, 2012 1:09 pm
Location: Texas

Re: Head Scratching Setting Time issue with Gmail.

Postby Snapcase on Mon Sep 09, 2013 3:36 am

Do you by any chance have daylights saving time checked or unchecked?


Where? I cannot find it in System settings

I'll check the bios time in the next boot.
User avatar
Snapcase
Level 3
Level 3
 
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 2 guests