Copying to USB pen drive very slow

Forum rules
Before you post please read this

Copying to USB pen drive very slow

Postby pelleoss on Fri Oct 04, 2013 4:39 am

I'm facing this problem: copying to USB pen drive takes ~3-4 minutes for 300MB!!! (data rate ~1.5MB/s!!!)
And this occurs only with USB pen drive: If I copy to an external usb hdd it take few seconds.
I think this happens after the last updates.
If I remember well last updates were about GRUB & HPLIB... but I'm not sure :oops:
I'm running LM 13 64bit KDE.

Anybody see the same behavior?
What can I do to solve it?

Thanks for your help,
Claudio:)
---------------------------------------------------------------------
Sony Vaio VGN-NW11S running LM 15 KDE 64 bit (dual boot Win7)
User avatar
pelleoss
Level 1
Level 1
 
Posts: 23
Joined: Sat Nov 17, 2012 9:39 am

Linux Mint is funded by ads and donations.
 

Re: Copying to USB pen drive very slow

Postby cessanfrancisco on Fri Oct 04, 2013 1:44 pm

Have you tried a different pen drive? The one you're using may have issues. I have had pen drives totally fail on me after a period of time.
cessanfrancisco
Level 1
Level 1
 
Posts: 39
Joined: Mon Jun 17, 2013 5:33 pm

Re: Copying to USB pen drive very slow

Postby beatink on Mon Oct 14, 2013 2:18 am

I have exactly the same problem and no matter what USB pendrive I use. And like as Claudio described, copying to the external HDD happens in a flash. There is an article on Archlinux (https://wiki.archlinux.org/index.php/US ... ge_Devices) discussing this problem and suggesting the following fix

If you experienced slow copy speed to pendrive (mainly in KDE), then append these three lines in a systemd tmpfile:

/etc/tmpfiles.d/local.conf

w /sys/kernel/mm/transparent_hugepage/enabled - - - - madvise
w /sys/kernel/mm/transparent_hugepage/defrag - - - - madvise
w /sys/kernel/mm/transparent_hugepage/khugepaged/defrag - - - - 0


However, I can't for the life of me find that directory or file.

Ron
beatink
Level 1
Level 1
 
Posts: 25
Joined: Thu May 26, 2011 7:10 pm

Re: Copying to USB pen drive very slow

Postby pelleoss on Mon Oct 14, 2013 4:04 am

Hi Ron,
I guess we have no such directory. SystemD is a startup process:
http://en.wikipedia.org/wiki/Systemd
https://wiki.archlinux.org/index.php/Systemd

And it is not present in LM13.
Maybe it can be starting from LM15, but I'm not sure.

So we have to find another way to solve our problem.

What is wired is I'm sure this strange behavior it was not present when I started with LM13. So probably a level 3 update caused that...
I read that some users never applies level 3 updates since they directly affect the HW. And I have to say quite often after an update the HW had some problems (once I had problem with the video driver, once with the heating and now with the USB slowness...)

I'm waiting for the next LTS release and than I will not update any level 3! :wink:

Ciao,
Claudio:)
---------------------------------------------------------------------
Sony Vaio VGN-NW11S running LM 15 KDE 64 bit (dual boot Win7)
User avatar
pelleoss
Level 1
Level 1
 
Posts: 23
Joined: Sat Nov 17, 2012 9:39 am

Re: Copying to USB pen drive very slow

Postby daveinuk on Mon Oct 14, 2013 4:23 am

However, I can't for the life of me find that directory or file.

Ron


Sorry if I'm asking the obvious as you don't say, but, are you viewing hidden files while you're looking in the filesystem? Pressing ctrl+h ??
Lenovo ThinkPad T61 LM16-64 bit Intel T7500/2.2GHz/Cinammon 1.8 Intel GM965. Toshiba Satellite M70: LM16-32bit. Desktop:LM13 Maya 64 bit, on new Intel 3.2ghz proc/asus MB/8gb RAM
User avatar
daveinuk
Level 5
Level 5
 
Posts: 977
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.

Re: Copying to USB pen drive very slow

Postby pelleoss on Tue Nov 12, 2013 8:10 am

beatink wrote:I have exactly the same problem and no matter what USB pendrive I use. And like as Claudio described, copying to the external HDD happens in a flash. There is an article on Archlinux (https://wiki.archlinux.org/index.php/US ... ge_Devices) discussing this problem and suggesting the following fix

If you experienced slow copy speed to pendrive (mainly in KDE), then append these three lines in a systemd tmpfile:

/etc/tmpfiles.d/local.conf

w /sys/kernel/mm/transparent_hugepage/enabled - - - - madvise
w /sys/kernel/mm/transparent_hugepage/defrag - - - - madvise
w /sys/kernel/mm/transparent_hugepage/khugepaged/defrag - - - - 0


However, I can't for the life of me find that directory or file.

Ron


Hi Ron,
I updated to LM15.
Despite now SystemD is present, there was no /etc/tmpfiles.d/ directory.
So I created it and I created also the local.conf file, filled with the line you suggested. I fixed the permissions (rwx/r-x/r-x)
Now I can copy to USB sticks with 3MB/s speed: it can be still quite slow (not sure if it is a 2.0 or 3.0) but at least the progress bar follows the transfer and I have no long wait time at the end with everything stuck.

Don't know if this can work also with LM13.
---------------------------------------------------------------------
Sony Vaio VGN-NW11S running LM 15 KDE 64 bit (dual boot Win7)
User avatar
pelleoss
Level 1
Level 1
 
Posts: 23
Joined: Sat Nov 17, 2012 9:39 am

Re: Copying to USB pen drive very slow

Postby ajgreeny on Tue Nov 12, 2013 9:15 am

There was a time when I was using ubuntu Lucid 10.04 that I used a newer kernel than the default, whatever that was, and suddenly my USB transfer rate went right down to hundreds of kilobytes per second instead of the expected and normal rate I had seen previously using the default kernel.

I only realised something was wrong when using rsync to backup my /home to an external drive, not a flash stick, but a normal spinning disk. I note you don't have this problem with such disks, but I just wonder if it is worth booting to an earlier kernel, if you have one, to see if it overcomes the problem.
ajgreeny
Level 3
Level 3
 
Posts: 114
Joined: Mon Nov 19, 2007 3:27 pm

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 4 guests