samba-mounter looses login credentials

Forum rules
Before you post please read this

samba-mounter looses login credentials

Postby mekanix on Wed Feb 19, 2014 3:54 am

I have an issue with the samba automount in kde - it looses my login credentials and get logged in as guest (ftp) instead of my username (mekanix).

I am using Linux Mint 16 (KDE flavour) 64bit and I am trying to connect to a NAS (Nas4Free).

These are the steps I am taking:

1) System-Setting -> Sharing -> Network Drive.
2) Setting up a network share with my login credentials.
3) On the NAS I can see this bit in the log:

Code: Select all
Feb 19 08:28:09   nas4free   smbd[23534]: 10.0.0.108 (10.0.0.108) connect to service artigo initially as user ftp (uid=21, gid=50) (pid 23534)
Feb 19 08:27:56   nas4free   smbd[23533]: thinkpadedgemint (10.0.0.108) connect to service artigo initially as user mekanix (uid=1000, gid=31) (pid 23533)


As you can see I do get logged in correctly but shortly after I get logged in as ftp instead (I haven't done anything on the client side after step 2).

4) Returning to the setup of auto mounter I can see that my login credentials are gone and I cannot change them. Can only delete and recreate.
5) Deleting the entry and use Dolphin to enter the share

Code: Select all
Feb 19 08:37:35   nas4free   smbd[23548]: thinkpadedgemint (10.0.0.108) connect to service artigo initially as user mekanix (uid=1000, gid=31) (pid 23548)


And I have not issues (can delete/create etc. as I am supposed).

Anyone have an idea to what's up?

- Bjarne
mekanix
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 18, 2014 4:28 pm

Linux Mint is funded by ads and donations.
 

Re: samba-mounter looses login credentials

Postby mekanix on Thu Feb 20, 2014 8:38 am

Question: Where is samba-mounter supposed to store username/password and configuration? I can't find any entries in kwallet or in .kde/share/apps/

Also did a bit more digging. The part where I get logged in as mekanix is part of the "browsing". If I remove my username/login from "Samba Shares" in System-settings it defaults to guest (ftp).

I also tried removing guest-access from the share (on the NAS) which just prompt an access denied response when trying to access/mount.

So it looks like samba-mounter default to log in as guest and there is no way to force it to use username/password. :-/
mekanix
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 18, 2014 4:28 pm

Re: samba-mounter looses login credentials

Postby altair4 on Thu Feb 20, 2014 9:22 am

I'm not a frequent KDE user so I can't answer your questions but if you don't get a "real" answer here you might consider AutoFS since this seems like a share you access often.

Here's a HowTo: Auto Mounting Samba Shares Using AutoFS

Note: I do have Mint15 KDE in a VBox guest for times like this and following the HowTo worked as advertised so it might for you as well.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6080
Joined: Tue Feb 03, 2009 10:27 am

Re: samba-mounter looses login credentials

Postby mekanix on Thu Apr 24, 2014 2:50 am

Stumbled over this bugreport: https://bugs.launchpad.net/linuxmint/+b ... mments=all

Seems like samba-mounter doesn't have any code to store (and use) username/password. So it is quite incomplete. :(
mekanix
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 18, 2014 4:28 pm


Return to KDE

Who is online

Users browsing this forum: No registered users and 3 guests