Linux Mint 6 KDE RC1

Forum rules
Before you post please read this

Linux Mint 6 KDE RC1

Postby debug on Mon Mar 02, 2009 7:51 am

Hi,

This is my first post here. I've been a Linux Mint user for quite some time (dual boot with XP) on an ASUS G1 S laptop. I've had Elyssa for quite sometime now (after moving on from Ubuntu Gutsy which didn't go quite well for me, maybe because my laptop hardware was not fully compatible with some of the stuff/drivers), but LM 5 has till now been rock solid on my laptop [EnvyNG, Compiz, Power Management etc. have all worked really well].
Eventually, I've wanted to migrate from Gnome (which is all nice, but, well, a bit boring, should I say) and try KDE, both for the interface and because I wanted to try the KDE apps.
So against Clem's warnings, I upgraded from LM 5 to LM 6 (and broke my nvidia drivers, grub, xconf), but after a lot of Google sessions, eventually fixed them :) , and then installed KDE from the ubuntu-experimental repos. at launchpad. On reboot, logging into the KDE session threw a splash of KDE 4.1 so I though confused, since I obviously wanted to install KDE 4.2 on Felicia. Some plasmoids and stuff (user panel) etc. didn't work pretty well, and I got some crashes and system restarts [linux version of bsod] when I ran Firefox etc.
Well, so I finally downloaded Felicia KDE RC1 today from the Italian LM site, and ran the Live CD session, and have really liked it. I had some initial hiccup when the Live CD booted in and set the default screen brightness to the lowest setting. After some amount of hunting around searching for a brightness applet which I couldn't find, I realized that my default ASUS G1 S Special Fn keys worked Out of the Box!!! :D Now that's really really cool !!!
Wireless also got detected (Intel 4965 wireless card) automatically, and got setup without hitches. [That's my biggest requirement since I only have a wireless net connection]. I've seen some users post that the default wireless setup is broken with Felicia, so just wanted to mention this.
Tested FireFox. Worked OK.

Just wanted to put in a post for other ASUS laptop users that things are really working fine with the Live CD. [ I havn't tried hibernate and other power management stuff, just so that you know].

Now I'm planning to do a fresh install tonight over my old Linux setup. Will let you guys know how it went. Hopefully it'll rock!!!

Also a round of thanks to all Ubuntu + Linux Mint + KDE folks for an awesome job. [and sorry if the post is too long].

PS: Just wanted to know if it will be possible to upgrade my RC1 LM 6 KDE install to the final release version once it comes out, or if I'll have to go in again for a fresh LM 6 KDE (final release) iso download and install (which I very much want to avoid :D ).

Thanks.
Debug.
debug
Level 1
Level 1
 
Posts: 8
Joined: Mon Mar 02, 2009 6:01 am

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 6 KDE RC1

Postby foggytown on Mon Mar 02, 2009 10:56 am

Hey debug,
Probably not the answer you want to hear, but it depends. It depends how many changes there are between the RC and the final release.
While I have no inside information, historically there has been an upgrade path from the RC to the final...but once again, it depends on how stable the RC is.
I did not mean to talk around your question, but I hope that helps.
Facts do not cease to exist because they are ignored.
--Aldous Huxley
User avatar
foggytown
Level 3
Level 3
 
Posts: 138
Joined: Sun Oct 07, 2007 4:54 pm
Location: Berkeley, CA usa

Re: Linux Mint 6 KDE RC1

Postby debug on Tue Mar 03, 2009 5:59 am

Ok, so I got around to installing LM 6 KDE RC1 on my system (and after wasting hours resolving a bad partition table issue, where the Live CD GParted tool was unable to detect my existing hard disk partitions, and showed the whole drive as unallocated space), I finally got the install done successfully.
EnvyNG installed the Nvidia drivers properly. Overall, everything looks pretty good.
A couple of issues that I'm facing now are -

1) my screen brightness gets reset back to the lowest setting every time I boot into system.

2) I'm unable to drag and move the panel widgets even though they are not locked to the panel.

3) The system date time settings is unable to contact the time server, and doesn't let me change the time and zone settings (internet is connected).

4) Some of the KDE apps are simply quitting at times (not always) without any notification when I click on them.

5) Desktop effects are not enabled, and reports that the Compiz engine needs to be installed first (I've been assuming that Compiz should be available by default in the install packages, so please correct me if I'm wrong). Apparently this is an Ubuntu 8.10 issue, though I'm not on any Intel Graphics card, but a GeForce 8600GT. I'm going to try out this suggestion http://forums.linuxmint.com/viewtopic.php?f=59&t=20538#p126147 and post back later.

6) I can increase the Folder View widget size horizontally by dragging on the [] control, but can't increase the size vertically. Dragging downwards on the [] control reduces the folder view widget height. This widget also cannot be re-sized by dragging at the borders. I guess I'll be reverting back to the traditional desktop http://hanswchen.wordpress.com/2009/01/29/plasma-desktop-icons-in-kde-42/ option for now and live with that.

Well, even though it's a list made only after some hours of usage, please remember that this is still a RC1 release, and a lot of things may be changing further down the line, so hopefully these points will get noticed as change/improvement requests by the Mint KDE folks.

If I should be putting these points in a different section (bug reports etc.), do let me know. I'm unaware of any such section/post under Mint KDE forum as of now.

Debug.
debug
Level 1
Level 1
 
Posts: 8
Joined: Mon Mar 02, 2009 6:01 am

Re: Linux Mint 6 KDE RC1

Postby debug on Wed Mar 04, 2009 5:38 am

Also check my latest post on the bug report thread here http://forums.linuxmint.com/viewtopic.php?f=143&t=22787&p=133663#p133663 for more details about Mint 6 KDE RC1.
debug
Level 1
Level 1
 
Posts: 8
Joined: Mon Mar 02, 2009 6:01 am


Return to KDE

Who is online

Users browsing this forum: No registered users and 5 guests