My Linux journey and some help with a plasmoid, please

Forum rules
Before you post please read how to get help

My Linux journey and some help with a plasmoid, please

Postby AKiRa121 on Thu Apr 16, 2009 1:35 am

Hi everybody :D ,
This is the first topic I'm writing. I started using Linux like a year ago, right after I read the "no viruses" legend and all that stuff. I tried everything (GNewSense, Fedora, Open SuSe, Mandriva, Ubuntu, Kubuntu) until I found Mint, like four months ago (I'm the only person from Mexico, in the frappr Map). Since then I stopped using Winbugs, and, like a recovery program I've been clean all this time (just for today, I will not use Winbugs). Yeah, well, after that very bad joke... :lol:
I have to say it, it was easier than I thought (yeah, well, easier after I read every tutorial and howto I could find in google), I had used Winbugs since I was eight and when I started using Gnome made myself at home, but after I saw KDE4 I fell in love, I had to have it.
I waited for the final KDE Mint release, and when it was ready I downloaded it and installed it.
Now I'm very happy with the result, I mean, I'm not an expert when it comes tu use Linux, when I first installed Ubuntu I lost all my data and had to format and partitionate my disk like three times before I learnt how to do it the right way :oops: . But now I've learnt the basics, use the terminal, use the software manager and, in a certain way, I've taken everything my old PentiumIV, 2.00ghz, 1gb ram and a GeForceFX5200 has to give.
Now I've started customizing my KDE4.2, and I think it starts looking really nice (snapshot down) but I want to install this plasmoid: http://www.kde-look.org/content/show.php/STasks?content=99739 and I haven't been able to do it.
When I follow the instructions to install it in the console I get this:

reves@reves-desktop ~/Descargas/stasks-0.5.1/build $ cmake ../ -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:72 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/reves/.kde/share/apps;/usr/share/mintkde-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:1 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring done


If anybody could help me to install this, I'd be very grateful.

Well, thank you for taking the time for reading my story (if you did), and here is my Desktop Snapshot (I know is not the big deal, but go ahead, do any question or suggestion):
Image
Uh, and sorry if you don't understand what I try to say or wrote... I haven't practised my English in a long time.
Image
The GIMP pimp... apprentice!!!
User avatar
AKiRa121
Level 1
Level 1
 
Posts: 29
Joined: Mon Mar 16, 2009 3:01 pm
Location: Mexico

Linux Mint is funded by ads and donations.
 

Re: My Linux journey and some help with a plasmoid, please

Postby cspack on Thu Apr 16, 2009 2:32 am

try:

sudo apt-get install cmake

you will probably need kdelibs5-dev also.
cspack
Level 1
Level 1
 
Posts: 5
Joined: Mon Apr 06, 2009 3:59 pm

Re: My Linux journey and some help with a plasmoid, please

Postby hoppy785 on Thu Apr 16, 2009 7:17 pm

hey the post above is correct make sure you have cmake... make sure you have ubuntu backports and experimental repo (important or you will have dependency issues) checked on in synaptic and get the following libkonq5-dev, libkonq5, cmake, libplasma-dev, kdelibs5-dev, kdebase-dev-kde4 as well as gcc-3.3base, and g++.... these are the basics packages needed to compile most plasmoids... some will require more than this, i believe stasks is one of them... if you get an error after all this post it and i will help you find the needed package.
hoppy785
Level 1
Level 1
 
Posts: 26
Joined: Tue Mar 24, 2009 1:06 am


Return to KDE

Who is online

Users browsing this forum: konjad and 0 guests