How do I install libmtp 0.3.5-1 ?

Forum rules
Before you post please read this

How do I install libmtp 0.3.5-1 ?

Postby anthony2010 on Mon May 04, 2009 6:18 pm

Hi all.

I have a samsung q1. Id love to have this player read by my KDE. So I posted on an outer site regarding this and got the following response:

"got my Samsung Yp-Q1 finaly working under Ubuntu 9.04.
I had to install the newer libmtp 0.3.5-1, because Ubuntu 9.04 has the libmtp 0.3.0.
So i added this ppa from this site https://edge.launchpad.net/~mieszkoslus ... chive/ppa/
Than i updatet libmtp and than i created a group "audio" with the number "660" and added root and myself to this group. After a restart I can connect with amarok to my q1."

Oh how I wish I knew what exactly to download and once downloaded as a tar.gz or Tar.bz ( whichever) what do do with it! Ive never been able to figure out this un tar 'ing malarchy!

Could someone help me please? Im soooo out of my depth here!

anyone!

ant.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Linux Mint is funded by ads and donations.
 

Re: How do I install libmtp 0.3.5-1 ?

Postby Boo on Wed May 06, 2009 2:19 am

it is a repository you added so it should install the deb binary, no tarball hopefully.

edit /etc/atp/sources.list and add
deb http://ppa.launchpad.net/mieszkoslusarczyk/ppa/ubuntu jaunty main
save and close, change jaunty to intrepid if other entries in sources.list are using intrepid.
now you have to add the key
so follow the instructions given from the link

or
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 071013EE

sudo apt-get update
sudo apt-get install libmtp

try that
boo
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: How do I install libmtp 0.3.5-1 ?

Postby anthony2010 on Wed May 06, 2009 2:49 pm

Hi Boo.

Please forgive, I could not make any sense of that.

I havent added any repositories. I wouldn't know how to.

I really need a janet and John version of your post. Open this, do that, click this, make a cup of tea, start that and finish with this, kind of delivery!

Any chance? Please?

I went to the link and got to jaunty main but there were so many options, I didnt know what to do.

ant.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Re: How do I install libmtp 0.3.5-1 ?

Postby anthony2010 on Thu Jun 04, 2009 11:30 am

Hi, its a while on now and I still havent figured out how to add this repo. I get a messsage saying 'deb not found' in the terminal. Also if I try to copy and paste the key into sources.list.d I cant. I think because its in root or something.

Isnt there an easier way to install this one file? I only want my mp3 player to work with my kde.

Alternatively, for those not so technically minded ( such as myself) could we have this libmtp3.5 added to the next distribution? It would be so much easier!

Im out of my depth and the answer given assumed I had added the repo, I hadnt. The person who I quoted added it. I just dont know how to.

Please, where do I start?

ant.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Re: How do I install libmtp 0.3.5-1 ?

Postby merlwiz79 on Thu Jun 04, 2009 1:57 pm

Code: Select all
kdesudo kate /etc/atp/sources.list
Add the line(change jaunty to intrepid if on felicia):
Code: Select all
deb http://ppa.launchpad.net/mieszkoslusarczyk/ppa/ubuntu jaunty main
Save. Open konsole and run
Code: Select all
apt update && apt install libmtp
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: How do I install libmtp 0.3.5-1 ?

Postby anthony2010 on Thu Jun 04, 2009 2:23 pm

Thanks merlwiz,

I typed in :kdesudo kate /etc/atp/sources.list

I got an error message saying 'Command not found'

I also have the file for this libmtp3.5 on my desktop. There are 2 tar.gz files inside. If i cd to them and try ./configure = No joy, make and make install yeild no results either. I also tried gksu and got the bouncy cogwheel. Encouraged that something may have happenned, i then tried the next line but got 'Bash; deb; command not found'

Recently I tried adding a program from the main site and it stripped out my system. I managed to get it back, but i wonder if thats the reason no commands I put in seem to be working?

Thanks

ant.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Re: How do I install libmtp 0.3.5-1 ?

Postby merlwiz79 on Thu Jun 04, 2009 3:20 pm

This is the kdes area, you can't have kde without kdesudo.
Try gksu if you're not on kde.
Last edited by merlwiz79 on Wed Jun 17, 2009 10:17 am, edited 2 times in total.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: How do I install libmtp 0.3.5-1 ?

Postby nick on Thu Jun 04, 2009 3:37 pm

Hi

When you stripped you system here:
viewtopic.php?f=109&t=25835
Your bash commands were working OK

Have you reinstalled Kate? go to Synaptic as in previous post
and install Kate

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Re: How do I install libmtp 0.3.5-1 ?

Postby dafi on Fri Jun 05, 2009 4:44 am

or try
Code: Select all
sudo vi /etc/apt/sources.list

then hit [i] (for insert)
go down with the arrow-key
and insert
Code: Select all
deb http://ppa.launchpad.net/mieszkoslusarczyk/ppa/ubuntu jaunty main

then hit [ESC]
then type
Code: Select all
:qw

(for write and quit)
after that
Code: Select all
sudo apt-get update && sudo apt-get install libmtp
dafi
Level 1
Level 1
 
Posts: 34
Joined: Sat Sep 27, 2008 8:55 am

Re: How do I install libmtp 0.3.5-1 ?

Postby anthony2010 on Fri Jun 05, 2009 11:34 am

hiyas all. Thanks so much for the help thus far.

Ive installed kate again and followed the procedure. I get the following:

W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9423A34CCA967634
W: Failed to fetch http://ubuntu.tribler.org/dists/intrepi ... ackages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.
anthony@Dragon ~ $
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Re: How do I install libmtp 0.3.5-1 ?

Postby slider on Fri Jun 05, 2009 2:19 pm

@anthony

Boo tried to tell you in the beginning! :) You need to add the key. Take things from the start again and check everything as you go. Text you see in the "code select all" boxes can be copy and pasted to where ever you need to put them. When you see the word "run" paste that into a terminal ok.

First add the repository. Run:
Code: Select all
kdesu kate /etc/apt/sources.list


When the text editor comes up copy and paste this
Code: Select all

deb http://ppa.launchpad.net/mieszkoslusarczyk/ppa/ubuntu intrepid main
to the file and save and close. (from what I read there the package that you want has been backported to Intrepid)

Now you need to add the key. Run:
Code: Select all
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 071013EE


Update Apt so that the system will see what you have added. Run:
Code: Select all
sudo apt-get update
Let it update and finish.

Now Install the package that your after. Run:
Code: Select all
sudo apt-get install libmtp


This should get you going. You may be able to just install the key instead of re-doing everything, but I would start afresh and recheck everything.
slider
Level 5
Level 5
 
Posts: 580
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: How do I install libmtp 0.3.5-1 ?

Postby anthony2010 on Tue Jun 16, 2009 2:48 pm

Hi there.

Im going to give up and hope that a suitable libmtp is included in a future edition of mint.

I get this:

Get: 4 ftp://cathbard.com ./ Translation-en_GB
Ign ftp://cathbard.com ./ Translation-en_GB
Hit ftp://cathbard.com ./ Release
Get: 5 ftp://cathbard.com ./ Packages
Ign ftp://cathbard.com ./ Packages
Hit ftp://cathbard.com ./ Packages
Fetched 8179B in 10s (752B/s)
Reading package lists... Done
W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9423A34CCA967634
W: You may want to run apt-get update to correct these problems
anthony@Dragon ~ $ apt-get update
E: Could not open lock file /var/lib/apt/lists/lock - open (13 Permission denied)
E: Unable to lock the list directory
anthony@Dragon ~ $


Ive had enough of wrestling with this. I just want to use my mp3 player ( which is a samsung q1) to work. It doesnt and I cant be bothered trying anymore. Please can we have this libmtp 3.5 be included in the next edition of kde?

Thanks for trying to help all.

ant.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Re: How do I install libmtp 0.3.5-1 ?

Postby dafi on Tue Jun 16, 2009 6:19 pm

anthony2010 wrote:anthony@Dragon ~ $ apt-get update
E: Could not open lock file /var/lib/apt/lists/lock - open (13 Permission denied)
E: Unable to lock the list directory

If you get a "permission denied" error in an application, you normally have to be root to do this.
so try
Code: Select all
sudo apt-get update


Or just ignore this signature error...
Code: Select all
W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9423A34CCA967634

I have also one or two every time I update my system, but it updates just fine...
dafi
Level 1
Level 1
 
Posts: 34
Joined: Sat Sep 27, 2008 8:55 am

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 5 guests