5.1 surround; gtk looks

Forum rules
Before you post please read this

5.1 surround; gtk looks

Postby rootkowski on Fri Aug 07, 2009 6:33 am

Hello!

I installed Gloria KDE a couple of days ago and I simply love it. It's not only that it looks beautiful, it also works smoothly and reliably. There are only 2 things I can't figure out:

1. how to get stereo files to play on all speakers of my 5.1 surround system. If I have 5.1 sources it works without problems - all 6 speakers produce sound, but only on VLC, not on dragon player. I have been trying to figure out what package/library takes care of the sound in Gloria KDE, and I'm quite sure it's not pulseaudio, so either phonon or/and alsa. How can I set them to play stereo files over all 6 speakers? I also noticed that when VLC uses all 6 channels I can't play sound from any other app. It feels a bit like a step two years back. I'm considering installing pulseaudio, but I'm quite hesitant because it's not exactly perfect (stuttering sound and such) and I'm not sure setting it up would be specially easy.

2. how to change the look of Gtk apps. I like the theme, but the fonts are too big and changing fonts for KDE doesn't influence gtk (like synaptic - maybe it's just gtk apps run as root actually).

I would be very happy for some help on these two questions above.
Cheers
rootkowski
Level 3
Level 3
 
Posts: 110
Joined: Tue Jun 26, 2007 5:06 am
Location: Wirral, UK

Linux Mint is funded by ads and donations.
 

Re: 5.1 surround; gtk looks

Postby rootkowski on Fri Aug 07, 2009 5:50 pm

I sort of solved the issues above by installing mint-meta-kde into my main Gloria installation. Everything went smoothly, except a few start-up processes (nm-applet for example). I also had to play around a bit to get compiz running as it should, but that required just to install emerald. Anyway, now I have Gloria main edition with KDE4.3 running smoothly and beautifully. I can easily change settings for gnome apps as well as kde. PulseAudio had been installed already, so no news there. I have had a problem with PA though (very annoying stuttering and other glitches) and have done a lot of googling about it. Now i settled with resample-method = ffmpeg, default-fragments = 5 and default-fragment-size-msec = 5. Seems to be working quite ok (meaning the stuttering occurs very seldom).

Cheers
rootkowski
Level 3
Level 3
 
Posts: 110
Joined: Tue Jun 26, 2007 5:06 am
Location: Wirral, UK

Re: 5.1 surround; gtk looks

Postby richyrich on Fri Aug 07, 2009 6:07 pm

GTK Apps found in the KDE forum:

viewtopic.php?f=109&t=29308
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: 5.1 surround; gtk looks

Postby rootkowski on Sat Aug 08, 2009 10:26 am

Thanks for that richyrich!

There is actually a file called .gtkrc-2.0-kde4 in the /root folder, but I created one called .gtkrc-2.0. Both have the same contents. Anyway, the file specifies only the theme to use. What I want to achieve is that the fonts used in Synaptic and other gtk apps run as root will be the same as in other applications. It's not a big deal, it just would be nice to be able to change it.

Cheers
rootkowski
Level 3
Level 3
 
Posts: 110
Joined: Tue Jun 26, 2007 5:06 am
Location: Wirral, UK

Re: 5.1 surround; gtk looks

Postby richyrich on Sat Aug 08, 2009 10:42 am

Hmmm . . thought that was what that thread was all about ?
it is the icons, text, and colors that I was looking to change.


Did you do a reboot as the thread suggested?
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: 5.1 surround; gtk looks

Postby rootkowski on Sat Aug 08, 2009 11:25 am

Thanks again for your help! I did a reboot, but unfortunately it didn't change anything. I also installed gtk-qt-engine to see how the settings look there. They look as they should, so I started systemsettings as root. I got some error messages. I tried with Qt 4 Settings both as desktop user and as root. Font settings are all the same (Liberation Sans 9), yet, synaptic insists on showing Sans 12 (my guess).

In the bug report it says that starting synaptic from the terminal makes it look as it should. I tried that and it's true. Suddenly the fonts look the same as the rest of the system. Anyway, I find it quite interesting that it's just font's settings that aren't applied when starting synaptic from the menu. I suppose I could change the way synaptic is started in the menu editor (run a sudo command in terminal for example). mintUpdate is a bit more difficult though, because it's a python script (I tried starting it from the terminal as well, but that didn't go so well).

Now, my other question, about sound system. Has anyone tried to install pulseaudio on Gloria KDE? Or is there any other way of getting surround sound from stereo files and being able to still use sound in more than one app at a time? I'm currently having sound issues on my main installation. I believe pulseaudio is at fault. Changing pa settings I can choose between stuttering or crackling. So I'm not exactly thrilled about installing pulseaudio.
rootkowski
Level 3
Level 3
 
Posts: 110
Joined: Tue Jun 26, 2007 5:06 am
Location: Wirral, UK

Re: 5.1 surround; gtk looks

Postby rootkowski on Mon Aug 10, 2009 2:47 pm

Just to summarize this thread I thought I would write how I finally solved my issues with KDE.

I settled down with Gloria Main + mint-meta-kde on top (I use KDE as the main desktop now). Just that fixes the problem with font sizes in gtk apps run as sudo. I obviously can play stereo files over 5.1 system since Main Edition comes with pulse audio. I had been messing up a bit with installing newer kernel and alsa & pa from a ppa, which unfortunately led to stuttering and other issues when playing music or any sounds. A lot of googling and testing different pa options went into solving that BUT NOW IT'S SOLVED. I managed to solve it by changing some options in /etc/pulse/daemon.conf.

Here is my working file:
Code: Select all
; daemonize = no
; fail = yes
; disallow-module-loading = no
; disallow-exit = no
; use-pid-file = yes
; system-instance = no
; disable-shm = no
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; high-priority = yes
; nice-level = -11

realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file =

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method = ffmpeg
; disable-remixing = no
disable-lfe-remixing = no

; flat-volumes = yes

; no-cpu-limit = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rtttime = 1000000

; default-sample-format = s16le
default-sample-rate = 48000
default-sample-channels = 6
; default-channel-map = front-left,front-right

default-fragments = 2
default-fragment-size-msec = 16


Two last options seemed to be the most crucial ones. It took quite a few guesses. Now, obviously, these settings might not work for everyone with the stuttering issues with pulse audio. My machine has Athlon64 3200+, 2GB RAM, ATI Radeon 1950 PRO, and what seems the most important in the context - SIS sound card SI7012 using snd-intel8x0 driver. On the software side, I run Linux Mint 7 Gloria, kernel 2.6.30, pulseaudio 0.9.15-3ubuntu1~ppa2, libasound2 1.0.19-1ubuntu3~ppa1 (the last to from http://ppa.launchpad.net/themuso/ppa/ubuntu/).

I hope my experiences can help others who also get problems with pulseaudio.

Cheers

UPDATE: I found another way of dealing with GTK looks within a KDE session. For details check out this: http://lists.opensuse.org/opensuse-kde/2004-12/msg00170.html. Scroll down to the answer (to create a start-up app I just went to System Settings/Advanced/Autostart and added gnome-settings-daemon).
rootkowski
Level 3
Level 3
 
Posts: 110
Joined: Tue Jun 26, 2007 5:06 am
Location: Wirral, UK

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: Jim Hauser and 1 guest