ALC882/GeForce8200 Static/Choppy/Echo Audio

Forum rules
Before you post please read this

ALC882/GeForce8200 Static/Choppy/Echo Audio

Postby rec9140 on Sat Sep 05, 2009 1:07 am

I have built a new system using the ASRock K10N780SLIX3-WiFi with Elyssa, unfortunately I've run into a problem with the audio.

Audio playback has static, choppy, and echoes.

Code: Select all
rec9140@rec9140-quad-desktop ~ $ lspci | grep Audio
00:07.0 Audio device: nVidia Corporation Unknown device 0774 (rev a1)


rec9140@rec9140-quad-desktop ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC882 Analog [ALC882 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC882 Digital [ALC882 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


I see this mentioned with other HDA Nvidia / GeForce 8200 boards, but no solutions.

No issues with gloria (using the live DVD as a test), but thanks, I do not care for kde 4.

This is an installed version, but the live DVD does it too, and fully updated, no change.

Any solutions to this short of disabling the on board audio and getting a replacement card. (KDE4/Gloria is NOT a solution).

Thanks.
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....
User avatar
rec9140
Level 5
Level 5
 
Posts: 634
Joined: Wed Mar 12, 2008 4:58 pm

Linux Mint is funded by ads and donations.
 

Re: ALC882/GeForce8200 Static/Choppy/Echo Audio

Postby rec9140 on Sat Sep 05, 2009 12:21 pm

I am trying to follow the script at
http://ubuntuforums.org/showthread.php?t=1046137

to do an upgrade to ALSA to try to fix this but no joy.

so far:

I am trying to upgrade to the latest ALSA (1.20) for use with a K10N780SLIX3-WiF HDA-NVIDIA due to choppy, staticy, and echoy audio.

Code: Select all

lspci:
00:07.0 Audio device: nVidia Corporation Unknown device 0774 (rev a1)

rec9140@rec9140-quad-desktop ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC882 Analog [ALC882 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC882 Digital [ALC882 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lshw:
 *-multimedia
          description: Audio device
          product: nVidia Corporation
          vendor: nVidia Corporation
          physical id: 7
          bus info: pci@0000:00:07.0
          version: a1
          width: 32 bits
          clock: 66MHz
          capabilities: pm msi ht bus_master cap_list
          configuration: driver=HDA Intel latency=0 maxlatency=5 mingnt=2 module
=snd_hda_intel
     *-pci:0
          description: PCI bridge
          product: nVidia Corporation
          vendor: nVidia Corporation
          physical id: 8
          bus info: pci@0000:00:08.0
          version: a1
          width: 32 bits
          clock: 66MHz
          capabilities: pci ht subtractive_decode bus_master cap_list



I am using the latest of the script posted in the first message.

First run I get:

Code: Select all
checking pkg-config is at least version 0.9.0... yes
checking for ALSA... configure: error: Package requirements (alsa >= 1.0.11) were not met:

No package 'alsa' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ALSA_CFLAGS
and ALSA_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

alsa-plugins-1.0.20 configure failed


See attachment for full log, lots of compiling info....

Looking here I did an :

Code: Select all
rec9140@rec9140-quad-desktop /var/log $ export ALSA_LIBS=/usr/src/Alsa-1.0.20/alsa-lib-1.0.20 


Which gives the second log, but still doesn't install the updated ALSA.

From uxchecker, full uxchecker -a included in attachment.

Code: Select all

-----------------------------------------------------------------------------
-    Ubuntu revision
-----------------------------------------------------------------------------

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 8.04.1
Release:        8.04
Codename:       hardy

------------------------------------------


Any one have any ideas or suggestions?

Thanks.
Attachments
alsa_upgrade.tar.gz
Logs
(30.91 KiB) Downloaded 32 times
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....
User avatar
rec9140
Level 5
Level 5
 
Posts: 634
Joined: Wed Mar 12, 2008 4:58 pm

Re: ALC882/GeForce8200 Static/Choppy/Echo Audio

Postby rec9140 on Sun Sep 06, 2009 8:16 pm

Not sure but after finding another thread about ALSA-BASE upgrades I managed to some how get this upgraded to the 1.0.20 version and the problem is solved. Clean, working, and reliable audio.

I am not sure how I managed it but when I went to use the LinuxAnt deb via:

Code: Select all
sudo dpkg --install alsa-driver-linuxant_1.0.20.3_all.deb.zip   


There was an error about something in /etc/ ??? being changed or overridden and wanted me to correct it so I hit Y to let correct it.. and after that I had working audio and the ALSA-BASE 1.0.20 was finally installed.

The audio started working BEFORE dpkg finished or a reboot, so the problem was what ever that error from the ALSA upgrade script.

I wish I could recall error or find it in the /var/log but none of the logs seem to have that info...

ok. I found the error in another log....:

Code: Select all

Configuration file `/etc/issue'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : background this process to examine the situation
 The default action is to keep your current version.
*** issue (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing base-files (--configure):
 EOF on stdin at conffile prompt
Errors were encountered while processing:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)


I got lucky that I got it installed...... since I am not sure what corrected the error the above, my Y during the linuxant install which finally showed this error on the konsole or the linuxant deb package itself.

So to sum up:

Any one looking to use this boards internal/on board audio will REQUIRE your distro to have the 1.0.18 OR LATER ALSA-BASE installed (which is why KcruDE 4.xx worked, it has 1.0.18).

The intel-hda which is alsu used by nvidia-hda driver that this included in earlier versions will not work for useable audio. It will be scractchy, echo, and choppy.

See:

See the ALSA upgrade thread here:

http://ubuntuforums.org/showthread.php?t=1046137

http://www.linuxant.com/alsa-driver/

NOTE: DO NOT accept any ALSA-BASE or hda-intel module updates or you will probably have to fix your audio again.

So KDE 3.5.10 Elyssa KMint is on my new PC, and I can finish software installs and configurig.....
Julep....mixing.....KDE Done right, and minty.
http://www.juleplinux.com

Its been a great 3 year run! Thanks for the fish.. but time for new waters....
User avatar
rec9140
Level 5
Level 5
 
Posts: 634
Joined: Wed Mar 12, 2008 4:58 pm


Return to KDE

Who is online

Users browsing this forum: Stosskraft and 3 guests