FIX - "the default gateway ip address is invalid"

Forums for the KDE Edition
Forum rules
Before you post please read this

FIX - "the default gateway ip address is invalid"

Postby leaston.h on Tue Jan 22, 2008 8:48 am

Hi,

If you aren't getting the following error when trying to setup your LAN, then this post isn't much use to you: "the default gateway ip address is invalid" :)

I just downloaded and installed KDE Beta 044 on my laptop and got an error when setting up the network card (for a LAN). After searching online, it seems this is a known bug (?). Here's the problem and the fix:

Oh, just bear in mind, I'm still a Linux noob (only been using it for a couple of years!), so this may not be very pretty! :D

Ok, when you try to set up your network card in KDENetworkManager, you go through it all and get this on screen as an error: "the default gateway ip address is invalid". My LAN is as follows and is fairly straightforward...Desktop PC with nic set to IP 192.168.0.1, laptop with Mint installed which I want to set as IP 192.168.0 23. So, the KNetworkManager program which sits in the taskbar and loads with KDE should allow me to set this up. It doesn't! From what I've read, there's a bug in the gui. So, you can enter your settings, but it won't update the config file, hence the error message.

Ignore KDENetworkManager as you can't set your LAN up with it. Open Konsole and navigate to /etc/network/ - in this folder, there's a file you need to edit called "interfaces". So, type:
sudo kate interfaces - you'll be asked for either your user or root password depending on whether you set up root with one.
Kate will open the file and you'll see something like this:
auto lo
iface lo inet loopback


This was no good for me and shows that the KDENetworkManager app hasn't worked. None of my settings are there. So, I changed mine as follows:
#auto lo
#iface lo inet loopback
iface eth0 inet static
address 192.168.0.23
netmask 255.255.255.0
gateway 192.168.0.1
auto eth0


I then saved the "interfaces" file with Kate and reopened KDENetworkManager. The settings above are now showing in the gui and the laptop is working online.

Despite the convoluted way I did it, I hope this helps someone else :mrgreen:

Regards,
Leaston
leaston.h
Level 1
Level 1
 
Posts: 25
Joined: Fri Jan 11, 2008 2:16 pm

Linux Mint is funded by ads and donations.
 

Re: FIX - "the default gateway ip address is invalid"

Postby Husse on Wed Jan 23, 2008 8:19 am

Interesting
Just a note - please use kdesu (gksudo in gnome) for GUI apps.
You may get problems accessing home else (and I've seen a post about this)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: FIX - "the default gateway ip address is invalid"

Postby Guest on Mon Aug 25, 2008 2:40 pm

I had the same problem mentioned above on an IBM Thinkpad using Debian Lenny with KDE 3.5. Strange that the GUI doesn't work - thanks though, modifying the interfaces file got me going.

For others who find this post - you can type 'man interfaces' for additional network configuration options. You might also need to specify a DNS server in /etc/resolv.conf. See 'man resolv.conf' for help.

-rdb
Guest
 


Return to KDE

Who is online

Users browsing this forum: No registered users and 4 guests