utf-8

Forum rules
Before you post please read this

utf-8

Postby lanrun on Tue Jan 22, 2008 6:35 pm

I use Daryna KDE Beta 044.
Why can't I give filenames containing æ,ø and å on my USB HDD? The HDD has the NTFS format. Is this due to trouble with utf-8, and how can it be solved?
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Linux Mint is funded by ads and donations.
 

Re: utf-8

Postby Husse on Thu Jan 24, 2008 7:30 am

It should work
Try
Code: Select all
sudo dpkg-reconfigure locales
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: utf-8

Postby lanrun on Thu Jan 24, 2008 4:24 pm

Husse wrote:It should work
Try
Code: Select all
sudo dpkg-reconfigure locales

OK:
Opened a Konsole. Typed in the command above. Executed OK. Restarted my PC. Mounted the USB HDD and opened it in Konqueror. Trying to create a folder named "øye" I get the error message: Could not make folder /media/sdf1-1/øye. Creating a folder named "hoppe" went ok.

Maybe this has something to do with how KDE is implemented? I believe it is because this works in Daryna Main edition.
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Re: utf-8

Postby Husse on Fri Jan 25, 2008 7:18 am

You have the same locale (danish I presume) in both?
I'll move this to the KDE section and maybe Boo sees it and has a solution. If it is something very KDE specific I'm not the guy to answer...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: utf-8

Postby lanrun on Fri Jan 25, 2008 9:40 am

Yes I have the same locale in both, it is norwegian. But it may be something in there for the KDE version about the add language button. It seems to me it is not possible to add norwegian. Although the system language can be set to norwegian.
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Re: utf-8

Postby Husse on Fri Jan 25, 2008 9:25 pm

There is (probably) a way to fix this in the terminal, I'll have to look it up
What does
Code: Select all
locale -a
give?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: utf-8

Postby lanrun on Sat Jan 26, 2008 4:56 am

Please remember that it is a difference in how the KDE version handles internal (SATA) HDD and external USB HDD. For the internal HDD it is OK with file names with æ, ø or å, but not for the USB HDD.

Well, typing sudo locale -a in the terminal, I get this:
C
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZW.utf8
nb_NO.utf8
POSIX
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Re: utf-8

Postby Husse on Sat Jan 26, 2008 8:36 pm

Sometimes thinking is disabled :)
Internal - external
Internal OK as expected
External - I fear this may have to do with USB strangely enough. USB must use some "protocol", "method" or whatever you want to call it, and that one may not handle non ascii well..
On the other hand there are USB keyboards around
*scratching my head*
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: utf-8

Postby lanrun on Sun Feb 03, 2008 1:59 pm

Husse wrote:Sometimes thinking is disabled :)
Internal - external
Internal OK as expected
External - I fear this may have to do with USB strangely enough. USB must use some "protocol", "method" or whatever you want to call it, and that one may not handle non ascii well..
On the other hand there are USB keyboards around
*scratching my head*

I have now switched over to Daryna Main edition, and this is not a problem here. My conclusion is that this has something to with KDE and how USB devices are handled there. I have tried Mandriva and it was the same thing there.
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Re: utf-8

Postby Husse on Sun Feb 03, 2008 2:23 pm

I've seen a few more problems since your original post.
There is some strange permissions problem with KDE as well...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: utf-8

Postby lanrun on Tue Mar 04, 2008 7:57 am

Is this problem solved now in the final release of Mint 4.0 KDE?
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Re: utf-8

Postby Husse on Wed Mar 05, 2008 8:08 am

I think this has to do with Policy kit and the strange "user999 access denied" error. If so we'll have to wait for Hardy to find a solution
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 4 guests