[SOLVED] Monitor turns off watching Flash screensaver is off

Forum rules
Before you post please read how to get help

[SOLVED] Monitor turns off watching Flash screensaver is off

Postby elaterite on Sun Jan 22, 2012 3:36 pm

[UPDATE: The solution is in the sixth post below.]

Problem: Watching flash in a web browser screen the goes off after 15 minutes or so.

Yes, I have turned off all screensavers and power management in both OS and Bios. (At least all that I could find.) I've even tried uninstalling both xscreensaver and kscreensaver.

Equipment and distro:
Lenovo Thinkpad #0302-44U
Linux Mint 9 "Isadora" LTS 64bit (Package base Kubuntu, Lucid Lynx.)
Desktop KDE

Current settings:
System Settings > Screen saver > "Settings" start automatically (NOT checked).
System settings > Advanced > Power Management & Edit Profiles > I went through and unchecked everything, set everything to "Performance" and set all of the dialog boxes to "Do Nothing".

I also checked in my bios at start up for power-saving settings and assured they we off &c.

This problem (annoyance) seems to be quite prevalent with a lot of people complaining about it on a variety of Linux forums.

Thus far I have found two solutions:

1) A script at this http://ubuntuforums.org/archive/index.php/t-1090393.html which I've not tried because it seems insanely complicated for solving such a simple problem, and it's written for Gnome. There was one written for KDE however. I'll go back and see if I can get it to work if no one can come up with a simpler solution in this thread. Also, it's just the script (many versions) and it says nothing about in which directory it should be placed, how to make it active, or how to set the permissions on it--all things I need to know to use it. (I'm not very good with using scripts.)

2) And this http://silviumc.wordpress.com/2011/12/05/how-to-stop-the-screen-saver-in-kde-while-watching-long-flash-clips-in-a-web-browser/ which suggests running the following at the command line:
Code: Select all
while /bin/true; do qdbus org.freedesktop.ScreenSaver /ScreenSaver SimulateUserActivity > /dev/null; sleep 1m; done


Number (2) worked great, however, when I was trying to send the Flash stream out to my TV in the front room via the HDMI port and a long cable--the TV screen blanked out while the monitor on the laptop remained on!

So clearly, the command in number (2) only works for the laptop monitor but not the HDMI port. Oy vei.

Thoughts anyone? And thanks in advance for reviewing this question! :)
Last edited by elaterite on Mon Jan 23, 2012 9:12 pm, edited 2 times in total.
elaterite
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 22, 2012 3:24 pm

Linux Mint is funded by ads and donations.
 

Re: Monitor turns off watching Flash (screensaver is off)

Postby tdockery97 on Sun Jan 22, 2012 6:38 pm

For a temporary solution (at least for the time you are logged in) you can run the following 2 commands in the terminal:

Code: Select all
xset -dpms


Code: Select all
xset s off


If you put them in a script saved as a hidden file in your /home directory, you can add it to your startup applications to do it automatically each time you boot.
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4909
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: Monitor turns off watching Flash (screensaver is off)

Postby elaterite on Mon Jan 23, 2012 3:39 am

tdockery97 wrote:For a temporary solution (at least for the time you are logged in) you can run the following 2 commands in the terminal:

Code: Select all
xset -dpms


Code: Select all
xset s off


If you put them in a script saved as a hidden file in your /home directory, you can add it to your startup applications to do it automatically each time you boot.



Thanks tdockery, but your commands did not work when I tried them as root. When I ran the commands they both returned:
No Protocol Specified
xset: unable to open display ":0.0"

Anymore thoughts?

It does seem, according to the other threads I've read on this topic, that whatever the DPMS is it's what's causing the problem. Somewhere (not in xorg though) I imagine there's a line something like: "DPMS=TRUE 10" (10 for ten minutes). But I can't seem to find the file. Do you know where the DPMS file is? If I could just change it to FALSE then everything would be OK. (I'm guessing.)
elaterite
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 22, 2012 3:24 pm

Re: Monitor turns off watching Flash (screensaver is off)

Postby tdockery97 on Mon Jan 23, 2012 4:24 am

You don't run it as root. Run the command as your normal user. When you run the commands, you won't see it do anything; it will just return to command prompt.
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4909
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: Monitor turns off watching Flash (screensaver is off)

Postby senseiski on Mon Jan 23, 2012 6:02 am

Have you tried Caffeine? It is a really handy application when it comes to preventing you display from going blank while watching flash videos. :)
User avatar
senseiski
Level 1
Level 1
 
Posts: 34
Joined: Sun Jul 12, 2009 2:47 pm

Re: [SOLVED] Monitor turns off watching Flash screensaver is

Postby elaterite on Mon Jan 23, 2012 8:59 pm

OK, I'm marking this thread as SOLVED.

Yes, I've seen Caffine, however, for some reason I elected not to try it. May be it was because it's Gnome based, but I forget?

For anyone else having this problem and reading this thread, tdockery's solution works if you run the following commands in terminal (as yourself, not as root):

Code: Select all
xset -dpms


Code: Select all
xset s off


Additionally, for people having problems with the audio when trying to stream Flash out of their HDMI port to another monitor/TV a solution is posted at the follwoing link: https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#HDMI_Output_Does_Not_Work

Thanks everyone!
elaterite
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 22, 2012 3:24 pm

Re: Monitor turns off watching Flash (screensaver is off)

Postby Ebere on Sat Jan 28, 2012 4:14 pm

tdockery97 wrote:For a temporary solution (at least for the time you are logged in) you can run the following 2 commands in the terminal:

Code: Select all
xset -dpms


Code: Select all
xset s off


If you put them in a script saved as a hidden file in your /home directory, you can add it to your startup applications to do it automatically each time you boot.


HowIdodat ?

"The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)
Ebere
Level 3
Level 3
 
Posts: 140
Joined: Mon Apr 26, 2010 7:47 pm
Location: Index, Wa. The great northwet

Re: Monitor turns off watching Flash (screensaver is off)

Postby elaterite on Sat Jan 28, 2012 5:16 pm

Ebere wrote:
tdockery97 wrote:For a temporary solution (at least for the time you are logged in) you can run the following 2 commands in the terminal:

Code: Select all
xset -dpms


Code: Select all
xset s off


If you put them in a script saved as a hidden file in your /home directory, you can add it to your startup applications to do it automatically each time you boot.


HowIdodat ?


How do you do what, run the commands or create a script?

To run the commands, open a terminal (in KDE: App Launcher (Start Button) > System > Konsole), and run each of the codes above one at a time by typing at the command promt: xset -dpms (hit enter) and then xset s off (hit enter). Close Knsole and you are done.

As far as the script, I can't help with that, however, this link http://www.linfo.org/create_shell_1.html should help you. Looks pretty easy if you read through it.
elaterite
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 22, 2012 3:24 pm

Re: [SOLVED] Monitor turns off watching Flash screensaver is

Postby ashtonford on Sun Jun 17, 2012 12:57 pm

why would mint put out a distro that you dont have a option to turn off the screen saver off? totally insane. That is a major complaint alot of people have been having. Shouldent have to go in editing start up files etc. Just a simple never option in the screen saver would be usefull. Could this be done as a update?
User avatar
ashtonford
Level 2
Level 2
 
Posts: 79
Joined: Thu Aug 11, 2011 2:55 pm

Re: [SOLVED] Monitor turns off watching Flash screensaver is

Postby BostonPeng on Mon Jun 18, 2012 9:04 am

Actually it should be very easy to disable the screensaver right within KDE. You should be able to go to System Settings > Display and Monitor > Screen Saver and clear the checkbox for Start automatically after:. At least that's how KDE 4.8.3 does it but it should be similar in the version of KDE you're running. I can snag a screenshot if you need me to.

ETA: You should also be able to get to that screen directly from the Run Command Interface by looking for Screen Saver.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 4 guests