Knetworkmanager no longer opening on boot [SOLVED]

Forums for the KDE Edition
Forum rules
Before you post please read this

Knetworkmanager no longer opening on boot [SOLVED]

Postby phd7 on Mon Mar 26, 2012 4:24 pm

I believe it has something to do with connecting to my VU+ duo. I had it running for a while and one day ig got some message whivh finished with "Knetwork manager will start automatically or some such. To get it running, I have to type "sudo knetworkmanager" in a terminal. Then Ican activate broadband but not the wired connection.


Typing without the sudo gives me:

mint@dell ~ $ knetworkmanager
mint@dell ~ $ knetworkmanager(2751)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
knetworkmanager(2751)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_networkmanager07.so" does not offer a qt_plugin_instance function.

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)



QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout

DIDNT OPEN
-----------------

With sudo (before activating dongle):

mint@dell ~ $ sudo knetworkmanager
[sudo] password for mint:
Error: "/var/tmp/kdecache-mint" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-mint" is owned by uid 1000 instead of uid 0.
knetworkmanager(2784)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_networkmanager07.so" does not offer a qt_plugin_instance function.

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)



QSystemTrayIcon::setVisible: No Icon set
QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
mint@dell ~ $ Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter

upon activating dongle...

Object::disconnect: Unexpected null parameter
KCrash: Application 'knetworkmanager' crashing...
sock_file=/home/mint/.kde/socket-dell/kdeinit4__0
Last edited by phd7 on Sat May 12, 2012 4:24 pm, edited 1 time in total.
phd7
Level 3
Level 3
 
Posts: 188
Joined: Wed Feb 04, 2009 6:34 am

Linux Mint is funded by ads and donations.
 

Re: Knetworkmanager no longer opening on boot

Postby Electroman6913 on Thu May 03, 2012 5:57 pm

At start up do you notice what it says while starting the network daemon.

Another good way to see what is going on is to restart the network daemon with /etc/rc.d/network restart
Electroman6913
Level 2
Level 2
 
Posts: 74
Joined: Mon May 30, 2011 6:57 pm

Re: Knetworkmanager no longer opening on boot

Postby phd7 on Sat May 12, 2012 4:23 pm

Thanks.
I sorted it by chowning these 2 back to me:

Error: "/var/tmp/kdecache-mint" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-mint" is owned by uid 1000 instead of uid 0.
phd7
Level 3
Level 3
 
Posts: 188
Joined: Wed Feb 04, 2009 6:34 am


Return to KDE

Who is online

Users browsing this forum: No registered users and 8 guests