External HDD does not properly eject. [AMENDED]

Forum rules
Before you post please read this

External HDD does not properly eject. [AMENDED]

Postby Intio on Sun Apr 29, 2012 5:07 pm

Ever since switching out my Gnome UP3 LMDE installation for the XFCE UP4 edition, I have noticed that my external USB backup HDD does not correctly spin down after clicking "Eject" (either from the right-click menu or from within Thunar) and so even though the drive appears safe to remove, unplugging the USB cable causes a grinding sound as the platters come to a halt. This didn't happened until the XFCE UP4 install, the HDD would spin down and could then be removed.

USB flash memory stick are unaffected by this, even the LED's on them will go out if I select eject.

Can anyone give me a terminal command I can used to 'instruct' the drive to spin down into it's 'safe' state before I remove the USB cable?
Last edited by Intio on Tue May 01, 2012 5:46 pm, edited 1 time in total.
Asus Eee 701 Netbook - 2GB OCZ RAM
Debian Edition - Xfce
Intio
Level 3
Level 3
 
Posts: 107
Joined: Tue Dec 01, 2009 2:16 pm

Linux Mint is funded by ads and donations.
 

Re: External HDD does not properly eject.

Postby Intio on Tue May 01, 2012 5:45 pm

I tried the simple

Code: Select all
sudo eject /dev/sdc


command and this did the trick, spinning the drive down then ejecting. Strangely no GUI "Eject" option did the same thing within Xfce.

Is there some file I can edit to amend this, rather than creating my own "Eject HDD.sh" file?
Asus Eee 701 Netbook - 2GB OCZ RAM
Debian Edition - Xfce
Intio
Level 3
Level 3
 
Posts: 107
Joined: Tue Dec 01, 2009 2:16 pm

Re: External HDD does not properly eject. [AMENDED]

Postby kuckunniwi on Thu Dec 13, 2012 7:06 am

I'm having the same problem on Mint 13 xfce (amd64 AND i386)
kuckunniwi
Level 1
Level 1
 
Posts: 7
Joined: Thu Dec 13, 2012 7:04 am

Re: External HDD does not properly eject. [AMENDED]

Postby zerozero on Thu Dec 13, 2012 12:19 pm

kuckunniwi,
this topic refers to a different edition of mint and is over 6 months old; you should open a specific topic for your issue.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm


Return to XFCE

Who is online

Users browsing this forum: No registered users and 5 guests