Can't get Xfce login screen to use German keyboard

Forums for the Xfce Edition
Forum rules
Before you post please read this

Can't get Xfce login screen to use German keyboard

Postby dman on Tue May 08, 2012 7:27 am

I installed LMDE Xfce 32-bit in English on an older machine. It's working fine, but the machine is intended for a German friend. After lots of cavorting, I got the German environment to load for users who want that and the keyboard localization to switch back and forth easily. It took quite a bit more hacking to get the login screen to switch to German, but I finally did that, too.

What I did not succeed at was getting the Xfce login screen to use a German keyboard even when the displayed environment is German. Help?
dman
Level 1
Level 1
 
Posts: 22
Joined: Sat May 05, 2012 9:28 am

Linux Mint is funded by ads and donations.
 

Re: Can't get Xfce login screen to use German keyboard

Postby jjaythomas on Tue May 08, 2012 1:10 pm

Because the login screen loads before the actual Desktop Enviroment (XFCE) it must be set at install time or the boot parameters must be modified.

Easiest is to install in German and then change the language/keyboard to English at the DE level (to setup tweak ect.) then switch back to german.

I would think their is a setting of MDM itself that would do it. (Don't know, I Speak/write American English (sometimes not coherent :mrgreen: ) only.

P.S. I've done it to where a recycled computer was Intended for a 'mostly Spanish/mexican family' the kids spoke (alot) better English tho

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Can't get Xfce login screen to use German keyboard

Postby dman on Tue May 08, 2012 7:08 pm

jjaythomas wrote:Because the login screen loads before the actual Desktop Enviroment (XFCE) it must be set at install time or the boot parameters must be modified.


Well, sure. But there is some setting that can be changed. "Your mission, Jim, is to find that setting, and change it." :-)

As I said, I did manage to change the displayed language on the Xfce login screen to German. So obviously these things can be changed. (It wasn't all that easy.) There will be a similar change to redefine the system keyboard.

jjaythomas wrote:Easiest is to install in German and then change the language/keyboard to English at the DE level (to setup tweak ect.) then switch back to german.


Somehow that seems like caving to me.

jjaythomas wrote:I would think their is a setting of MDM itself that would do it. (Don't know, I Speak/write American English (sometimes not coherent :mrgreen: ) only.


I'll not mention, then, that I teach English grammar. Nor will I hint at the two mistakes in your quoted line. :twisted:

No, don't worry, I'm not going to start grammar-flaming folks here -- though I do seriously wish the board would ask us to "log in" and "log out." (The verbs are two words; the single words are nouns.)

So, back to business: what's MDM?
dman
Level 1
Level 1
 
Posts: 22
Joined: Sat May 05, 2012 9:28 am

Re: Can't get Xfce login screen to use German keyboard

Postby xenopeek on Wed May 09, 2012 2:03 pm

From reading the manpage about mdm, I figured mdmsetup was worth a shot. Tried it with:
Code: Select all
gksudo mdmsetup

You can configure a lot, but it doesn't let you configure keyboard layout (that I could find at least).

The default MDM configuration file, /usr/share/mdm/defaults.conf, has a lot of settings to tweak (override them in /etc/mdm/mdm.conf). Haven't found keyboard layout there.

MDM is a fork of GDM 2.20, so perhaps Google a bit if setting keyboard layout was possible in GDM 2.20? Sources to MDM are available online (for those that can do something with it :)) here: https://github.com/linuxmint/mdm

I did find how to change keyboard layout after login, but that doesn't help here (https://wiki.archlinux.org/index.php/GD ... S-keyboard).

You can change the default locale in /etc/mdm/mdm.conf, under the section header "[greeter]". Setting is "DefaultLocale=english", you can change the locale to an option from /etc/mdm/locale.conf. Again, I don't think that helps here...

Hopefully I'm missing something here, and it is possible, but it looks like jjaythomas' approach is the way to go :wink:
Forum Rules | IRC Channel Rules
Image
Arch Linux / 64-bit / Gnome Shell
User avatar
xenopeek
Level 21
Level 21
 
Posts: 13678
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Can't get Xfce login screen to use German keyboard

Postby jjaythomas on Wed May 09, 2012 10:51 pm

Sorry (caving sometimes easier, faster, and less stress in long run...
I can't find setting either in MDM or xorg. I would think in ect/x11/xorg.config would be the place to start looking (that what passes most boot setting to the login manager.

If it's a 1 user system you can set to auto-login (I know less secure but would still need sudo/password to do anything for system.
or maybe
Set the DE (XFCE) for German and correct keyboard layout. Then use synaptic/apt to purge mdm. Restart and login at cli (command line) and reinstall mdm.
Might pick up and use German and keyboard at future logins(???)

Sorry if not much help
J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Can't get Xfce login screen to use German keyboard

Postby dman on Fri May 11, 2012 7:52 pm

Thanks to both of you, J.Jay and Vincent.

So here's what I did: (caved) -- installed anew in German. But I kept the English installation in another partition. So then I grepped all files under /etc/ on both systems for instances of "de_DE" or "en_US" and saved both lists to files. (I filtered out some obviously unrelated hits such as to do with Java config files.) Now I can run "diff" on them.

Here was my silly code:
Code: Select all
cd /etc
sudo find . -type f | grep -v ' ' | grep -v java | grep -v mplayer | xargs sudo egrep '(en_US|de_DE)' | sudo tee ../home/dman/Desktop/coffee_sda6


(The old installation is on /dev/sda5; I did the same for that.)

Here's the output from the new installation, which does have the German keyboard set at the login screen:

./mdm/locale.conf:English(USA) en_US
./mdm/locale.conf:English(USA) en_US.ISO-8859-15
./mdm/locale.conf:English(USA) en_US.UTF-8
./mdm/locale.conf:German(Germany) de_DE
./mdm/locale.conf:German(Germany) de_DE@euro
./mdm/locale.conf:German(Germany) de_DE.UTF-8
./locale.alias:deutsch de_DE.ISO-8859-1
./locale.alias:german de_DE.ISO-8859-1
./locale.gen:# de_DE ISO-8859-1
./locale.gen:# de_DE.UTF-8 UTF-8
./locale.gen:# de_DE@euro ISO-8859-15
./locale.gen:# en_US ISO-8859-1
./locale.gen:# en_US.ISO-8859-15 ISO-8859-15
./locale.gen:en_US.UTF-8 UTF-8
./locale.gen:# en_US.UTF-8 UTF-8
./locale.gen:de_DE.UTF-8 UTF-8
./default/locale:LANG=de_DE.UTF-8


And here's a diff.
Code: Select all
dman@nomo-gklm ~/Desktop $ diff -U0 coffee_sda* | grep -v '#'

--- coffee_sda5 2012-05-11 02:45:32.081903115 +0200
+++ coffee_sda6 2012-05-12 01:38:16.330936381 +0200
@@ -1,8 +0,0 @@
-./locale.gen:de_DE ISO-8859-1
-./locale.gen:de_DE.UTF-8 UTF-8
-./locale.gen:de_DE@euro ISO-8859-15
-./locale.gen:en_US ISO-8859-1
-./locale.gen:en_US.ISO-8859-15 ISO-8859-15
-./locale.gen:en_US.UTF-8 UTF-8
@@ -15,4 +6,0 @@
-./default/locale:LANG="de_DE.UTF-8"
-./default/locale:LC_MONETARY="de_DE.UTF-8"
-./default/locale:LC_NUMERIC="de_DE.UTF-8"
-./default/locale:LC_TIME="de_DE.UTF-8"
@@ -20,0 +9,9 @@
+./locale.gen:en_US.UTF-8 UTF-8
+./locale.gen:de_DE.UTF-8 UTF-8
+./default/locale:LANG=de_DE.UTF-8


Short answer, I don't see anything in there that would cause the difference in behavior. So I will have to go with what jjaythomas guessed might work and purge "mdm" on the old setup, then reinstall it -- just to see if it will succeed.

(I wonder what will happen if I try just "--reinstall" first without rebooting?)

Code: Select all
apt-get install --reinstall mdm
dman
Level 1
Level 1
 
Posts: 22
Joined: Sat May 05, 2012 9:28 am

Re: Can't get Xfce login screen to use German keyboard

Postby jjaythomas on Sat May 12, 2012 10:09 pm

That alot more then I would know/think of doing

The reason I said to purge MDM with a reboot is because a reinstall ussually will fix problems of a broxen package But will pick up the old configurations (I would think thats where its told to use what keyboard(?) and a purge will deleate confige and a reboot insure its even out of a temp/chache file).

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to Xfce

Who is online

Users browsing this forum: No registered users and 8 guests