XFCE 4.10 plugins (most not working, rare error msg?)

Forum rules
Before you post please read this

XFCE 4.10 plugins (most not working, rare error msg?)

Postby tedbell on Wed May 09, 2012 7:33 am

I posted this over at xfce...

I am getting tis error message when I try to add most of my pluging to the new 4.10:

Plugin "Weather Update" unexpectedly left the panel, do you want to restart it?
The plugin restarted more than once in the last 60 seconds. If you press Execute the panel will try to restart the plugin otherwise it will be permanently removed from the panel.

I tried googling this error but only a handful of sites come up with only 1 about xfce. Leads me to believe it's something I did.

Is there any way to fix this?

I ave the xfce goodies installed.

Other than this it works great and has nice new features. MIME type GUI among others.

Thanks
tedbell
Level 1
Level 1
 
Posts: 19
Joined: Sat Mar 17, 2012 4:34 am

Linux Mint is funded by ads and donations.
 

Re: XFCE 4.10 plugins (most not working, rare error msg?)

Postby jjaythomas on Wed May 09, 2012 11:11 pm

No
I read most of plug-ins are new and re-implemented for 4.10. (current setting may throw errors)
(remember weather plug-in when they lost the info provider :lol: ) Can't remember how long that one was useless. :roll:
So...
you may have to start a new panel and delete the old one. and re construct panel (remember the old plug-ins may or may-not work). the ones in the package manager will be mostly 4.8 versions, unless you also got replaced with newer ones (XFCE-Goodies package :?: )
Only a few come with the stock XFCE4 meta package

P.S. you can check the official XFCE site to compare plug-ins versions and what works with what
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: XFCE 4.10 plugins (most not working, rare error msg?)

Postby tedbell on Thu May 10, 2012 1:25 am

Thanks for the reply.
Turns out it the problem is something to do with the old plugins from xfce4-goodies (which I have installed) pointing to this file: libxfce4panel-1.0.so.3 when it needs to point to this: libxfce4-panel-1.0.so.4.

I get this error when I try to add the old plugins to the new panel:

/usr/lib/x86_64-linux-gnu/xfce4/panel-plugins/xfce4-weather-plugin: error while loading shared libraries: libxfce4panel-1.0.so.3: cannot open shared object file: No such file or directory
xfce4-panel-Message: Plugin weather-7 has been automatically restarted after crash.
/usr/lib/x86_64-linux-gnu/xfce4/panel-plugins/xfce4-weather-plugin: error while loading shared libraries: libxfce4panel-1.0.so.3: cannot open shared object file: No such file or directory

Any way to fix it manually?
tedbell
Level 1
Level 1
 
Posts: 19
Joined: Sat Mar 17, 2012 4:34 am

Re: XFCE 4.10 plugins (most not working, rare error msg?)

Postby jjaythomas on Thu May 10, 2012 9:54 am

So I see posted (Thank you)

I wonder if you could purge the actual plug-in in synaptic and reinstall new one :?: (from Sid :!: )
Is the xfce-goodies package available in Sid (that may have the correct plugins :?: (although you probably would need to build a fresh panel

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: XFCE 4.10 plugins (most not working, rare error msg?)

Postby jjaythomas on Sat Jun 30, 2012 5:34 pm

On the new 'LMint13-XFCE RC...

anyone planing on installing any component of xfce (like plug-ins) should activate the XFCE4.10 PPA. (reloading sources) before search/install! Be leery of anything with version 4.8 (just may not re-written yet or merged with another (probably don't work anymore), or depreciated in 4.10 (probably won't work either).

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: XFCE 4.10 plugins (most not working, rare error msg?)

Postby crispytown on Wed Jul 11, 2012 2:42 am

jjaythomas wrote:On the new 'LMint13-XFCE RC...

anyone planing on installing any component of xfce (like plug-ins) should activate the XFCE4.10 PPA. (reloading sources) before search/install! Be leery of anything with version 4.8 (just may not re-written yet or merged with another (probably don't work anymore), or depreciated in 4.10 (probably won't work either).

J.Jay


Following J.Jays instructions to add the xfce4.10 repository, this works:

sudo add-apt-repository ppa:xubuntu-dev/xfce-4.10

sudo apt-get update

sudo apt-get dist-upgrade

The update manager then prompts that you have updates and the xfce4 goodies are listed and can be updated as required. I'm using the following plugins with no errors: Mount Devices, System Load Monitor, CPU Frequency Monitor and Network Monitor.

Thanks J.Jay. :D
crispytown
Level 1
Level 1
 
Posts: 4
Joined: Wed Jul 11, 2012 1:31 am

Re: XFCE 4.10 plugins (most not working, rare error msg?)

Postby jjaythomas on Wed Jul 11, 2012 5:59 pm

That works...

But the new(ish) Mint13-XFCE RC ISO its already present (just not activated) :wink:

Easiest way to activate is from synaptic (setting menu go to repositories), go to other software tab and activate (click) box to use.

P.S. don't forget to reload (packages) on main screen before searching anything.

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 3 guests