GIMP stays in all workspaces

Forum rules
Before you post please read this

GIMP stays in all workspaces

Postby Vito49 on Thu Jun 21, 2012 4:56 am

Hello, first of all: I'm not sure this is a GIMP problem or an XFCE problem. But i think it happened after GIMP froze and I had to use ctrl/alt/del ... I'm not English but I will try to explain what happens.

I'm using Xfce 4.8.
I use 4 workspaces. When I open GIMP in a workspace everything seems to be normal, I have the main GIMP window, the toolbox and the layers-window. I can use GIMp the way it is intended, no problems.
But when I switch to another workspace, the toolbox and the layer-window are there too, NOT the main-window, and they are in all workspaces.
In fact these windows seem to be made "sticky", but there is no way to switch them to "un-sticky", I even can't move them to another workspace (there's no option to do that), this I can only do with the main-window which is only in the workspace I started GIMP in.
Another thing: when I move the main-window to another workspace all Gimp-windows disappear from the other workspaces, everything seems to be completely normal as it was before, GIMP is only in 1 workspace, but from the moment I open the workspace containing GIMP the toolbox and the layer-window are back on all workspaces ....

Confused? Me too :?
Believe me, I did almost everything possible to fix this, but nothing helps.
I would appreciate if somebody could help me to fix this problem. Feel free to ask if you need additional information.

Thanks.
Vito
Vito
Gnu/Linux user #547905 from Aarschot/Belgium
using Linux Mint 17 KDE
on an old Fujitsu Siemens desktop PC (2.8 GHz / 2 GB ram)
User avatar
Vito49
Level 2
Level 2
 
Posts: 60
Joined: Sat May 14, 2011 4:32 am
Location: Aarschot - Belgium

Linux Mint is funded by ads and donations.
 

Re: GIMP stays in all workspaces

Postby wenchkin on Wed Jun 27, 2012 9:54 am

Ok, try this...Right click on the top title bar of your Gimp window. In the drop-down menu that appears, below the maximise and minimise options etc, look for the option "Only on This Workspace" and select it.

If that fixes it, you possibly selected "Always on visible workspace" from that menu without realizing it.

Wenchy
wenchkin
Level 1
Level 1
 
Posts: 20
Joined: Sun Jun 28, 2009 12:16 pm

Re: GIMP stays in all workspaces

Postby jjaythomas on Sat Jun 30, 2012 1:53 pm

Thats a option on the context menu right clink title bar (or actual icon if shown in 'button layout from setting>Window Manager) :wink:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm


Return to XFCE

Who is online

Users browsing this forum: No registered users and 1 guest