MIDI: I want to use Timidity, not Qsynth!

Forum rules
Before you post please read this

MIDI: I want to use Timidity, not Qsynth!

Postby archtop on Sun Jul 29, 2012 6:24 pm

I have lots of MIDI type stuff I want to do (on Mint 13 Xfce), so I installed Timidity and a soundfont. Now I can play any MIDI file on the command line by doing this: "timidity examplefile.mid" and it plays the file perfectly, with all instruments playing. However, when I use a program (banshee, movie player, or others) to play a MIDI file, it plays the file but I only hear a few of the instruments playing.

I suspect (although I don't know for sure) that the programs are using Qsynth (which came with Mint 13) rather than Timidity. How can I disable Qsynth and enable Timidity as a default for these programs?
archtop
Level 1
Level 1
 
Posts: 37
Joined: Sat Jan 01, 2011 8:00 pm

Linux Mint is funded by ads and donations.
 

Re: MIDI: I want to use Timidity, not Qsynth!

Postby kyphi on Sun Jul 29, 2012 8:13 pm

I do not have qsynth installed although it is in synaptic and my midi files play fine. Why don't you go into synaptic and remove it now that you have installed Timidity. You can also get some interfaces for Timidity by installing "timidity-interfaces-extra". If you type "timidity -ia" you will get the default gnome interface, "timidity -ig" for the GTK interface and "timidity -ik" for the TKM interface.

Timidity and pmidi are all you need. The command "man pmidi" gives you lots of information, for example try the command "pmidi -l" which will list all your midi ports. For further information, see the URL below:

http://tldp.org/HOWTO/MIDI-HOWTO.html#toc1
User avatar
kyphi
Level 5
Level 5
 
Posts: 832
Joined: Sat Jul 09, 2011 1:14 am
Location: Australia


Return to XFCE

Who is online

Users browsing this forum: No registered users and 3 guests