No auto connect USB Mobile Broadband (GSM)

Forum rules
Before you post please read this

No auto connect USB Mobile Broadband (GSM)

Postby opm595 on Wed Aug 01, 2012 2:09 am

Hi Guys,
No "Biggie", but more so of an annoyance then anything else.
I've recently decided to move back to Mint and installed 13 Maya Xfce (32bit) on my laptop and I'm really impressed with this distro. However, I don't seem to be able to get my Mobile Broadband USB Modem to automatically connect. All network connections are working fine, including the Mobile Broadband, however I have to manually select it from the notification area in order to connect after startup etc. Strangely, cable and wireless connect straight away without any assistance. Therefore, I'm assuming there's something I need to tweak in Session & Startup, but not too sure where to go from there.

As mentioned, no big deal, but if anyone has any tips, tricks or suggestions on this one it would be much appreciated.
Thanks in advance.
Cheers,
Rob
Aude aliquid dignum - "Dare Something Worthy"
User avatar
opm595
Level 1
Level 1
 
Posts: 4
Joined: Sat Jul 23, 2011 12:25 am
Location: Sydney Australia

Linux Mint is funded by ads and donations.
 

Re: No auto connect USB Mobile Broadband (GSM)

Postby gblacks on Tue Aug 21, 2012 10:52 pm

Hi Rob - same problem in Maya XFCE. I have a possible solution which I will explore at a later date but the following has been my experience so far:

Firstly my hardware: Away from home (last 6 months) I use a tiny Asus netbook with the usual Celeron 1.66 GHz processor hooked up to Bigpond Mobile BB via a Sierra Ultra modem. It doesn't sound much but it's enough for my needs when travelling. I'm a Linux only user but can boot into Windows if I really need to which thankfully is almost never. Maya XFCE is without doubt the best general purpose distro currently available. They should dump Firefox and make Chromium the default browser though. I've been a Mint user/supporter since the very start and it's my OS of choice for writing, communicating, and keeping records. I keep a number of other 'buntu types on USB thumb drives for the odd day when my computing taste buds need a change. For consistency I stick to 'buntu type distros as my personal feeling is that they have set the level of the bar and the others are trying to keep up.

I'm getting there..... To date, all the 'buntu 12.04 variants I've tried need a manual Mobile BB startup. Prior to 12.04, going back maybe to 9.04, all the 'buntu variants I tried would auto-connect. Therefore something changed in 12.04 and the only item I can think of that significantly affected hardware recognition at boot time, was the kernel upgrade which came with this version. Maybe I'm on the wrong tack but I'll do some more digging when I get home to my desktop in November and I'll have more time.

I know all the above is of little help but at least you now know of someone else who has the same issue. I'll post a solution in due course if I can but hopefully someone else on this forum will get to it first. Best advice I can offer right now is "don't buy Facebook shares and never run with scissors!" :lol:
gblacks
Level 1
Level 1
 
Posts: 3
Joined: Mon Dec 03, 2007 4:39 pm
Location: Sea Lake, Victoria, Australia

Re: No auto connect USB Mobile Broadband (GSM)

Postby jjaythomas on Thu Aug 23, 2012 1:14 am

I Dont't have a mobile BB but...

If you right click 'network icon' and edit the connection is the 'auto connect' box checked? (will ask sudo/password to change)?

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: No auto connect USB Mobile Broadband (GSM)

Postby gblacks on Thu Aug 23, 2012 1:59 am

Thanks, but that checkbox doesn't make any difference with a mobile bb card for some reason. It used to in 'buntu variants prior to 12.04. Cheers anyway. :D
gblacks
Level 1
Level 1
 
Posts: 3
Joined: Mon Dec 03, 2007 4:39 pm
Location: Sea Lake, Victoria, Australia

Re: No auto connect USB Mobile Broadband (GSM)

Postby jjaythomas on Thu Aug 23, 2012 6:10 pm

sorry 'simple answers sometimes easiest to overlook. :oops:
, but that checkbox doesn't make any difference with a mobile bb card for some reason. It used to in 'buntu variants prior to 12.04. Cheers anyway. :D


I know reading 12.04 based seem to have alot of networking problems/regressions. If able to try, test 'WICD' or maybe a different kernel. :idea: I've used and had good luck with the 'Optimus kernel' thats was compiled for 12.04 desktop usage (I believe).


sorry don't have link at presant but can 'Google' 'Duck Duck' ect. to find download :wink:
J.Jay
EDIT Optimus at 3.3.7 I believe now.
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: No auto connect USB Mobile Broadband (GSM)

Postby gblacks on Thu Aug 23, 2012 8:24 pm

Thank's J.Jay - will give it a try when time permits. I'm no guru on kernels so I'll need to clone my partition before I try to massage a solution. Cheers.
gblacks
Level 1
Level 1
 
Posts: 3
Joined: Mon Dec 03, 2007 4:39 pm
Location: Sea Lake, Victoria, Australia

Re: No auto connect USB Mobile Broadband (GSM)

Postby Zorba on Thu Nov 07, 2013 7:34 pm

Image
User avatar
Zorba
Level 8
Level 8
 
Posts: 2290
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 1 guest