(Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Forums for the Xfce Edition
Forum rules
Before you post please read this

(Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby guimaster on Sat Aug 04, 2012 3:58 am

Greetings,

Is there are command that can be run from Terminal (/usr/bin/___/) to open the MintMenu in Linux Mint 13 XFCE? I cannot find one that works.

Thanks!
Last edited by guimaster on Sat Aug 04, 2012 4:28 pm, edited 1 time in total.
guimaster
Level 2
Level 2
 
Posts: 79
Joined: Sat Nov 20, 2010 2:16 am

Linux Mint is funded by ads and donations.
 

Re: Command For Mint Menu (XFApplet) In /usr/bin ?

Postby sagirfahmid3 on Sat Aug 04, 2012 9:55 am

Terminal > whereis mintmenu
/usr/bin/mintmenu

I am on Debian Squeeze btw, I had to use the source package to get mintmenu.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: Command For Mint Menu (XFApplet) In /usr/bin ?

Postby guimaster on Sat Aug 04, 2012 4:27 pm

sagirfahmid3 wrote:Terminal > whereis mintmenu
/usr/bin/mintmenu

I am on Debian Squeeze btw, I had to use the source package to get mintmenu.


Thanks. I was hoping to find a different way to get the Super Key to work with the Mint Menu in Mint 13 XFCE (by adding the start-up command for Mint Menu to the keyboard shortcuts controls). It didn't work but I found other instructions that did work. Running /usr/bin/mintmenu doesn't work properly in XFCE.

Thanks!
guimaster
Level 2
Level 2
 
Posts: 79
Joined: Sat Nov 20, 2010 2:16 am

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby stetilley on Sun Sep 23, 2012 1:10 pm

hey,

I know this is an old post, but you're the first post I've seen where someone has found a way to actually bind Super_L to open MintMenu. How did you manage it?! It's really annoying that the menu settings won't actually bind it!

Thanks in advance
stetilley
Level 1
Level 1
 
Posts: 4
Joined: Sun Sep 23, 2012 1:05 pm

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby palo on Sun Sep 23, 2012 1:55 pm

stetilley > You didn't mention your version. I did it this way: Settings>Keyboard>Application Shortcuts. You will see <Alt>F1 is used for that and I just left it as is. Press Add and enter the same command you see for F1 and OK. Then the Super key. You're done. Hope that works for you. Oh I just saw you said Mint Menu - I use the default menu so you may just have to find the command for Mint Menu if you installed it - not sure...
Trying to start Mint Menu from the terminal just brings up the icon that needs to be clicked - there is a package called mintmenu keybindings in Synaptic but no information on it. When someone says they solved the problem without saying how you just have to scratch your head.

Pat
~/mintmaya/xfce/enlightenment
Help Vampires: A Spotter's Guide
User avatar
palo
Level 4
Level 4
 
Posts: 418
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby stetilley on Sun Sep 23, 2012 3:38 pm

you, kind sir, are a genius!

went into synaptic, installed mintmenu-keybinder, restarted, fixed!

it seems very strange that mintmenu would be included with the mint install, but the package that makes its keybinding work doesn't...

ah well, sorted now :) thanks for the help!
stetilley
Level 1
Level 1
 
Posts: 4
Joined: Sun Sep 23, 2012 1:05 pm

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby caribriz on Sun Sep 23, 2012 6:47 pm

I can use the Super_L key to open mintmenu in Mint 13 xfce, but only a "minimised" mintmenu pops up in the middle of the desktop -

mintMenu popup.png
mintMenu popup.png (4.44 KiB) Viewed 2188 times


Then when you click on the icon, the mintmenu opens fully.

mintMenu in Mint 13 xfce.png
mintMenu in Mint 13 xfce.png (343.28 KiB) Viewed 2188 times


I would like to just be able to press Super_L and have it open the mintmenu from the panel icon in the bottom left of the desktop like it does in mate
and previous versions of Mint.

When I click on the icon with the mouse, it opens from the panel as it should.

I installed mintmenu-keybinder and restarted but it made no difference - it worked the same as before.

So, still looking for a solution ....

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 13 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 786
Joined: Mon Nov 28, 2011 7:43 am

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby stetilley on Mon Sep 24, 2012 7:13 pm

I would suggest checking your application shortcuts in the keyboard control panel

If you've set one in there to run "mintmenu" when you press Super_L then that's what your problem is. The command "mintmenu" starts the whole MintMenu itself up, rather than opening the one you already have.
nk of anything else
I don't know what the command for opening up the menu you have actually is, but if you make sure you don't have that shortcut set up anywhere. then go into the mintmenu preferences (right click the menu button, click preferences), you can change the shortcut to Super_L on the very first page it takes you to.

This was bugging me for days, so if that doesn't help just reply and I'll see if I can think of anything else (tried just about everything to sort this myself!)
stetilley
Level 1
Level 1
 
Posts: 4
Joined: Sun Sep 23, 2012 1:05 pm

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby caribriz on Mon Sep 24, 2012 9:54 pm

Thanks for replying, stetilley -
I did make a keyboard shortcut in Menu > Settings > Keyboard > Application Shortcuts - so I deleted it.
Restarted, and tried it again, just having Super_L in mintmenu > Preferences - Keyboard shortcut.
Unfortunately, no go.

But ..... I have managed to get it working - found this:
https://bugs.launchpad.net/linuxmint/+bug/898184

The post by J.Albert has worked for me:

1. Install python-keybinder
Code: Select all
sudo apt-get install python-keybinder

2. Download this patch: https://bugs.launchpad.net/linuxmint/+bug/898184/+attachment/3180257/+files/mintMenu.py.patch
(I saved it to Downloads folder, and then as root copied it to /usr/lib/linuxmint/mintMenu, then backed up the original mintMenu.py before proceeding)

3. Apply the attached patch to mintMenu.py
Code: Select all
cd /usr/lib/linuxmint/mintMenu
sudo patch mintMenu.py mintMenu.py.patch

4. Logged out/in.

Of course, I used Super_L, not <Control>Super_L like in the post.

So, solved for me as well now :)
caribriz

Edit: the command given initially - sudo patch /usr/lib/linuxmint/mintMenu/mintMenu.py mintMenu.py.patch
was incorrect. I copied/pasted it direct from the link. Sorry for any confusion caused. :oops:
The edited instructions above did work for me.
Last edited by caribriz on Sat Oct 13, 2012 5:31 pm, edited 2 times in total.
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 13 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 786
Joined: Mon Nov 28, 2011 7:43 am

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby stetilley on Tue Sep 25, 2012 7:25 am

glad you got it sorted :)

have to say, other than binding this button and making the mute button work both ways (mute AND unmute) I've had no trouble since installing mint 13 xfce about a week ago. first time I've used the mint distro, and I'm very happy with it :D

i had previously used ubuntu and, whilst that was fine, I never liked the gnome desktop. also, i found it bloated and overly power-hungry for my little dell mini 10. Mint seems to be perfect :)

hope you're enjoying it too!
stetilley
Level 1
Level 1
 
Posts: 4
Joined: Sun Sep 23, 2012 1:05 pm

Re: (Solved) Command For Mint Menu (XFApplet) In /usr/bin ?

Postby caribriz on Tue Sep 25, 2012 6:28 pm

I am enjoying Mint 13 xfce very much.
I also like Cinnamon ....and mate (a full install on usb stick).
Poor Mint 9 (and 10) Gnome now being ignored on my main pc :cry:

:lol:
cheers
caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 13 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 786
Joined: Mon Nov 28, 2011 7:43 am

Linux Mint is funded by ads and donations.
 

Return to Xfce

Who is online

Users browsing this forum: No registered users and 9 guests