disable screensaver/power saving (Solved)

Forum rules
Before you post please read this

disable screensaver/power saving (Solved)

Postby jonass on Sun Aug 12, 2012 5:40 pm

I am using mint xfce 13 and every 10 minutes the video goes black, frustrating when watching video, i disabled the screensaver in the gui and set the power saving options to never and it still happened. So then i deleted the ,xscreensaver file and it still did it. any other options? it is an htpc so preferably i could disable all of these power saving options
Last edited by jonass on Tue Aug 14, 2012 8:25 pm, edited 1 time in total.
jonass
Level 3
Level 3
 
Posts: 112
Joined: Wed Jun 22, 2011 7:11 pm

Linux Mint is funded by ads and donations.
 

Re: disable screensaver/power saving

Postby sagirfahmid3 on Sun Aug 12, 2012 6:13 pm

This isn't the screensaver's issue. It is actually Xorg's default settings.
Add these lines in your xorg.conf (which is located in /etc/X11/xorg.conf and you must edit the file as superuser).

Code: Select all
Section "ServerFlags"
   Option "BlankTime"   "0"
   Option "StandbyTime" "0"
   Option "SuspendTime" "0"
   Option "OffTime"     "0"
   Option "DontZap" "false"
EndSection
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: disable screensaver/power saving

Postby jonass on Mon Aug 13, 2012 1:59 am

I added the bit you gave me to the xorg.conf file and restarted the computer and it worked like a charm, thank you
jonass
Level 3
Level 3
 
Posts: 112
Joined: Wed Jun 22, 2011 7:11 pm

Re: disable screensaver/power saving

Postby sagirfahmid3 on Mon Aug 13, 2012 10:40 am

No problem. Could you please change your title and add "Solved" to it? Thanks. (Easier for other people to find).
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: disable screensaver/power saving

Postby jjaythomas on Mon Aug 13, 2012 7:30 pm

I also set screesaver and power settings to max time (2+ hours) :wink:
Can also run script to disable timeout and then a launcher (I do for a Launcher for Chromium going to 'clickertv') :wink:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: disable screensaver/power saving (Solved)

Postby jonass on Tue Aug 14, 2012 8:27 pm

Just as an after thought, what exactly is the computer doing when it turns off every 10 minutes? And why isn't there just an option to turn off as opposed to adding that to the .conf file? Is this a bug?
jonass
Level 3
Level 3
 
Posts: 112
Joined: Wed Jun 22, 2011 7:11 pm

Re: disable screensaver/power saving (Solved)

Postby sagirfahmid3 on Tue Aug 14, 2012 8:55 pm

The computer can be doing anything, it will continue to function as normal--if you left a download running in the background, it wont be interrupted, etc etc...
I don't know why there isn't an option to turn that off (these days), but, once upon a time when CRT monitors were prevalent, that technique would save your monitor from burn-in or etching from the electrons being fired at the same spot (by a stationary image) for a prolonged period of time. These days, with LCD and LED monitors making the majority and CRTs going extinct, there isn't any need at all for any kind of screensaver or auto-shut-off for the monitor (LCDs don't suffer from burn-in). So, in answer to your last question, no, it isn't a bug.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 4 guests