It's solved for me but weird problem getting Compiz to load

Forums for the Xfce Edition
Forum rules
Before you post please read this

It's solved for me but weird problem getting Compiz to load

Postby wyrdoak on Mon Aug 27, 2012 10:42 pm

With the normal way to start Compiz on startup I couldn't get the desktop to load properly without login and out, some times more than once.[ie. no panels, panels covering the whole destop, and only the wallpaper, to name a few.] :lol:

To get Compiz to load at startup in Maya-Xfce I had to, in Sessions and Startup create an entry for the Fusion-icon with the command line: fusion-icon, only then set up the desktop manager and windows decorator from it.
After a few reboots just to test that it's working, everything is working 5X5 now.

Only thing I can think is, some conflict while loading the desktop. Loading with fusion-icon and not compiz --replace delays Compiz long enough not to cause a loading problem.

I though this info might be helpful
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1310
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Linux Mint is funded by ads and donations.
 

Re: It's solved for me but weird problem getting Compiz to l

Postby jjaythomas on Wed Aug 29, 2012 12:43 am

Not sure if will work... But

I allways had to (benn atleast year since used compiz) either uninstall xfwm and xfdesktop or kill from session using 'session tab' in settings>startup and session. Then either start compiz and 'resave session' or put compiz as startup app. Not sure if compiz checks if itself running so may not save session at logout (if in startup).

J.Jay
P.S. a Xfce session will start 'xfwm' you haveto 'compiz-replace (thats what fusion icon does) or bybass xfwm running at start (as above) or they conflict. :wink:
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm


Return to Xfce

Who is online

Users browsing this forum: Exabot [Bot] and 8 guests