Prevent mint from sleeping

Forum rules
Before you post please read this

Prevent mint from sleeping

Postby Tharbad on Thu Oct 04, 2012 8:48 am

Hello,

Mint version: 13 x32

I want to prevent my system from going into sleep or suspend mode when it's idle. I don't see any possible setting like that in the power manager (I can only chose between suspend and sleep).

Thanks
Tharbad
Level 1
Level 1
 
Posts: 20
Joined: Thu Nov 24, 2011 1:56 pm

Linux Mint is funded by ads and donations.
 

Re: Prevent mint from sleeping

Postby stratus_ss on Thu Oct 04, 2012 3:09 pm

Which desktop are you using?

Mate? Cinnamon? Gnome? KDE? XFCE?

Are you sure the computer is suspended and not just turning off the monitor?
stratus_ss
Level 4
Level 4
 
Posts: 270
Joined: Fri May 25, 2012 5:22 pm

Re: Prevent mint from sleeping

Postby wyrdoak on Thu Oct 04, 2012 3:15 pm

Might try changing you screen-saver settings also. Last resort, make a .sh file and run it when you don't want your screen to sleep.

Code: Select all
#!/bin/bash
xset -dpms;xset s off
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Prevent mint from sleeping

Postby Tharbad on Thu Oct 04, 2012 5:50 pm

Screen saver is off.

Desktop is Xfce
Tharbad
Level 1
Level 1
 
Posts: 20
Joined: Thu Nov 24, 2011 1:56 pm

Re: Prevent mint from sleeping

Postby wyrdoak on Thu Oct 04, 2012 9:29 pm

Tharbad wrote:Screen saver is off.

Desktop is Xfce


Have you move your "Put the computer to sleep when inactive for:" slider over to "Never"Image
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Prevent mint from sleeping

Postby Tharbad on Fri Oct 05, 2012 11:48 am

Yes.
Tharbad
Level 1
Level 1
 
Posts: 20
Joined: Thu Nov 24, 2011 1:56 pm

Re: Prevent mint from sleeping

Postby stratus_ss on Fri Oct 05, 2012 4:10 pm

So I actually have had to remove the xscreensaver before on some computers to prevent it from turning off the monitor even though there the options were set properly in the screensaver.

Have you tried wyrdoak's suggestion? I have tested this myself by ssh'ing into the computer in question and running this (had to fiddle with the screen settings but the same idea)
stratus_ss
Level 4
Level 4
 
Posts: 270
Joined: Fri May 25, 2012 5:22 pm

Re: Prevent mint from sleeping

Postby Tharbad on Fri Oct 05, 2012 8:31 pm

The option wyrdoak is talking about is already set to never.

I'm not talking about monitor going to sleep but about the OS going to sleep (it's a home server).
Most of the time the screen is off anyway.

Just to make it clear - 2 days ago the system was shutdown when I woke up in the morning. Since then it still up.
As this is a new installation I assumed it wasn't a crash. The hardware is OK (This computer was running Mint 11 KDE which is now out of support). There was no power outage at that time. So I'm assuming the system went to sleep.
Tharbad
Level 1
Level 1
 
Posts: 20
Joined: Thu Nov 24, 2011 1:56 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 1 guest