GDM and Openbox, Error!!

Forums for the Xfce Edition
Forum rules
Before you post please read this

GDM and Openbox, Error!!

Postby xvedejas2052 on Sat Jun 07, 2008 5:48 pm

I'm trying to create sort of a Mint-Openbox out of XFCE CE, but I get this error trying to log back into openbox;

This process is currently running setuid or setgid. This is not a supported use of GTK+. You must create a helper program instead.


I haven't been able to find a fix, and I really need one. Any help, guys?
xvedejas2052
 

Linux Mint is funded by ads and donations.
 

Re: GDM and Openbox, Error!!

Postby merlwiz79 on Sat Jun 07, 2008 6:15 pm

This is the development forum. Post help topics here: viewforum.php?f=57&st=0&sk=t&sd=d&start=0
Ok I am using Elyssa XFCE CE.

Which version are you using.(Cassandra or Daryna)

Installed openbox obmenu openbox-themes pypanel obconf pypanel libobparser16 libobrender16
Logged in to Openbox Session and it worked fine.(Not openbox gnome or kde).
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: GDM and Openbox, Error!!

Postby xvedejas on Sat Jun 07, 2008 8:27 pm

It worked the first time I logged in, but not the second time. I'm using the Daryna version -- sorry, didn't realize this was the wrong place. Someone can move this thread then.
Image
xvedejas
Level 3
Level 3
 
Posts: 143
Joined: Mon Apr 07, 2008 6:48 pm

Re: GDM and Openbox, Error!!

Postby merlwiz79 on Sat Jun 07, 2008 10:58 pm

I have logged in several times into Openbox in Daryna XFCE CE Beta.
Try deleting everything in ~/.config/openbox
Then copy /etc/xdg/openbox/autostart.sh to ~/.config/openbox/
Then right click on ~/.config/openbox/ and click Permissions and check Allow this file to run as a program.
Open with mouse pad and add what you want to auto start to the end of the file.

Examples:
#makes the icons and gtk theme autostart:
xfce-mcs-manager &
#Starts gnome screensaver and power manager
gnome-screensaver &
gnome-power-manager &
#starts Wicd tray
/opt/wicd/tray.py &
#starts mintUpdate
/usr/lib/linuxmint/mintUpdate/mintUpdate.py &
#Starts panel in xfce
xfce4-panel &
Save file and make sure it's an executable.

If this doesn't work you can try and purge openbox and reinstall it.(sudo apt --remove -purge openbox )


If this doesn't wor
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)


Return to Xfce

Who is online

Users browsing this forum: Google [Bot] and 5 guests