[SOLVED] Boots into XFCE fine, but no cursor

Forums for the Xfce Edition
Forum rules
Before you post please read this

[SOLVED] Boots into XFCE fine, but no cursor

Postby benali72 on Sun Dec 01, 2013 12:34 am

I'm on Mint 13 with both XFCE and Mate installed.

Normally I use XFCE. It's been working fine for over a year until recently.

Just recently, when I boot into XFCE, the GUI looks fine -- except that I have no mouse cursor.

At the Login Panel, I see the mouse cursor and it moves fine. But then it disappears when I actually login in and get into the XFCE GUI.

I should mention that the problem ONLY occurs when login to XFCE. If I login to use Mate I always have a valid working mouse cursor. The mouse is a USB mouse.

Could you help me get my cursor back? Thank you.

(SYSTEM INFO -- Mint 13 using XFCE, updates are current, hardware is HP Pavilion a1600n desktop, with Athlon 64 x2 at 3800+ and 2G ram)
Last edited by benali72 on Thu Mar 06, 2014 12:11 am, edited 1 time in total.
benali72
Level 2
Level 2
 
Posts: 63
Joined: Sat Mar 23, 2013 11:49 am

Linux Mint is funded by ads and donations.
 

Re: Boots into XFCE fine, but no cursor

Postby benali72 on Tue Dec 03, 2013 4:37 pm

OK, what I'm going to try is to re-install the XFCE4 packages through Synaptic. We'll see if that fixes this.

Another optiion is to upgrade from Mint 13, but I'd rather stay on LTS. (I've got a half dozen machines I'm supporting and I'd like to keep them on all LTS with XFC4.) Or another option would be to always use MATE, but the user of this box finds it hard to scroll the apps list (it scrolls jerky and you have to be careful to keep the cursor in that very narrow scroll bar).

I'll post results when I get this figured out. Ciao.
benali72
Level 2
Level 2
 
Posts: 63
Joined: Sat Mar 23, 2013 11:49 am

Re: Boots into XFCE fine, but no cursor

Postby bobafetthotmail on Wed Dec 04, 2013 8:57 pm

I had issues with my touchpad being completely disabled on boot randomly, and only way to fix was going into the Mouse options and removing the dot from "disable touchpad when typing".

Might or might not be relevant to you.

Another random tip. In case it does not work, you can try installing the latest xfce from its ppa as described here http://www.noobslab.com/2013/07/install ... buntu.html

I have it and it's fine (issue was there before, and is still here after, I suspect hardware). The usual "BACKUP! BACKUP! BACKUP!" still applies though. :mrgreen:
bobafetthotmail
Level 4
Level 4
 
Posts: 289
Joined: Sat Aug 10, 2013 8:20 am

Re: Boots into XFCE fine, but no cursor

Postby MtnDewManiac on Fri Dec 06, 2013 12:37 pm

Since it's a USB mouse, have you tried not plugging it in until you reach the desktop?

Also, is your mouse... cursor(?) actually missing, or is it just invisible? Have you tried moving your mouse in such a way that, if the cursor was there but invisible, it would - for example - cause one of your desktop panels to appear? (The previous makes the assumption that you have set your panels to auto-hide, of course; if you have chosen to keep the default and allow them to eat your desktop's real estate, you'll have to change the setting temporarily.)

Regards,
MDM
_____
Proud to be a Mint user. Running 32-bit Mint 14 Xfce (with Xfce 4.10 and 4.12 PPAs). I have the best modern OS and it runs on my really old hardware, lol.
"Change should never be your goal but, instead, only a means to reach your goal."
MtnDewManiac
Level 4
Level 4
 
Posts: 417
Joined: Fri Feb 22, 2013 5:18 pm

Re: Boots into XFCE fine, but no cursor

Postby benali72 on Sat Dec 07, 2013 2:34 am

Thank you both for your help and the great ideas.

MDM, good point, you're right, my mouse is invisible (not missing).

It's a USB mouse, I've tried plugging it in at different times but that didn't help. I have an old PS/2 round-plug mouse, I'll give it a try too. Maybe it will pick that up beter.

I will review the mouse settings in the control panel to see if changing anything there helps.

If not, I'll try the reinstall idea, and also Bob's idea of using the latest XFCE PPA (thanks, I didn't think of that!).

I bet one of these ideas will work. I'll post back my results (note-- it may be awhile, unfortunately since the original post I just got swamped with another high priority problem).

Thanks again for the ideas.
benali72
Level 2
Level 2
 
Posts: 63
Joined: Sat Mar 23, 2013 11:49 am

Re: Boots into XFCE fine, but no cursor

Postby MtnDewManiac on Sat Dec 07, 2013 10:03 am

Since it's "only" invisible, I would enable the option that draws attention to the location of the mouse cursor when the user presses the CTRL key - maybe when it does, the cursor will become and stay visible. IIRC, when set to be invisible (in text fields) and the user does this, it'll stay visible even in text until it's moved.

I'd then try going to the settings area where the user chooses which images to use for the cursor, change it to something else, then change it back (if desired).

Regards,
MDM
_____
Proud to be a Mint user. Running 32-bit Mint 14 Xfce (with Xfce 4.10 and 4.12 PPAs). I have the best modern OS and it runs on my really old hardware, lol.
"Change should never be your goal but, instead, only a means to reach your goal."
MtnDewManiac
Level 4
Level 4
 
Posts: 417
Joined: Fri Feb 22, 2013 5:18 pm

Re: [SOLVED] Boots into XFCE fine, but no cursor

Postby benali72 on Thu Mar 06, 2014 12:17 am

Just wanted to post that I finally got a permanent solution to my "invisible cursor" problem. After some research I found that some of the AMD/HP boxes like mine (from about 2005/6, early dual core machines) had this invisible cursor issue due to their graphics subsystem. I just installed a PCI Express 16 graphics card (specifically a Radeon X700 from Gigabyte Technology). The card only has 128M video ram, vs. my built-in graphics subsystem of 256M. But no matter! Since its a hardware bug in the original system, I effectively replaced it by installing the PCI x-16 graphics card. Bingo. The cursor is now always visible and my problem is solved.

It never occurred to me that a cursor problem would be related to the graphics subsystem. But there you go. All works fine now.

BTW, even with only 128M in graphics memory, I've found that Linux games like Extreme Tux Racer, SuperTux2, and SuperTuxKart work just fine.

Thanks for everyone's help in this thread. Cheers.
benali72
Level 2
Level 2
 
Posts: 63
Joined: Sat Mar 23, 2013 11:49 am

Linux Mint is funded by ads and donations.
 

Return to Xfce

Who is online

Users browsing this forum: No registered users and 3 guests