Problem with SOUND (Linux Mint 16 XFCE)

Forums for the Xfce Edition
Forum rules
Before you post please read this

Problem with SOUND (Linux Mint 16 XFCE)

Postby JinRoh on Sat Dec 21, 2013 7:23 am

Hello.

I have installed Linux Mint 16 Petra XFCE in a Dell Mini 1018 (netbook).

Everything has been working perfectly, except for the sound. Since the first boot with the live-cd I noticed sound was not playing regularly. You had to enter "Sound Settings" and play with it a bit until it finally played any sounds.

After installing, the problem persists.

1) After opening any program with Sounds (ie: Browser with Youtube, VLC with a video, Music...) it DOESN'T sound by default (despite not having been muted at all).

2) The only workaround is, after opening any program that uses sound, I have to do the following steps
- Click in sound icon
- Sound Settings
- Output settings
- Click in "Speaker"
- Change it to something else (Headphones I believe?)
- Revert it to "Speaker" and sounds will now automagically play from the program running.

However, as soon as I close that program, even if I reopen it, I need to do those steps AGAIN.

Is this a common problem and is there any solution for it?
JinRoh
Level 1
Level 1
 
Posts: 2
Joined: Sat Dec 21, 2013 7:16 am

Linux Mint is funded by ads and donations.
 

Re: Problem with SOUND (Linux Mint 16 XFCE)

Postby korpyk on Wed Dec 25, 2013 10:05 pm

I too have the problem that two applications cannot use the soundcard at once :roll:
korpyk
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 25, 2013 11:26 am

Re: Problem with SOUND (Linux Mint 16 XFCE)

Postby ans on Mon Jan 20, 2014 2:09 pm

Me too, and the reshuffle with the output settings doesn help for a second, sorry
i'am looking for a real improvement ....
ans
Level 1
Level 1
 
Posts: 1
Joined: Mon Jan 20, 2014 2:03 pm

Re: Problem with SOUND (Linux Mint 16 XFCE)

Postby dragonfrog on Thu Feb 27, 2014 2:40 pm

I have a different problem (also using Petra XFCE) but sounds like it might stem from a similar overall flaw. As near as I can tell, switching AWAY from any sound output device is permanent until the next reboot.

That is:
- After I start up and log in, the default output is the builtin speakers on my laptop. Audio works fine on the speakers.
- After I switch to the headphone output, audio works fine on the headphone jack
- If I then switch back to the speakers, speaker output doesn't work. The audio control panels shows sound levels in the view meter, but no sound comes out.
- If I then switch back to the headphone, headphone output also doesn't work. As above, the control panel shows sound levels in the view meters.

In short, once I've switched from speaker to headphone and back, there's no way of getting sound from anything until the next reboot.

I have tried simply killing and restarting pulseaudio, to no effect.
I have not yet tried logging out of XFCE and back in again, but stopping short of a reboot.

Does anyone know where pulseaudio writes its log messages, and if there is a way to turn up the verbosity of those messages?
dragonfrog
Level 1
Level 1
 
Posts: 2
Joined: Thu Feb 27, 2014 2:08 pm

Re: Problem with SOUND (Linux Mint 16 XFCE)

Postby dragonfrog on Thu Feb 27, 2014 8:28 pm

Well, I seem to have fixed it for myself by the simple expedient of ditching pulseaudio and switching to alsa (uninstall pavucontrol, install xfce4-mixer).
dragonfrog
Level 1
Level 1
 
Posts: 2
Joined: Thu Feb 27, 2014 2:08 pm


Return to Xfce

Who is online

Users browsing this forum: No registered users and 5 guests