Please help theme issues!

Forum rules
Before you post please read this

Please help theme issues!

Postby doomwake on Sat Mar 29, 2014 11:28 am

Trying to get a theme to work on my linux 13 x64 xfce but for some reason it grays out and looks ugly where it should be smooth and black

http://killhellokitty.deviantart.com/ar ... -342067457

This is the theme i'm trying to install and I have tired getting it to work for the last 12+ hours

Thinking it might be gnome package or gtk themeing not being installed on my pc
I tired installing gnome and searching for gtk in the package manager and installing all the things that show up but some package cant be installed with each other.

Also tired installing it from the repo but i get a Couldn't find any package by regex error

So I downloaded and dropped it into usr/share/themes and the result is this:
1.png


Also tired another dark them I liked Blackbird-master: Missing title bar on this theme

2.png


So I must be missing something that makes these skins work and I was hopping someone could shade some light on the matter.

Thanks in Advance :)

Doomwake
doomwake
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 29, 2014 11:11 am

Linux Mint is funded by ads and donations.
 

Re: Please help theme issues!

Postby zerozero on Sat Mar 29, 2014 12:00 pm

mint 13 is based on gtk3.4, the theme (at least Green DeLorean-Dark Theme for 3.6) as the name implies is based on gtk3.6;
that's why you see those visual glitches.
you need to find (assuming that you still can) gtk3.4 compatible themes;
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: Please help theme issues!

Postby doomwake on Sat Mar 29, 2014 1:08 pm

bliss of ignorance lol not so much with Linux haha

Thank you!

Thought it was his theme version number

So next question is it possible to install gtk 3.6 with repo and apt? Really want this theme :/

Once again thanks in advance! ^_^
doomwake
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 29, 2014 11:11 am

Re: Please help theme issues!

Postby zerozero on Sat Mar 29, 2014 1:38 pm

doomwake wrote:So next question is it possible to install gtk 3.6 with repo and apt? Really want this theme :/
not while keeping mint 13 (in fact i don't even know if you can find a repo with gtk3.6 or, even if you did it would most certainly break your system)

from what i can see DeLorean-Dark_1.55 (that you already have installed) is the latest supporting gtk3.4 (yep, it's blue, not green :roll: )
http://killhellokitty.deviantart.com/ar ... -318612217


you can however use this >> http://www.webupd8.org/2012/09/customiz ... using.html << to tweak the colors of the theme and change the blue to green
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: Please help theme issues!

Postby JosephM on Sat Mar 29, 2014 4:02 pm

mint 13 is based on gtk3.4, the theme (at least Green DeLorean-Dark Theme for 3.6) as the name implies is based on gtk3.6;
that's why you see those visual glitches.


That actually shouldn't stop the theme from loading. At worst it should just cause some individual widgets to appear incorrect. It also should have no effect on gtk2 applications.

you can however use this >> http://www.webupd8.org/2012/09/customiz ... using.html << to tweak the colors of the theme and change the blue to green


In the case of that particular theme I'm not sure how well that tool is going to work. Almost all the widgets are created through the use of image maps.

You do have the pixbuf and murrine engines along with gnome-themes-standard installed correct? They are required for that theme. Try starting one of your applications from the terminal. That will often give you a clue to what the error is with loading the gtk theme.
JosephM
Level 3
Level 3
 
Posts: 188
Joined: Sun May 26, 2013 6:25 pm

Re: Please help theme issues!

Postby zerozero on Sat Mar 29, 2014 4:43 pm

JosephM wrote:That actually shouldn't stop the theme from loading. At worst it should just cause some individual widgets to appear incorrect. It also should have no effect on gtk2 applications.
the theme loads (as you can see in the screenshot posted above) but with visual glitches (and that is the complain doomwake makes in this topic)

furthermore if the theme is gtk3.6 compatible it won't work with gtk3.4
further reading
http://blog.linuxmint.com/?p=2038
http://igurublog.wordpress.com/2012/11/ ... in-threes/
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: Please help theme issues!

Postby JosephM on Sat Mar 29, 2014 5:15 pm

ZeroZero, thanks for the links. In the screenshot doomwake posted using the delorean-dark theme, the theme is not loading when his application is opened. What he is getting looks like the default fallback theme. That happens sometimes even when the theme has a typo and isn't being parsed properly.

I can for example install and use a gtk3.10 theme on mint16 which uses gtk3.8. Certain widgets just don't appear quite as the author intended. Those issues occur with every new gtk3 version. Regardless of issues with gtk3, his screenshots are showing gtk2 apps which should not be affected at all. I could be wrong, I don't have Mint13 installed to test, but I don't believe so.

Also the fact that he installed a bunch of random packages to try and fix the problem kinda throws everything out the window :)
JosephM
Level 3
Level 3
 
Posts: 188
Joined: Sun May 26, 2013 6:25 pm

Re: Please help theme issues!

Postby doomwake on Sun Mar 30, 2014 3:23 pm

Running new install of mint 13 on my windows 7 host on vmplayer trying to figure out how to fix this

I ran updates and did apt-get upgrade and tried again now the blackbird theme is working how it suppose to but the delorean-dark theme is still going back to the fallback theme.

JosephM or anyone have any suggestions to try and get it to render correctly?

Thanks You,

Doomwake
doomwake
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 29, 2014 11:11 am

Re: Please help theme issues!

Postby JosephM on Sun Mar 30, 2014 3:31 pm

Did you try running one of your applications from the terminal to see if it gives you any errors while using delorean dark? That sometimes will give you a clue as to what wrong.
JosephM
Level 3
Level 3
 
Posts: 188
Joined: Sun May 26, 2013 6:25 pm

Re: Please help theme issues!

Postby doomwake on Sun Mar 30, 2014 4:41 pm

They open with no errors
doomwake
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 29, 2014 11:11 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 3 guests