SOLVED : Software Index Broken

Forum rules
Before you post please read this

SOLVED : Software Index Broken

Postby TANUJMINTLINUX on Fri May 02, 2014 4:13 am

BLUNDER happend.
I am using linux mint 16 xfce and
i tried to install adobe reader9.5 throudh its .deb file but my notebook got shutdown due to low battery and on re- switching it debian package installer i.e . GDebi shows me

"This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'."


then i tried to open synaptic manager and it shows

ERROR OCCURRED

"E: The package adobereader-enu needs to be reinstalled, but I can't find an archive for it.
E: Internal error opening cache (1). Please report.


and yes i tried to run software update and it says this in terminal



inux@linux-Notebook-PC ~ $ sudo apt-get update
[sudo] password for linux:
Ign http://extra.linuxmint.com petra InRelease
Ign http://packages.linuxmint.com petra InRelease
Get:1 http://extra.linuxmint.com petra Release.gpg [198 B]
Get:2 http://packages.linuxmint.com petra Release.gpg [198 B]
Get:3 http://extra.linuxmint.com petra Release [3,090 B]
Get:4 http://packages.linuxmint.com petra Release [18.5 kB]
Get:5 http://extra.linuxmint.com petra/main Sources [20 B]
Get:6 http://extra.linuxmint.com petra/main i386 Packages [655 B]
Get:7 http://packages.linuxmint.com petra/main Sources [25.5 kB]
Get:8 http://archive.getdeb.net saucy-getdeb InRelease [8,129 B]
Ign http://archive.ubuntu.com saucy InRelease
Get:9 http://archive.getdeb.net saucy-getdeb/apps i386 Packages [61.3 kB]
Get:10 http://packages.linuxmint.com petra/upstream Sources [8,645 B]
Ign http://archive.ubuntu.com saucy-updates InRelease
Get:11 http://packages.linuxmint.com petra/import Sources [12.0 kB]
Hit http://archive.ubuntu.com saucy Release.gpg
Get:12 http://archive.ubuntu.com saucy-updates Release.gpg [933 B]
Get:13 http://packages.linuxmint.com petra/main i386 Packages [28.7 kB]
Hit http://archive.ubuntu.com saucy Release
Get:14 http://packages.linuxmint.com petra/upstream i386 Packages [23.3 kB]
Get:15 http://archive.ubuntu.com saucy-updates Release [49.6 kB]
Get:16 http://packages.linuxmint.com petra/import i386 Packages [40.4 kB]
Ign http://security.ubuntu.com saucy-security InRelease
Ign http://archive.canonical.com saucy InRelease
Get:17 http://security.ubuntu.com saucy-security Release.gpg [933 B]
Hit http://archive.canonical.com saucy Release.gpg
Ign http://extra.linuxmint.com petra/main Translation-en_IN
Get:18 http://security.ubuntu.com saucy-security Release [49.6 kB]
Hit http://archive.canonical.com saucy Release
Ign http://extra.linuxmint.com petra/main Translation-en
Get:19 http://archive.canonical.com saucy/partner Sources [1,418 B]
Ign http://archive.getdeb.net saucy-getdeb/apps Translation-en_IN
Get:20 http://archive.ubuntu.com saucy/main Sources [1,009 kB]
Hit http://archive.canonical.com saucy/partner i386 Packages
Ign http://archive.getdeb.net saucy-getdeb/apps Translation-en
Get:21 http://security.ubuntu.com saucy-security/main Sources [43.6 kB]
Err http://packages.domain.com saucy InRelease

Err http://packages.domain.com saucy Release.gpg
Could not resolve 'packages.domain.com'
Get:22 http://security.ubuntu.com saucy-security/restricted Sources [14 B]
Get:23 http://security.ubuntu.com saucy-security/universe Sources [8,836 B]
Ign http://archive.canonical.com saucy/partner Translation-en_IN
Get:24 http://security.ubuntu.com saucy-security/multiverse Sources [1,827 B]
Get:25 http://security.ubuntu.com saucy-security/main i386 Packages [114 kB]
Ign http://archive.canonical.com saucy/partner Translation-en
Get:26 http://security.ubuntu.com saucy-security/restricted i386 Packages [14 B]
Get:27 http://security.ubuntu.com saucy-security/universe i386 Packages [38.8 kB]
Ign http://packages.linuxmint.com petra/import Translation-en_IN
Ign http://packages.linuxmint.com petra/import Translation-en
Ign http://packages.linuxmint.com petra/main Translation-en_IN
Get:28 http://security.ubuntu.com saucy-security/multiverse i386 Packages [3,634 B]
Ign http://packages.linuxmint.com petra/main Translation-en
Ign http://packages.linuxmint.com petra/upstream Translation-en_IN
Ign http://packages.linuxmint.com petra/upstream Translation-en
Hit http://security.ubuntu.com saucy-security/main Translation-en
Hit http://security.ubuntu.com saucy-security/multiverse Translation-en
Hit http://security.ubuntu.com saucy-security/restricted Translation-en
Hit http://security.ubuntu.com saucy-security/universe Translation-en
Ign http://security.ubuntu.com saucy-security/main Translation-en_IN
Ign http://security.ubuntu.com saucy-security/multiverse Translation-en_IN
Ign http://security.ubuntu.com saucy-security/restricted Translation-en_IN
Ign http://security.ubuntu.com saucy-security/universe Translation-en_IN
Get:29 http://archive.ubuntu.com saucy/restricted Sources [4,759 B]
Get:30 http://archive.ubuntu.com saucy/universe Sources [6,108 kB]
Get:31 http://archive.ubuntu.com saucy/multiverse Sources [175 kB]
Hit http://archive.ubuntu.com saucy/main i386 Packages
Hit http://archive.ubuntu.com saucy/restricted i386 Packages
Hit http://archive.ubuntu.com saucy/universe i386 Packages
Hit http://archive.ubuntu.com saucy/multiverse i386 Packages
Hit http://archive.ubuntu.com saucy/main Translation-en
Hit http://archive.ubuntu.com saucy/multiverse Translation-en
Hit http://archive.ubuntu.com saucy/restricted Translation-en
Hit http://archive.ubuntu.com saucy/universe Translation-en
Get:32 http://archive.ubuntu.com saucy-updates/main Sources [85.8 kB]
Get:33 http://archive.ubuntu.com saucy-updates/restricted Sources [14 B]
Get:34 http://archive.ubuntu.com saucy-updates/universe Sources [69.0 kB]
Get:35 http://archive.ubuntu.com saucy-updates/multiverse Sources [2,352 B]
Get:36 http://archive.ubuntu.com saucy-updates/main i386 Packages [233 kB]
Get:37 http://archive.ubuntu.com saucy-updates/restricted i386 Packages [14 B]
Get:38 http://archive.ubuntu.com saucy-updates/universe i386 Packages [162 kB]
Get:39 http://archive.ubuntu.com saucy-updates/multiverse i386 Packages [3,894 B]
Hit http://archive.ubuntu.com saucy-updates/main Translation-en
Hit http://archive.ubuntu.com saucy-updates/multiverse Translation-en
Hit http://archive.ubuntu.com saucy-updates/restricted Translation-en
Hit http://archive.ubuntu.com saucy-updates/universe Translation-en
Ign http://archive.ubuntu.com saucy/main Translation-en_IN
Ign http://archive.ubuntu.com saucy/multiverse Translation-en_IN
Ign http://archive.ubuntu.com saucy/restricted Translation-en_IN
Ign http://archive.ubuntu.com saucy/universe Translation-en_IN
Ign http://archive.ubuntu.com saucy-updates/main Translation-en_IN
Ign http://archive.ubuntu.com saucy-updates/multiverse Translation-en_IN
Ign http://archive.ubuntu.com saucy-updates/restricted Translation-en_IN
Ign http://archive.ubuntu.com saucy-updates/universe Translation-en_IN
Fetched 8,388 kB in 4min 8s (33.7 kB/s)
Reading package lists... Done
W: Failed to fetch http://packages.domain.com/dists/saucy/InRelease

W: Failed to fetch http://packages.domain.com/dists/saucy/Release.gpg Could not resolve 'packages.domain.com'

W: Some index files failed to download. They have been ignored, or old ones used instead.

"


also one more thing the SOFTWARE MANGER is not working i.e. it is not opening

please tell me how i should solve this problem
Last edited by TANUJMINTLINUX on Sat May 03, 2014 12:05 am, edited 2 times in total.
TANUJMINTLINUX
Level 1
Level 1
 
Posts: 40
Joined: Sun Apr 20, 2014 9:23 am

Linux Mint is funded by ads and donations.
 

Re: Software Index Broken

Postby Kalyk on Fri May 02, 2014 6:17 am

TANUJMINTLINUX wrote:"This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'."


Did you also in the terminal try the second command
Code: Select all
sudo apt-get install -f

I believe that is the command to fix the broken installation.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.
User avatar
Kalyk
Level 5
Level 5
 
Posts: 516
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Software Index Broken

Postby TANUJMINTLINUX on Fri May 02, 2014 6:51 am

Kalyk wrote:
TANUJMINTLINUX wrote:"This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'."


Did you also in the terminal try the second command
Code: Select all
sudo apt-get install -f

I believe that is the command to fix the broken installation.



i did what u said and it gives
Code: Select all
linux@linux-Notebook-PC ~ $ sudo apt-get install -f
[sudo] password for linux:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package adobereader-enu needs to be reinstalled, but I can't find an archive for it.
TANUJMINTLINUX
Level 1
Level 1
 
Posts: 40
Joined: Sun Apr 20, 2014 9:23 am

Re: Software Index Broken

Postby kurotsugi on Fri May 02, 2014 7:11 am

put that deb file into /var/cache/apt/archives then repeat the command. you can also try
Code: Select all
dpkg -i /path/to/file
# or use this one
gksudo gdebi /path/to/file
# right click continued with 'open with gdebi' should work too
kurotsugi
Level 5
Level 5
 
Posts: 890
Joined: Fri Jan 25, 2013 3:54 am

Re: Software Index Broken

Postby TANUJMINTLINUX on Fri May 02, 2014 7:31 am

kurotsugi wrote:put that deb file into /var/cache/apt/archives then repeat the command. you can also try
Code: Select all
dpkg -i /path/to/file
# or use this one
gksudo gdebi /path/to/file
# right click continued with 'open with gdebi' should work too

WHAT is this " /path/to/file"
TANUJMINTLINUX
Level 1
Level 1
 
Posts: 40
Joined: Sun Apr 20, 2014 9:23 am

Re: Software Index Broken

Postby TANUJMINTLINUX on Fri May 02, 2014 7:34 am

TANUJMINTLINUX wrote:
kurotsugi wrote:put that deb file into /var/cache/apt/archives then repeat the command. you can also try
Code: Select all
dpkg -i /path/to/file
# or use this one
gksudo gdebi /path/to/file
# right click continued with 'open with gdebi' should work too

WHAT is this " /path/to/file"


oh i got it but the command says
Code: Select all
inux@linux-Notebook-PC ~ $ gksudo gdebi "/media/linux/TANUJ/"
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Error opening the cache:
E:The package adobereader-enu needs to be reinstalled, but I can't find an archive for it.
TANUJMINTLINUX
Level 1
Level 1
 
Posts: 40
Joined: Sun Apr 20, 2014 9:23 am

Re: Software Index Broken

Postby kurotsugi on Fri May 02, 2014 7:44 am

it should be a full path. 'dpkg -i /home/cats/Downloads/my_cat_is_here.deb'
kurotsugi
Level 5
Level 5
 
Posts: 890
Joined: Fri Jan 25, 2013 3:54 am

Re: Software Index Broken

Postby austin.texas on Fri May 02, 2014 11:31 am

You can also right-click on the .deb file in your File Manager, and chose "Open With GDebi"
Mint 17 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 9
Level 9
 
Posts: 2629
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Software Index Broken

Postby TANUJMINTLINUX on Fri May 02, 2014 12:12 pm

austin.texas wrote:You can also right-click on the .deb file in your File Manager, and chose "Open With GDebi"



i guess are not understanding the problem .the problem here is not the installation of .deb file, the problem is that the synaptic package manager is not opening,
gdebi is not working and so does the software manger.
all this is coz i tried installing that .deb file and my notebook got off meanwhile



any help in this regard is invited
TANUJMINTLINUX
Level 1
Level 1
 
Posts: 40
Joined: Sun Apr 20, 2014 9:23 am

Re: Software Index Broken

Postby kurotsugi on Fri May 02, 2014 4:39 pm

one of these proposed solution should work
put that deb file into /var/cache/apt/archives then repeat the command. you can also try

Code: Select all
    dpkg -i /path/to/file
    # or use this one
    gksudo gdebi /path/to/file
    # right click continued with 'open with gdebi' should work too
kurotsugi
Level 5
Level 5
 
Posts: 890
Joined: Fri Jan 25, 2013 3:54 am

Re: Software Index Broken

Postby austin.texas on Fri May 02, 2014 5:17 pm

E: The package adobereader-enu needs to be reinstalled, but I can't find an archive for it.

installing from external sources can cause this.
You need to do this:
sudo dpkg --purge adobereader-enu


add adobereader-enu to breaks section
Fixed by manually deleting package adobereader-enu.
https://bugs.launchpad.net/ubuntu/+sour ... ug/1137451
Mint 17 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 9
Level 9
 
Posts: 2629
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Software Index Broken

Postby TANUJMINTLINUX on Fri May 02, 2014 11:34 pm

austin.texas wrote:
E: The package adobereader-enu needs to be reinstalled, but I can't find an archive for it.

installing from external sources can cause this.
You need to do this:
sudo dpkg --purge adobereader-enu


add adobereader-enu to breaks section
Fixed by manually deleting package adobereader-enu.
https://bugs.launchpad.net/ubuntu/+sour ... ug/1137451


i tried this and terminal shows
Code: Select all
linux@linux-Notebook-PC ~ $ sudo dpkg --purge adobereader-enu
[sudo] password for linux:
dpkg: error processing adobereader-enu (--purge):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 adobereader-enu

i think things are just getting worse
TANUJMINTLINUX
Level 1
Level 1
 
Posts: 40
Joined: Sun Apr 20, 2014 9:23 am

Re: Software Index Broken

Postby TANUJMINTLINUX on Sat May 03, 2014 12:02 am

hey!
i got it
i found this on one of the ubuntu forum
1. first i removed all the files associated with adobereader from /var/lib/dpkg/info
2. then i ran this command
Code: Select all
sudo dpkg --purge --force-remove-reinstreq adobereader-enu

it worked successfully andthen i entered this in terminal
Code: Select all
sudo apt get upadate && sudo apt install -f



ang bingo!! it worked
and now synaptic, gdebi and software manager are working fine


But still one question why that dpkg purge command mentioned earlier was not working without using 'force'.
TANUJMINTLINUX
Level 1
Level 1
 
Posts: 40
Joined: Sun Apr 20, 2014 9:23 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 3 guests