Problem in copying into flash memory

Forum rules
Before you post please read how to get help

Problem in copying into flash memory

Postby osama_ on Mon May 12, 2014 6:00 am

Hello,

I have Linux Mint 15 with both XFCE and KDE, in KDE once I plug a flash memory, it is automatically mounted and I can copy files into it, but in XFCE I have to mount the device using mount command, but when I try to copy files into the flash drive using Dolphin I find "Paste" command grayed, and I have to copy using the command line after gaining super user privilege! Is their a solution for this problem?

NOTE:
I can copy files normally using Dolphin to any other partition, but not the USB!

Thanks
osama_
Level 1
Level 1
 
Posts: 7
Joined: Mon May 12, 2014 5:32 am

Linux Mint is funded by ads and donations.
 

Re: Problem in copying into flash memory

Postby karlchen on Mon May 12, 2014 6:26 am

Hello, osama_.

This is a misunderstanding. There is no need to "sudo mount" the device inside the xfce desktop. By doing so you are mounting it with root privileges thus preventing any normal user from writing to it.
Instead you should mount the device by clicking on it inside Thunar, the xfce default filemanager. Clicking on it a second time will unmount it again. (No root privileges needed.)
Moreover, you may configure Thunar to auto-mount removable devices as soon as they are inserted, just like your KDE desktop does. - Sorry, cannot give you the exact steps for xfce right now, because I am logged on to a Windows system.

Kind regards,
Karl
User avatar
karlchen
Level 11
Level 11
 
Posts: 3984
Joined: Sat Dec 31, 2011 7:21 am

Re: Problem in copying into flash memory

Postby osama_ on Mon May 12, 2014 7:15 am

The device does not appear in Thunar, but it appears in the output of fdisk -l :(
osama_
Level 1
Level 1
 
Posts: 7
Joined: Mon May 12, 2014 5:32 am

Re: Problem in copying into flash memory

Postby karlchen on Mon May 12, 2014 9:38 am

Hi, osama_.

No Thunar available here at the moment, only Nemo, another Nautilus clone. Nonetheless. They should be similar enough.
Does your Thunar display the vertical sidebar on the lefthand side? The vertical sidebar should at minimum offer the categories (from top to bottom): Computer - Devices - Network.
Newly plugged-in devices should be visible and clickable under "Devices".

Kind regards,
Karl
User avatar
karlchen
Level 11
Level 11
 
Posts: 3984
Joined: Sat Dec 31, 2011 7:21 am

Re: Problem in copying into flash memory

Postby osama_ on Mon May 12, 2014 10:22 am

Yes, I have the left sidebar, but my device does not appear there :!: , this only occurs in the case of KDE (with Dolphin file manager)

NOTE:
The device also does not appear in Dolphin under XFCE! However it appears in both Thunar and Dolphin under KDE, this issue seems to be XFCE related not Thunar
osama_
Level 1
Level 1
 
Posts: 7
Joined: Mon May 12, 2014 5:32 am

Re: Problem in copying into flash memory

Postby austin.texas on Mon May 12, 2014 10:37 am

In my File Manager (Nemo) I can go to Edit > Preferences > Behavior > Automatically mount removeable media when inserted.
Your File Manager may be similar.
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3786
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Problem in copying into flash memory

Postby osama_ on Mon May 12, 2014 12:33 pm

Yes, I found the same option in Thunar, I just had to install a software named thunar-volman, but after installing and configuring it, nothing occurs:
Image
It does not auto-mount the flash memory
but at least, I could manually mount NTFS devices and copy files to them, but no luck with FAT32

Unfortunately, my flash memory has to be FAT32 as it has Hiren't boot which have to be on a FAT32 device.

Anyway, thanks a lot Karlchen and Austin, I think I will have to switch to KDE before copying to a flash memory :lol:
osama_
Level 1
Level 1
 
Posts: 7
Joined: Mon May 12, 2014 5:32 am

Re: Problem in copying into flash memory

Postby karlchen on Mon May 12, 2014 6:53 pm

Hi, osama_.

Weird behaviour which you experience. - All my USB pendrives use a FAT32 filesystem. Thunar always mounts them without any problem as soon as they have been plugged in. (Mint 13, Mint 16)
Cannot really offer any good explanation why it does not work this way on your system. - Maybe because Dolphin handles your desktop on KDE and on xfce? (This is a question, not a statement. Your default filemanager on KDE and on xfce is Dolphin?)

Cheers,
Karl
User avatar
karlchen
Level 11
Level 11
 
Posts: 3984
Joined: Sat Dec 31, 2011 7:21 am

Re: Problem in copying into flash memory

Postby osama_ on Tue May 13, 2014 4:42 am

Hello Karl,

The default file manager on Xfce is Thunar.

:shock: Surprisingly, the problem was solved when I mounted the flash memory using Dolphin, then opened it using Thunar :!: It works now under Xfce in both Dolphin and Thunar, but it has to be mounted using Dolphin!
When unmounted it appears only in Dolphin!

Thanks,
Osama
osama_
Level 1
Level 1
 
Posts: 7
Joined: Mon May 12, 2014 5:32 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 2 guests