Update Daryna XFCE to Elyssa XFCE

Forum rules
Before you post please read this

Update Daryna XFCE to Elyssa XFCE

Postby merlwiz79 on Fri Sep 19, 2008 3:23 am

Added apt preferences:
Run
Code: Select all
gksu mousepad /etc/apt/preferences
Copy and paste this into the new file and then save:
Code: Select all
Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: release o=Ubuntu
Pin-Priority: 500
Back up old sources.lst:
Run:
Code: Select all
sudo mv /etc/apt/sources.list /etc/apt/sources.list.bak
Create new sources.list:
Run:
Code: Select all
gksu mousepad /etc/apt/sources.list
Copy and paste this into the new file and then save:
Code: Select all
## -----------------------
## LINUX MINT REPOSITORIES
## -----------------------

## +++ Linux Mint 5 Elyssa (stable) +++
deb http://packages.linuxmint.com/ elyssa main upstream import

## +++ Backports (not as stable) +++
# deb http://packages.linuxmint.com/ elyssa backport

## +++ Community (not as stable) +++
# deb http://packages.linuxmint.com/ elyssa community

## +++ Romeo (unstable) +++
# deb http://packages.linuxmint.com/ elyssa romeo

## +++ Source Repositories +++
# deb-src http://packages.linuxmint.com/ elyssa main upstream import
# deb-src http://packages.linuxmint.com/ elyssa community
# deb-src http://packages.linuxmint.com/ elyssa backport
# deb-src http://packages.linuxmint.com/ elyssa romeo

## -------------------
## UBUNTU REPOSITORIES
## -------------------

## +++ Hardy (Ubuntu 8.04) +++
deb http://archive.ubuntu.com/ubuntu/ hardy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ hardy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ hardy-security main restricted universe multiverse

## +++ Backports & Proposed (Ubuntu Unstable) +++
# deb http://archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse
# deb http://archive.ubuntu.com/ubuntu/ hardy-proposed main restricted universe multiverse

## +++ Source Repositories +++
# deb-src http://archive.ubuntu.com/ubuntu/ hardy main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu/ hardy-updates main restricted universe multiverse
# deb-src http://security.ubuntu.com/ubuntu/ hardy-security main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu/ hardy-proposed main restricted universe multiverse

## ------------------
## OTHER REPOSITORIES
## ------------------

## +++ Canonical +++
deb http://archive.canonical.com/ubuntu/ hardy partner

## +++ Medibuntu +++
deb http://packages.medibuntu.org/ hardy free non-free

## Exaile Music Player updates
# deb http://ppa.launchpad.net/exaile-devel/ubuntu/ hardy main

##  Wicd Updates
# deb http://wicd.longren.org/ hardy extras

## Swiftfox
# deb http://getswiftfox.com/builds/debian/ unstable non-free

## Cathbard art
# deb ftp://cathbard.com/ ./

Update system:(DON'T REBOOT UNTIL I TELL YOU TO!!)
Run in terminal:(should answer Y to anything you didn't modify)
Code: Select all
apt update
apt upgrade

Now run this in terminal:(must be done exactly this way)
Code: Select all
apt update
apt dist-upgrade

Now run:
Code: Select all
apt remove --purge xarchiver xscreensaver envy hal-device-manager gnome-keyring-manager

Install replacements to dead projects and install new Dependences:
Code: Select all
apt install file-roller envyng-gtk gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-plugins-bad-multiverse nspluginwrapper gtk2-engines-aurora gtk2-engines-pixbuf gtk2-engines-candido mintbackup gtkhtml3.14 libgtkhtml3.14-19 libgtkhtml3.16-cil libgtk-vnc-1.0-0 gstreamer0.10-pitfdll jockey-gtk jockey-common libwpg-0.1-1 libwps-0.1-1 obex-data-server bluez-gnome gimp-gnomevfs gvfs-fuse hal-cups-utils ghostscript-x dcraw libnss-mdns samba libpam-smbpass seahorse language-support-en bogofilter evolution-data-server openprinting-ppds pxljr splix libpt-1.10.10 libpt-1.10.10-plugins-alsa libpt-1.10.10-plugins-v4l libpt-1.10.10-plugins-v4l2 system-config-printer-gnome xfce4-places-plugin gnome-device-manager libgnome2-perl libgnome-device-manager0 feh giblib1 libimlib2 firefox-3.0-gnome-support xulrunner-1.9-gnome-support

Install XFCE CE Updates:
Download my updates and extract.
Open the updates folder with all the .deb files.
Now right click Open Terminal Here and run
Code: Select all
sudo dpkg -i xfcemint-doc_0.5-1_all.deb
Code: Select all
sudo dpkg -i *.deb
Make sure to say Y to everything.
Code: Select all
apt install -f
Shouldn't remove anything.
MUST DO:
Run in terminal:
Code: Select all
sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
sudo update-grub
sudo rm /usr/bin/apt

Use Mint Lock Screen:
Run:
Code: Select all
gconftool-2 --type string --set  /apps/gnome-screensaver/lock_dialog_theme mint


Getting new XFCE Menu::
In Thunar Show Hidden files (Ctrl + H)
Delete all menu-cache* files in ~/.cache/xfce4/desktop/
Delete any menu.xml* files in ~/.config/xfce4/desktop/

Fix custom actions updates::
Delete all files in ~/.config/Thunar/

Update wicd:
apt remove --purge wicd-autostart-plugin
Download and install the stable version here.(debian package)

Fix compiz Settings:
Open Advanced Desktop Effects Settings --> General --> Focus & Raise Behavior
Change Focus Prevention Level to Off
Open Advanced Desktop Effects Settings --> General --> Desktop Size --> Horizontal Virtual Size = 4
Open Advanced Desktop Effects Settings --> General --> Display Setting --> Texture Filter = Fast

Use the default artwork:
Open XFCE 4 mintDesktop
Restore Gimp, OpenOffice, and Exaile artwork.

Firefox:
New Homepage: http://www.linuxmint.com/start/elyssa/
Add Artwork and Blog to book marks

NOW YOU CAN RESTART
If you installed the 3d Acceleration driver with Envy you may need to run this on Reboot:
Code: Select all
envyng -t

Testing New mintDesktop:http://www.linuxmint.com/forum/viewtopic.php?f=110&t=17016
Testing New mintInstall:http://www.linuxmint.com/blog/?p=252
Testing New mintUpdate:http://www.linuxmint.com/blog/?p=232
Please translate into your language if it already hasn't been done:http://www.linuxmint.com/forum/viewforum.php?f=43
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Linux Mint is funded by ads and donations.
 

Re: Update Daryna XFCE to Elyssa XFCE

Postby msuggs on Fri Sep 19, 2008 6:56 pm

Thank you for taking to the time and energy to work this one out :) Your efforts with XFCE are remarkable :)
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local


Return to XFCE

Who is online

Users browsing this forum: No registered users and 5 guests