Problems with Samba fusesmb

Forum rules
Before you post please read how to get help

Problems with Samba fusesmb

Postby Arron on Mon Mar 09, 2009 9:18 am

Im using the fusesmb, default with Mint XFCE 6. When I browse i get errors as i browse around the folders, and I cant play any media. Most of the time after an error the "Network" folder disappear in my home folder and i need to reboot to get it back.

Is anyone else having problems with it?
User avatar
Arron
Level 3
Level 3
 
Posts: 147
Joined: Wed Apr 02, 2008 12:24 pm

Linux Mint is funded by ads and donations.
 

Re: Problems with Samba fusesmb

Postby joeham on Mon Mar 09, 2009 5:47 pm

Did you fill in the setup part of the fusesmb screen?

I have problems like this if I don't fill in the user and global password correctly. Some windows machines setup sharing with no password and guest user and some need to have a specific user and password to gain access.

I am running windoze now so I can't tell you the exact screens.
joeham
Level 1
Level 1
 
Posts: 19
Joined: Sun Feb 08, 2009 1:00 am

Re: Problems with Samba fusesmb

Postby Arron on Fri Mar 13, 2009 6:54 pm

I have set the settings, reset and tried again.

The error i get is:

Failed to open directory "Movies".
Software caused connection abort.

Then the network folder disappears till reboot. As well i cant play media files. There is no user settings on the shares, just open shared folders on a Mint 5 xfce box.

Can anyone help?
User avatar
Arron
Level 3
Level 3
 
Posts: 147
Joined: Wed Apr 02, 2008 12:24 pm

Re: Problems with Samba fusesmb

Postby Zwopper on Mon Mar 16, 2009 3:36 pm

Same problem here - this was not a problem in Mint 5, so I see it as specific to this version.

[Ramblings]
This is not the only problem in version 6, I'm actually consider to roll back to version 5, the current version inherited too many problems from *buntu...
[/Ramblings]
Image
My artwork at deviantART | My Tweet
CREA DIEM!
Lenovo E320 | 8GB | 512GB Samsung 840 PRO - SSD | Ubuntu 14.04
User avatar
Zwopper
Level 10
Level 10
 
Posts: 3101
Joined: Fri Nov 30, 2007 12:20 pm
Location: Deep in the Swedish woods

Re: Problems with Samba fusesmb

Postby carlverge on Tue Mar 24, 2009 9:57 am

This is likely the problem I had in Ubuntu 8.10 - libsmbclient 3.2 Onwards is incompatible with fusesmb and smbnetfs. The only solution I've found to make those two work is to roll back to version 3.0.28. I forget if there is something special you need to do to do this, but I do know that it breaks gvfs-backends which is depended on by various gnome applications - notably the gnome printer manager and nautilus.

Alternatively, you can mount network shares using smbfs (which does not depend on the above).
Code: Select all
> sudo apt-get -y install smbfs smbclient
> sudo mkdir /media/netshare
> sudo mount -t smbfs -o username=USER,password=PASS //<computer>/<share> /media/netshare


If you want to add it to fstab, use this line:
Code: Select all
//<computer>/<share>  /media/netshare  smbfs  defaults,user,noauto,username=USER,password=PASS  0  0
carlverge
Level 1
Level 1
 
Posts: 1
Joined: Tue Mar 24, 2009 9:43 am

Re: Problems with Samba fusesmb

Postby Arron on Sun Apr 05, 2009 8:42 am

bump

Any updates on this? Is there any alternative way to browse the network and use the files on it right now, what does mint flux use? The mount did work for me, but I just change from a few different wifi networks and makes it a pain.
User avatar
Arron
Level 3
Level 3
 
Posts: 147
Joined: Wed Apr 02, 2008 12:24 pm


Return to XFCE

Who is online

Users browsing this forum: No registered users and 5 guests