turning off tapping in Xfce

Forum rules
Before you post please read this

turning off tapping in Xfce

Postby FedoraRefugee on Thu Mar 26, 2009 2:53 pm

Okay, this one has bothered me now to the point where I need to do something about it! I installed gsynaptics in order to turn off the tapping feature on the touchpad. It turns off just fine, but whenever I log out and back in tapping is enabled again! :cry: I live with it until I accidently hit one link too many when surfing and disable it yet again. How can I disable this for good? I am not good with writing policies and such, I miss the good old days when I could just add a line to xorg.conf...
FedoraRefugee
Level 6
Level 6
 
Posts: 1301
Joined: Fri Oct 03, 2008 11:25 am

Linux Mint is funded by ads and donations.
 

Re: turning off tapping in Xfce

Postby Boo on Thu Mar 26, 2009 7:57 pm

you could run gsynaptics from a terminal to see what it is doing.
you could run it also with sudo or gtksu and see if that makes it permanent.
last time i used it it was permanent.

Boo
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: turning off tapping in Xfce

Postby FedoraRefugee on Thu Mar 26, 2009 9:12 pm

No go. :cry:

I have to run it from the terminal as it does not show up in the Xfce menu (at least I have not found it) but running as root was a good idea. Unfortunately it did not make the change permanent. I need to track down where this change is now happening.

edit: Have done some serious research and this is definitely an Ubuntu problem that others are having. I have edited the fdi policy and still cannot make the change stick. One thing I notice is that in my settings manager/mouse settings my device is set to Macintosh mouse button emulation instead of synps/2 synaptics touchpad. These are the only two entries. I change to the later and close the settings manager and reopen it to find the selection is moved back to mac. I have an HP dv6700 but the product key in lshal matches with mac:

udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input_4'
info.capabilities = {'input', 'input.mouse'} (string list)
info.category = 'input' (string)
info.parent = '/org/freedesktop/Hal/devices/computer' (string)
info.product = 'Macintosh mouse button emulation' (string)
info.subsystem = 'input' (string)
info.udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input_4' (string)
input.device = '/dev/input/event0' (string)
input.product = 'Macintosh mouse button emulation' (string)
input.x11_driver = 'evdev' (string)
linux.device_file = '/dev/input/event0' (string)
linux.hotplug_type = 2 (0x2) (int)
linux.subsystem = 'input' (string)
linux.sysfs_path = '/sys/devices/virtual/input/input0/event0' (string)

Surely this is not right? :?: I am all kinds of confused, very PO'd that I cant just make a stupid xorg entry for this, almost ready to just boot back into Vista permanently (no, I have used Linux too long and this is just par for the course), and resigned that every time I log into Mint I will have to open a terminal, type "gsynaptics" and disable the tapping manually, which works fine. If anyone has any clues I am all ears...
FedoraRefugee
Level 6
Level 6
 
Posts: 1301
Joined: Fri Oct 03, 2008 11:25 am


Return to XFCE

Who is online

Users browsing this forum: No registered users and 2 guests