RESOLVED Rsync won't start

Forum rules
Before you post please read this

RESOLVED Rsync won't start

Postby herdivet on Sun Apr 19, 2009 12:22 am

Okay, this may be a stupid question, but I'm not able to get rsync to start. In Ubuntu I just type sudo /etc/init.d/rsync startt and that does the trick. In Mint, I type this and instead of a message acknowledging the service is running, I get no response. When I type sudo /etc/init.d/rsync status I get the message that it's not running.

What am I doing wrong?

Thanks!

OK - this is (as usual) all my fault. If anyone else is dumb enough to have this problem, the fix is -DON'T RELY ON YOUR MEMORY - follow the original instructions step-by-step. DUH. The FIRST STEP - "To use rsync on and Ubuntu system, you must first enable it so that the system starts rsync as a background process...."

sudo emacs /etc/default/rsync

In the line that begins with RSYNC_ENABLE, change false to true, then save the updated file.....

Yeah, that might be kind of required to get it to work.

Sorry if this wasted anyone's time, and I really hope you didn't go to the trouble of installing MINT XFCE just to look at this.

Thanks for your patience.
Last edited by herdivet on Sun Apr 26, 2009 12:27 pm, edited 1 time in total.
herdivet
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 19, 2009 12:13 am

Linux Mint is funded by ads and donations.
 

Re: Rsync won't start

Postby Fred on Sun Apr 19, 2009 8:11 am

herdivet,

If you want to start rsync simply open a terminal and type:

sudo rsync "whatever"

You don't need rsync running to use it from the terminal with sudo. You can have it run as a service on start-up, but it isn't necessary if you call and use it locally as root.

Fred

EDIT: Is rsync installed on the version of Mint you are using?
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Rsync won't start

Postby herdivet on Sun Apr 19, 2009 9:22 am

I use backuppc to make backups of all my PC's home directories, and the easiest way is with rsync. This requires the rsync deamon be running. Another option would be smb, which I use on an XP box, but I try not to use it on the linux systems.

When I check /usr/bin rsync is there. When I check /etc/services rsync is listed. It just doesn't 'stay' running.

I just thought there might be a quick, simple reason why rsync wasn't running.

Thanks.
herdivet
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 19, 2009 12:13 am

Re: Rsync won't start

Postby Fred on Sun Apr 19, 2009 10:19 am

herdivet,

Oh, I see what you are saying now. From your post rsync must be installed and you say you have it in services to start. I know of no reason right off hand that would keep that from happening. I don't have a copy of XFCE installed currently, but I will install it this afternoon if I have a chance and see if I see anything unusual.

Maybe merlwiz79 will see this and offer some advice. He is the release manager/maintainer of the XFCE edition. He may be able to shed some light on the matter.

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA


Return to XFCE

Who is online

Users browsing this forum: No registered users and 4 guests