Emerald has hijacked my windows! (bug?)

Forums for the Xfce Edition
Forum rules
Before you post please read this

Emerald has hijacked my windows! (bug?)

Postby jojopumpkin on Fri Jul 24, 2009 1:47 am

I just installed "Gloria" XFCE, updated everything, enabled my video card, then enabled compiz and my windows went all wacky with Emerald theme madness. I went into the compiz settings and disabled Emerald themes and lost sight of my window decorations. I then went back into compiz and enabled emerald for the simple satisfaction of having a complete looking window. I like compiz but emerald seems a bit campy for me.

It seems that with compiz running I cannot do anything in XFCE 4 mintConfig related to the window manager aside from the styles. I click and get no feedback just dead clicks.

Perhaps an easy one click option to return to the default window manager (if there is one I cannot find it) and simply not have emerald enabled as default when compiz is enabled might be the more user friendly route.

The default theme for "Gloria" XFCE is great and I wish to enjoy it while watching it spin around on my rotating desktop cylinder or watching it burst into flames as I minimize it to my taskbar.

Can someone help me return to the land of XFCE decorations with compiz enabled?
jojopumpkin
Level 1
Level 1
 
Posts: 14
Joined: Fri Jul 24, 2009 1:15 am

Linux Mint is funded by ads and donations.
 

Re: Emerald has hijacked my windows! (bug?)

Postby Carl on Fri Jul 24, 2009 3:40 am

can't you just uninstall emerald...?

if not you can install compiz-fusion icon which will let you select disable emerald and use the default of xcfe :D

Code: Select all
sudo apt-get install fusion-icon
[AMD Sempron 145 2.8GHz + Unlocked 2nd Core|ATI Radeon™ HD3000 Graphics|4GB DDR3|Biostar A780L3L]
Image
User avatar
Carl
Level 5
Level 5
 
Posts: 667
Joined: Wed Apr 15, 2009 5:20 pm
Location: West Sussex, UK

Re: Emerald has hijacked my windows! (bug?)

Postby jojopumpkin on Fri Jul 24, 2009 8:26 am

Thanks for the suggestions Carl.

I did remove emerald, still had no decorations and was still locked out of the Window Manager Settings in XFCE 4 mintConfig > Desktop. I should also add that reinstalling emerald and it's themes got me no themes in return? When I open emerald themes manager there is nothing there.

Fusion Icon didn't help either. It is only set up for KDE it seems and @ 225mb it seems a bit harsh to simply turn one thing off so I can have what was already there.

Thanks for the suggestions nonetheless. It is much appreciated.

Code: Select all
sudo apt-get install fusion-icon


Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  compiz-kde compizconfig-backend-kconfig exiv2 kde-icons-oxygen
  kdebase-runtime kdebase-runtime-bin-kde4 kdebase-runtime-data
  kdebase-runtime-data-common kdebase-workspace-libs4+5 kdelibs-bin
  kdelibs-data kdelibs4c2a kdelibs5 kdelibs5-data khelpcenter4 libavahi-qt3-1
  libclucene0ldbl libexiv2-5 libkdecorations4 liblua50 liblualib50 libphonon4
  libplasma3 libpq5 libqt4-dbus libqt4-designer libqt4-network libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg
  libqt4-webkit libqt4-xml libqtcore4 libqtgui4 librasqal1 librdf0 libsoprano4
  libstreamanalyzer0 libstreams0 libxcb-shape0 libxcb-shm0 libxcb-xv0 libxine1
  libxine1-bin libxine1-console libxine1-misc-plugins libxine1-x phonon
  phonon-backend-xine qt4-qtconfig redland-utils soprano-daemon
Suggested packages:
  kdebase perl-suid libqt4-dev gxine xine-ui libxine1-doc libxine-doc
  libxine1-ffmpeg phonon-backend-vlc phonon-backend-mplayer
The following NEW packages will be installed:
  compiz-kde compizconfig-backend-kconfig exiv2 fusion-icon kde-icons-oxygen
  kdebase-runtime kdebase-runtime-bin-kde4 kdebase-runtime-data
  kdebase-runtime-data-common kdebase-workspace-libs4+5 kdelibs-bin
  kdelibs-data kdelibs4c2a kdelibs5 kdelibs5-data khelpcenter4 libavahi-qt3-1
  libclucene0ldbl libexiv2-5 libkdecorations4 liblua50 liblualib50 libphonon4
  libplasma3 libpq5 libqt4-dbus libqt4-designer libqt4-network libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg
  libqt4-webkit libqt4-xml libqtcore4 libqtgui4 librasqal1 librdf0 libsoprano4
  libstreamanalyzer0 libstreams0 libxcb-shape0 libxcb-shm0 libxcb-xv0 libxine1
  libxine1-bin libxine1-console libxine1-misc-plugins libxine1-x phonon
  phonon-backend-xine qt4-qtconfig redland-utils soprano-daemon
0 upgraded, 56 newly installed, 0 to remove and 0 not upgraded.
Need to get 68.9MB of archives.
After this operation, 225MB of additional disk space will be used.
Do you want to continue [Y/n]?


I also tried turning off the window decorations in compiz settings manager before enabling compiz and got the same results.

I feel dirty now and must purge this installation and start anew. I am reinstalling "Gloria" XFCE and sadly will not be enabling compiz until I can resolve this.

Thanks again Carl.
jojopumpkin
Level 1
Level 1
 
Posts: 14
Joined: Fri Jul 24, 2009 1:15 am

Re: Emerald has hijacked my windows! (bug?)

Postby merlwiz79 on Sun Jul 26, 2009 1:02 am

Try and run xfwm4.
To install fusion icon install compiz-gnome and compiz 1st.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)


Return to Xfce

Who is online

Users browsing this forum: No registered users and 7 guests