Keyboard volume buttons not working in Gloria.

Forum rules
Before you post please read this

Keyboard volume buttons not working in Gloria.

Postby alexian on Mon Aug 10, 2009 4:06 pm

OK -- I've messed with my system some, and I'm trying to get it back to "normal" without doing a complete reload.

Primarily, I'd be interested in knowing if there's some software package that could be reinstalled to convince my keyboard volume +/-/mute buttons to work again. I remember them working briefly, including showing a transparent splash screen showing what was happening to the volume. But I'm not sure when I saw that -- post install of Linux Mint XFCE Elyssa, or after successful upgrade to Gloria (I never was able to get a GUI to work as I passed through Felicia), or maybe it was just as I was playing with live CD's.

I now have a Gloria install disk, but I'm saving that for a last resort. Most of my current configuration is working fine, so I don't want to play too much with it. Sound is working, but only when controlled through the mixers. I'd like to have the hardware buttons work for when games have taken over full-screen mode, and I can't readily get to the mixers.

Thanks in advance!
alexian
Level 1
Level 1
 
Posts: 7
Joined: Tue Feb 03, 2009 10:47 am

Linux Mint is funded by ads and donations.
 

Re: Keyboard volume buttons not working in Gloria.

Postby lvleph on Mon Aug 10, 2009 5:23 pm

You could set them in keyboard shortcuts under the control center.
lvleph
 

Re: Keyboard volume buttons not working in Gloria.

Postby alexian on Tue Aug 11, 2009 10:48 am

I found the application shortcuts (control center -- isn't that a gnome thing? I thought this was the XFCE forum), and tried to modify those. Not having much luck. Which has started me thinking along another possibility.

Whether control center (gnome) or settings -> keyboard -> Application Shortcuts (XFCE) or whatever in KDE -- aren't all of these user-level settings? That would mean, a) that I'd have to change the settings for each individual user (if I can ever find the right settings), and b) that such settings would *not* work when no users are signed in (say, in gdm).

So, where do the global settings get set up for the entire computer? How do I tie my keyboard volume buttons to the volume settings for *all* users, or even in places where user has not been established?
alexian
Level 1
Level 1
 
Posts: 7
Joined: Tue Feb 03, 2009 10:47 am

Re: Keyboard volume buttons not working in Gloria.

Postby alexian on Wed Aug 12, 2009 6:10 am

Figured out how to get these set for one user, after actually reading the amixer man page. Once again, simply reading the documentation comes in useful.

For the sake of others, here's what I did:
Go to a terminal and type 'amixer scontrols'. This will list the simple controls available to you. Either have a song playing or watch your volume meter when testing these amixer commands for yourself:

For sound up: amixer set {Your simple control} 5%+ -q (notice the + sign)
For sound down: amixer set {Your simple control} 5%- -q (notice the - sign)
For mute: amixer set {Your simple control} toggle -q

If anyone can advise how to set these commands globally for the computer, I'd love to hear. Currently, I'm using Settings -> Keyboard -> Application Shortcuts, but I would think this only works at the user level. How do we set these for all users on the computer?
alexian
Level 1
Level 1
 
Posts: 7
Joined: Tue Feb 03, 2009 10:47 am

Re: Keyboard volume buttons not working in Gloria.

Postby merlwiz79 on Thu Aug 13, 2009 12:21 am

They should work.
I have test it on my desktop and 2 laptops and they all worked.
Do you have aumix installed?
That's how I set it up.
It's Settings --> Keyboard --> Application Shortcuts.
It should show the shortcuts for the aumix commands.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Keyboard volume buttons not working in Gloria.

Postby Gumbotron on Thu Aug 13, 2009 6:03 am

the keyboard shortcut commands i used where:

DECREASE: amixer sset Master 5%-
RAISE: amixer sset Master 5%+
MUTE: amixer sset Master toggle
User avatar
Gumbotron
Level 1
Level 1
 
Posts: 34
Joined: Thu Apr 09, 2009 2:00 am

Re: Keyboard volume buttons not working in Gloria.

Postby alexian on Fri Aug 14, 2009 10:40 am

As indicated, I'm able to, on a user-by-user level, establish the amixer commands (using PCM, not Master). The question has now migrated to -- how do we set this once for the entire system, instead of on a user-by-user level? The Settings -> Keyboard -> Application Shortcuts method is specific to the user currently logged on. How do we change the settings for *all* users of the computer, so I don't have to individually reset these settings?
alexian
Level 1
Level 1
 
Posts: 7
Joined: Tue Feb 03, 2009 10:47 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 5 guests