Compiz problem with integrated graphics

Forum rules
Before you post please read this

Compiz problem with integrated graphics

Postby Mazai on Mon Jan 18, 2010 7:20 am

Hi all! :D
Pls help:
Videocard: Intel 82865G (have 32Mb)
Problem with Compiz.
Check system:
Error: Software Rasterizer in use

Will work or all bad?
User avatar
Mazai
Level 1
Level 1
 
Posts: 7
Joined: Thu Oct 29, 2009 5:00 am

Linux Mint is funded by ads and donations.
 

Re: Compiz problem with integrated graphics

Postby MaddogF16 on Mon Jan 18, 2010 9:21 am

What's the exact problem for compiz? Just that error?
MaddogF16
Level 5
Level 5
 
Posts: 762
Joined: Tue Jun 16, 2009 10:47 am

Re: Compiz problem with integrated graphics

Postby Mazai on Mon Jan 18, 2010 9:46 am

I want enable compiz!
User avatar
Mazai
Level 1
Level 1
 
Posts: 7
Joined: Thu Oct 29, 2009 5:00 am

Re: Compiz problem with integrated graphics

Postby richyrich on Mon Jan 18, 2010 10:11 am

Well, :( . . I don't think you are going to like my answer, so open a terminal and type compiz-check (enter). You will see that one of the checks fail! And that it is using "Software Rasterizer" or some such. Translation: Compiz 3D effects require OpenGL, Intel graphics only have a basic software subset of OpenGL, and do NOT have Hardware Rendering for 3D effects.
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Compiz problem with integrated graphics

Postby Mazai on Mon Jan 18, 2010 11:00 am

Will work or all bad?

...
Thx for help.
User avatar
Mazai
Level 1
Level 1
 
Posts: 7
Joined: Thu Oct 29, 2009 5:00 am

Re: Compiz problem with integrated graphics

Postby Joylove on Mon Mar 08, 2010 3:39 pm

Have a same GPU as OP. Had to disable compiz as performance hits occur when it was enabled.
Joylove
Level 3
Level 3
 
Posts: 130
Joined: Wed Feb 10, 2010 12:33 pm

Re: Compiz problem with integrated graphics

Postby glas on Tue Apr 06, 2010 3:35 pm

I've just installed Mint 8 Xfce CE on this box (AMD Sempron 3000+ / 512 Ram)

I have installed the Nvidia driver but can't get the Compiz effects (such as wobbly windows and 3D cube) to work.

It's not a problem with the hardware because I have Mint 8 Gnome on another partition and compiz-fusion works fine.

Here's the terminal output of compiz-check:

Distribution: Linux Mint 8
http://www.linuxmint.com/rel_helena_xfce.php
Desktop environment: Xfce
Graphics chip: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
Driver in use: nvidia
Rendering method: Nvidia

Checking if it's possible to run Compiz on your system...

Checking for texture_from_pixmap... [ OK ]
Checking for non power of two support... [ OK ]
Checking for composite extension... [ OK ]
Checking for FBConfig... [ OK ]
Checking for hardware/setup problems... [ OK ]

Everything seems fine, except the fact that no effects are apparent even after rebooting.

Any ideas?
User avatar
glas
Level 2
Level 2
 
Posts: 54
Joined: Tue Jan 09, 2007 8:13 am
Location: Cymru/Pays de Galles/Wales

Re: Compiz problem with integrated graphics

Postby user1238 on Wed Apr 07, 2010 4:27 pm

resetting video, from http://www.ubuntugeek.com/ubuntu-tiphow ... buntu.html (edited for punctuation and grammar):
"The X.Org Server (officially the X.Org Foundation Open Source Public Implementation of X11) is the X server in the official reference implementation of the X Window System.

This tutorial will explain how to remove, install and reconfigure xorg, without reinstalling ubuntu. This is very useful if you mess up with your xorg file.

Open terminal and run these commands:
Remove existing xorg using the following command

sudo apt-get remove --purge xserver-xorg

Install xorg using the following command

sudo apt-get install xserver-xorg

Reconfigure xorg using the following command

sudo dpkg-reconfigure xserver-xorg

I hope this helps some users to fix problems with xorg."
If this does not fix effects on 1 install but they still work on the other (same HW), then u've got linux voodoo :?:
user1238
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 07, 2010 4:17 pm
Location: Pacifistan

Re: Compiz problem with integrated graphics

Postby glas on Tue Apr 13, 2010 9:22 am

Thanks user1238 - your method totally screwed my Xorg files. Couldn't fix it even in recovery mode. Needed a total new install just to get a gui back.

Perhaps copying and pasting untested ubuntu geek ideas on a Linux Mint forum isn't such a smart idea.
User avatar
glas
Level 2
Level 2
 
Posts: 54
Joined: Tue Jan 09, 2007 8:13 am
Location: Cymru/Pays de Galles/Wales

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 2 guests