Madwifi and Atheros

Forum rules
Before you post please read this

Madwifi and Atheros

Postby Blazedforever on Mon Jan 21, 2008 2:59 am

Hey guys i was wondering if you could walk me through the installation and configuration of madwifi for my atheros wifi card installed in my acer aspire 3050 laptop. i can't seem to get iwconfig to display my card. i used lspci and got the following information for the device, i just am not sure how to use it:
02:00:0 168c:001c

i looked in the restricted drivers manager and it says atheros hardware acces layer is in use. though no hardware is detected when i run ndiswrapper there is a long stall and the application does not load.

help would be appreciated!

//Edit by husse/
Don't add your post to a topic with solved in the subject!//
Blazedforever
Level 1
Level 1
 
Posts: 4
Joined: Fri Jan 18, 2008 2:27 pm

Linux Mint is funded by ads and donations.
 

Re: Madwifi and Atheros

Postby Chi on Mon Jan 21, 2008 5:09 pm

I had success with Atheros (main LinuxMint though should be similar) by turning off the Restrcited Hardware and default module then using ndiswrapper.

Previous post here:
http://www.linuxmint.com/forum/viewtopic.php?f=90&t=7517&p=52772&hilit=atheros#p52772
Time is what keeps everything from happening all at once.
User avatar
Chi
Level 2
Level 2
 
Posts: 79
Joined: Wed Jan 09, 2008 5:02 am
Location: New Zealand

Re: Madwifi and Atheros

Postby roadrash on Sun Feb 03, 2008 10:48 pm

If your acer laptop uses the latest Atheros AR5007EG wireless chip you might want to follow this tutorial. it got my laptop working.

http://www.ubuntugeek.com/atheros-5007eg-with-madwifi-on-i386-platform.html#more-394
User avatar
roadrash
Level 2
Level 2
 
Posts: 77
Joined: Tue Nov 21, 2006 4:11 pm
Location: Huntingdon U.K.

Re: Madwifi and Atheros

Postby palmitobom on Mon Feb 04, 2008 12:45 am

Wow, this last one worked great for my Toshiba A215 with that Atheros PCI card on Daryna KDE CE) , I had tried all the other ndiswrapper fixes and given up, this one worked like a charm though I had to remove the ath-pci off the blacklist first.
User avatar
palmitobom
Level 1
Level 1
 
Posts: 5
Joined: Tue Nov 13, 2007 10:06 pm

Re: Madwifi and Atheros

Postby roadrash on Mon Feb 04, 2008 5:39 am

Yes you have to remove ath_pci from the blacklist if have previously tried to use ndiswrapper to install a windows driver because this isn't a windows driver , i'ts a true native LINUX driver in a very new MadWiFi driver package. Glad it has worked for you.
User avatar
roadrash
Level 2
Level 2
 
Posts: 77
Joined: Tue Nov 21, 2006 4:11 pm
Location: Huntingdon U.K.


Return to XFCE

Who is online

Users browsing this forum: No registered users and 4 guests