Home folder open on start-up

Forum rules
Before you post please read this

Home folder open on start-up

Postby norm.h on Thu Mar 15, 2012 10:07 am

Is there any way I can prevent my Home Folder from automatically opening each time I start up?
I'm running Thunar, in xfce4,under Mint12.
norm.h
Level 4
Level 4
 
Posts: 230
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Linux Mint is funded by ads and donations.
 

Re: Home folder open on start-up

Postby jjaythomas on Thu Mar 15, 2012 10:18 am

Probally...

check if in autostarted program (settings->session and startup) if on 'Application Autostart' tab make sure deleated or just uncheck it.
IF Not
chech in session tab, if running it is quit program and resave session.

If these don"t work it's probally a quirk of running XFCE under Gnome sys (make sure running Thunar not Nautilus?)

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Home folder open on start-up

Postby norm.h on Thu Mar 15, 2012 10:50 am

Tried your suggestions, but nothing worked, Home Folder still opens on start-up.
I'm definitely running Thunar.
Thanks anyway.
norm.h
Level 4
Level 4
 
Posts: 230
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Home folder open on start-up

Postby jjaythomas on Thu Mar 15, 2012 4:31 pm

Im not sure then...

have you manually closed the thunar home file and then resaved session? Sometimes running apps don't show in session list even if running. Check if process runing in ' system->system monitor' if is kill and try saving session again... ?Maybe might work?

P.S.. I think LMint 12 run nautilus as a sys startup for Gnome, It may be tring to do that with thunar but showing it/not have running in background as usual? May need to change a sys autostart file?
I don't use Gnome much so can't say "where/what/or even if their is such a file.

J.Jay
Last edited by jjaythomas on Thu Mar 15, 2012 4:39 pm, edited 1 time in total.
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Home folder open on start-up

Postby sagirfahmid3 on Thu Mar 15, 2012 4:35 pm

Ok I think I know what happened.

You had Thunar open at a point, then you decided to logout (or end session), but, you forgot to UNCHECK that box that says "save running applications as session" or something similar to that. Do the same thing, except, this time have no applications open and click on the box that says "save running applications" and hit logout--that should stop it.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: Home folder open on start-up

Postby hattpa on Sat May 05, 2012 2:47 am

I've just had the same issue, running Mint12 but with XFCE installed and using as default desktop.

I installed BleachBit, ran it both as root, then as normal user. In each case selected everything that didn't give a warning of taking a long time.

Re-started and irritation has gone away.
hattpa
Level 1
Level 1
 
Posts: 11
Joined: Sat May 05, 2012 2:42 am

Re: Home folder open on start-up

Postby hattpa on Sat May 05, 2012 9:24 am

Aaarrrrrggghhhhh. Had re-started a couple of times and was OK. Switched off. Couple of hours later switched back on.....problem back again.

Anyone have any ideas how to correct this permanently?
hattpa
Level 1
Level 1
 
Posts: 11
Joined: Sat May 05, 2012 2:42 am

Re: Home folder open on start-up

Postby jjaythomas on Sat May 05, 2012 10:45 am

That's the problem with installing a DE over something else not designed for (I constantly do it anyways :) ). Their may be tweaks/hacks to better the default DE in the system But may have adverse/unintended results in other DE's. (Hence the problems nautilus ect. have on XFCE in both LMDE and LMint 12 when XFCE overlayed onto.

The only solution (I can think of) is to make sure not running thunar and *nautilus also :wink: *(check in task manager) kill if are, and resave session, then make sure not restarted in auto start and unclick save session in log-out screen.

P.S. if not going to use Gnome also may want to get rid of nautilus (purge) in synaptic.
If none of that works I'm at out of ammo (and I put (at least try :( to put XFCE on everything)

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 4 guests